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Objectives

The objective of this training is to provide the user with information on 

the purpose and background of SNAP/RADTRAD. The training will 

also teach the users how to build and run simple models for accident 

dose analysis as well as show the user how to read and plot output 

information from SNAP/RADTRAD.
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First Day Overview

• SNAP/RADTRAD Overview

• Using Model Editor with SNAP/RADTRAD

• Output File Description

• Plotting with AptPlot

• Exercise 1: Fuel Handling Accident

• Governing Equations

• Exercise 2: Control Room

• Source Term Models

• Exercise 3: Rod Ejection Accident 
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SNAP/RADTRAD Overview

• Purpose of SNAP/RADTRAD is to determine the dose from a 

release of radionuclides during a design basis accident to the 

following locations:

• Exclusion Area Boundary (EAB)

• Low Population Zone (LPZ)

• Control Room (or Emergency Offsite Facility)

• Focus of SNAP/RADTRAD is dose analysis for licensing 

applications to show compliance with nuclear plant siting and 

control room dose limits for various LOCA and non-LOCA 

accidents. 
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SNAP/RADTRAD Overview

• Symbolic Nuclear Analysis Package – suite of applications 

that interface with nuclear analysis/safety computer codes:

• Developed by ISL, Inc.

• Initial focus was the thermal hydraulics codes (TRACE, 

RELAP5)

• Later, other codes added (MELCOR, FRAPTRAN, FRAPCON, 

etc.)

• SNAP provides a standard graphical user interface to simplify the 

development of models for the supported analytical codes.  SNAP is 

used to:

• Construct, maintain and document models

• Run simulations and analyze results
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SNAP/RADTRAD Overview

The primary apps in SNAP for RADTRAD analysis are:

• Model Editor – primary interface for developing models.

• Configuration Tool – used to configure SNAP to be able to 

run analysis applications.

• Job Status Tool – used to check simulation progress and view 

results.

• Calculation Server – operates in the background and 

performs code execution.  Allows concurrent jobs on multicore 

processors.

SNAP is developed in JAVA and is platform-independent.  

• Uses a plug-in architecture to make it possible to add support 

for new engineering analysis codes.
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SNAP/RADTRAD Overview

• SNAP/RADTRAD has two parts:

• The SNAP plugin for RADTRAD is intended as the primary model building 

interface for RADTRAD models.

• A RADTRAD ‘executable’ for running models. The ‘executable’ is a jar file 

that requires a java virtual machine (jvm) to be installed to execute. The jvm

is installed with SNAP. The RADTRAD executable also depends on the java 

castor library which is provided with the RADTRAD jar file.

• Documentation is available on SNAP/RADTRAD and the RADTRAD analytical 

code from the RAMP website.  Link is:

https://ramp.nrc-gateway.gov/codes/snap-radtrad/docs

https://ramp.nrc-gateway.gov/codes/snap-radtrad/docs
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Using Model Editor with SNAP/RADTRAD

To start the Model Editor, click on 

• Start → All Programs → SNAP → Model Editor
• Alternately, you can type “Model Editor” in the windows search box and select 

it.

A “splash screen” will appear with NRC credit, code version, etc.  Then the Model 

Editor opens.
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Using Model Editor with SNAP/RADTRAD

• Five options available as shown on 

the Welcome Screenshot – typical of 

Windows programs

• Most of the time, users will create a 

new model, open an existing model or 

import an existing model from a .psx 

file.  

• You can use the welcome screen to do 

any of the above, or after the welcome 

screen is closed, use the ‘File’ menu.

• File → New to create a new 

model

• File → Open to open a 

previously saved model

• File → Import to import a model
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Using Model Editor with SNAP/RADTRAD

We’ll start by opening a previously created model Test23.  The test23.med
file is found in Samples/Test23.  Steps are as follow:

1. Open the Model Editor as before.

2. Select Continue >> under Open a Model Document on the 

welcome screen.  Navigate to the Test23 subdirectory under the 

Samples directory.

3. Select Test23.med and click Open. The RADTRAD model will 

then be displayed in the Model Editor.
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Using Model Editor with SNAP/RADTRAD

• A useful feature is the Model Notebook feature.  This feature generates an initial Model Notebook 

that you can modify.

• To generate an initial Model Notebook, right-click on the “black bar” in the Navigator Window, 

select Export → Model Notebook.  Click on Export and provide a filename in the File Name textbox. 

A notebook is generated in .docx (Microsoft Word) or .odt (Open Office document) format

• An odt formatted file can be read and edited using Microsoft Word.

• You can append the Test23NRC.out file to the initial notebook to get an editable notebook that 

you can modify as needed.

• If you prefer, you can select File → Export → Model Notebook to generate a model notebook.
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Using Model Editor with SNAP/RADTRAD

• RADTRAD Data is built into the Model Editor

• Dose conversion factors (FGR 11, 12 based on ICRP 30)

• A comprehensive list of nuclides based on International Commission 

on Radiological Protections (ICRP) Report 38.

• Core inventory data (RADTRAD 3.03 for PWR, BWR)

• Release fractions and release timings (Regulatory Guide 1.183)

• Iodine chemical form fractions (Regulatory Guide 1.183, 1.195)

• Data file export – above data can be exported from SNAP/RADTRAD by 

selecting File → Export → RADTRAD ASCII and specifying a 

CaseName.  CaseName is Test23 in this situation.

• Import of RADTRAD 3.03 models also available.  RADTRAD 3.03 input 

sample from report SAND2008-6601 (Appendix B).
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Using Model Editor with SNAP/RADTRAD

Name Description

CaseName.psx Plant information file in ASCII (XML) format.  

Note that the suffix was added when the export 

was done.

CaseName.dfx Dose conversion factors file in ASCII (XML) 

format.

CaseName.nix Nuclide data file in ASCII format for each source 

(x is source number).

CaseName_x.srx Release fraction file in ASCII format for each 

source (x is source number).

CaseName_X.icx Nuclide inventory file in ASCII (XML) format.

• The following files are exported:
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Using Model Editor with SNAP/RADTRAD

Lock 

Navigator
Window

View Window

Properties 

Window Message Window

View Tabs
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Using Model Editor with SNAP/RADTRAD

• Click on the Test23 Model tab to see model nodalization. Click on 

RADTRAD Stream tab to see the job stream representation.

• Click on the Lock icon (     ) to unlock the model. This allows items to be 

moved around in the view or new components to be added. Note the 

change in the toolbar.

• Click on Tools → Check Model to perform an input check on the model.  

Note the message

Note: Model check complete.  No errors found
in the Messages Window at the bottom of the screen.

• Click on Expand icon (   ) icon to expand each node in the Model 

Navigator Window to see the input fields for SNAP/RADTRAD.
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Component Navigator Window

Current Model

Categories

Components

Connections

Job Streams

2D Views

Using Model Editor with SNAP/RADTRAD
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Using Model Editor with SNAP/RADTRAD

The Property Window associated with the Navigator Model Options node is 

where the following model options are specified:

• Title/Description

• Plant Power Level (MW)

• Decay Options: 

• no decay, 

• decay only, 

• decay and daughter production

• Onset of Gap Release (hrs) – typically 0.

• Start of Accident (hrs) – typically 0.

• Duration of Accident (hrs) – typically 720 

hrs

• Dose Conversion Factors: FGR 11&12 or 

User-Specified

• Dose Conversions: View FGR default 

conversion factors or specify alternate DCFs.

• Time Step Algorithm: 

• Adaptive

• Default

• Default with error calculation.

• Output Parameters

• Dose/Activity Output Units

• Activity/Dose Units (Ci, Rem)

• Si Activity/Dose Units (MBq, mSv)

• Echo Model Definition (T, F)

• Show event results (T, F)
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Using Model Editor with SNAP/RADTRAD

• Model Options - continued

• NRC Output:

• Dose results listed by nuclide for 

various dose components.

• Formatted output (page layout) to 

allow insertion into a Word 

document.

• Lines per page can be set as well as 

a tolerance for displaying output.

• Diagnostic Flags:

• Used for debugging
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Using Model Editor with SNAP/RADTRAD

• Click on the Expand node icon (    ) next 

to Compartments, then click on 

Compartment 1.  

• Note that the compartment 1 input 

appears in the Properties Window

• To switch units to English, right-click on 

the black title bar atop the Navigator 

Window. This is shown in a red box in 

the image to the left. Select Engineering 

Units → British to change the units. 

• Experiment with other input groups –

approach is the same – we’ll get to 

specifying input later.
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Using Model Editor with SNAP/RADTRAD

Compartment Types in RADTRAD that are principally used:

1. Normal compartment:

• Used to model plant structures (e.g., containment).

• Radionuclides can be released to the compartment, transferred 

to/from other compartments and removed (filtered, sprays, natural 

deposition).

• Various removal processes models available for normal (other) 

compartments.

2. Control Room Dose compartments:

• Used to model control rooms.

• Control room intake and exhaust is from the environment (release at 

intakes is X/Q dependent).

• Can model filtration in control room (both direct and recirculation 

filters).
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Using Model Editor with SNAP/RADTRAD

3. Environment Compartment

• Compartment used to model the Exclusion Area Boundary (EAB) and Low Population Zone 

(LPZ) doses.  

• Control room HVAC intake draws from the environment compartment.

• Coupling with the EAB and LPZ locations as well as the control room intake is through X/Q 

values. 

4. Normal dose compartment – used to compute the dose at an arbitrary dose point (e.g., in 

containment).
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Using Model Editor with SNAP/RADTRAD

Compartment

Source

Filter Indicator

Spray Indicator
Flow Pathway Connection

Natural Deposition Indicator
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Using Model Editor with SNAP/RADTRAD

• Simulation execution depends on the Job Stream.  Job streams are used to define 

an execution workflow (i.e., specify the execution tasks to perform). For example, 

the workflow may include plot generation. A default job stream is automatically 

set up by the Model Editor for SNAP/RADTRAD.

• The default job stream for RADTRAD passes input from the Model Editor to the 

RADTRAD analytical code.  Plot file results are passed from RADTRAD  

analytical code output to APTPlot input.

SNAP RADTRAD model to 

RADTRAD analytical code.
RADTRAD analytical code

plot file to AptPlot.
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Using Model Editor with SNAP/RADTRAD

• Job Stream Check - Job stream settings can 

be checked in the Model Editor.  In the case 

of Test23, expand the Job Stream node,  

select Test23 and right-click, then select 

Check Stream.  An Error Report window 

will appear.

• Common error is to forget to set the Root 

Folder, which, in combination with the 

Relative Location is where the output files 

are written.

• To set the Root Folder, click on     .  An 

Edit Calculation Server Root Folders

window will appear.  Click on the New (    ) 

icon and  navigate to the desired location in 

the Select Folder Location window.  A new 

folder can be created by clicking the       icon 

in the popup file explorer window. The Root 

Folder name will change to the last folder 

name in the selected directory path.
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Using Model Editor with SNAP/RADTRAD

• Relative location can also be set.  It is 

helpful to set this to a name that helps 

you organize your simulations. 

• To change the name, highlight the 

Relative Location Name and type in a 

new name (e.g., Test23).

• Note that the path separator (/) is 

automatically appended, so no need to 

add it at the end of the folder name.

• Run a job stream check to determine if 

everything is OK.  Expand the Job 

Stream node (       ), then right-click on 

the job stream name Test23 and select 

Check Stream.  An Error Report window 

will appear displaying the error status.
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Using Model Editor with SNAP/RADTRAD

• Before we continue, confirm the 

link to the analytical code                  

by navigating to 

Tools → Configuration Tool

and then expand the Applications

node by clicking on the      icon. 

Then click on RADTRAD.  

• This link is to the RADTRAD 

analytical code.

• Note that this location is 

installation-dependent.
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Using Model Editor with SNAP/RADTRAD

• To run the Test23 case, click on Tools → Submit Job.  A Submit Job Stream 

window appears.  

• Click OK and a confirmatory Submit Stream window appears.  

• Click OK and the run will start.  The SNAP Job Status window will appear.  In 

this case, the run is completed.
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Using Model Editor with SNAP/RADTRAD

• Note the relationship between the RADTRAD 

stream, the Navigator Window and the Job 

Status Window.

• Two Job Stream steps
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Output File Description

• Output Review – Click on the RADTRAD Job Type in the Job Status Window, then click on 

the File Viewer (     ) icon and then select Text Files.  A list of files will appear.  Select the 

file of interest to open the file in the File Viewer to review the file data (reminiscent of 

V3.03)

• Key output files are listed below (there are others as well).

Name Description

radtrad.dfx dose conversion factors file in xml format (input)

radtrad.nix nuclide information file in xml format (input)

radtrad.plt plot file read by AptPlot plotting program (output)

radtrad.psx plant information file in xml format (input)

radtrad_1.icx, 

radtrad_2.icx, etc.

initial inventory file for each source (input)

radtrad_1.srx, 

radtrad_2.srx, etc.

source term file for each source (input)

radtrad.out RADTRAD output in original output format (output)

radtradNRC.out RADTRAD output in NRC output format (output)

radtrad.screen RADTRAD screen output file (output)



30

Output File Description

• radtrad.out – original output format in V3.03/3.10 format.  Major sections are:

• Input echo – provides an edited input summary of plant description (model), scenario 

(radionuclide source term/DCF) information, compartment/pathway data, X/Q, etc. 

• Breakdown of dose results at various time points generally selected by changes in events (e.g., 

time at which flow rate changes, time at which X/Q changes).  Activity balance information also 

given.

• I-131 Summary, Cumulative Dose Results, Worst Two-Hour Doses and Final Doses at the end 

of the file.  

• Contents can be controlled from Model Options → Output Parameters in the Model Editor. 

Output units in cgs (Rem/Ci) or SI units (mSv, MBq) available.
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Output File Description

• radtradNRC.out – provides time-dependent summary of dose by nuclide 

• Input echo – provides an edited input summary of plant description (model), scenario (radionuclide source 

term/DCF) information, compartment/pathway data, X/Q, etc. 

• Output – activity distribution, cumulative and dose difference (delta-dose) for each dose component 

(inhalation, cloudshine, skin, thyroid, and TEDE).  Output units in cgs (Rem/Ci) or SI units (mSv, MBq) 

available (under Model Options → Output Parameters).

• I-131 Summary, Cumulative Dose Results, Worst Two-Hour Doses and Final Doses at the end of the file.  

• Contents can be controlled from Model Options → NRC Output Flags in the Model Editor.  

• Note that this file is designed to be imported into a word processor (page breaks, etc.).  Lines/page and 

output cutoff (so that the file doesn’t get too large) can be set in the Model Editor.

• radtrad.screen – summarizes time step information.
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Plotting with AptPlot

• Note that context of the job stream step affects the output available for display through the File 

Viewer.

• Click on Test23 – only the stream log is available for display.

• Click on RADTRAD – all files listed on the previous chart are available for display.  Time step 

history is displayed in the window.

• To display a plot, then click on the File Viewer (     ) icon, then click on Plot Files and select “plot –

radtrad.plt.”  AptPlot will open.  Alternately, click on the (     ) icon and AptPlot will open.

• In the Select EXTDATA Channels window, scroll down to desired results to be plotted.  For 

example, scroll to “ControlRoom.tede.”  A plot of the TEDE dose for the control room will appear.

• If you don’t want to scroll, type “ControlRoom.tede” in the Filter text box and then click on 

Control.Room.tede at the top of the data channel window.
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Plotting with AptPlot

• Wildcards can be used to identify the results of interest in the Filter text box. Ex:

• L*P*Z* - isolates the LPZ dose results for all dose categories.

• L*P*Z*th* - isolates the LPZ dose results for the thyroid dose for all nuclides 

and the total dose (LowPopulationZone.thyroid).

• Note that case counts.

• Click on the Clear Sets button to clear the plot.

• To change the units of the x-axis from seconds to hours, navigate to the Time 

unit's drop-down menu and pick hours.

• If you accidently close the “Select EXTDATA Channels” window, navigate to 

Window → Select EXTDATA Channels to reopen the window.

• Suppose you want to plot the Control Room dose for all dose categories.  

Available dose categories are whole body, cloudshine, skin, TEDE, and thyroid.  

Type in the desired result in the Filter window, then pick the result from the 

Channels window and finally click on the Plot button to add the data plot.

- C*R*cloudshine – cloudshine dose          - C*R* - inhalation

- C*R*skin – skin dose                                - C*R*tede – TEDE dose

- C*R*thyroid – thyroid dose
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Plotting with AptPlot

• Note that as each data set is added to the plot, AptPlot adds it to the Data sets 

window (number in brackets are x-y array dimensions).

• G0.S0[2][1664] – control room cloudshine dose

• G0.S1[2][1664] – control room inhalation dose

• etc.

• Double-click on the desired dataset to see the actual data.  Note that you can cut 

and paste the data into a spreadsheet.  You can also export the date but cut and 

paste works better.

• Suppose you close the Select EXTDATA Channels window.  Navigate to  

Window → Select EXTDATA Channels window to reopen.

• The plotted data is hard to see and distinguish.  Let’s plot all of the control room 

dose components as illustrated above and make some changes:

• Navigate to Plot → Set Appearance to change the appearance of each line.

• Main tab – select a data set and then go to Line properties and change the color of 

the line to black.  Other line-formatting changes are available.  Note that the 

datasets can be grouped.

• Main tab – select a data set and then a symbol for each dataset under Symbol 

Properties (one at a time).  Click the Apply button after each selection.
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Plotting with AptPlot

• More changes:

• Navigate to Plot → Set Appearance to change the appearance of each line. 

Click on the symbols tab and then input a value for Symbol skip for each line 

– use a value of 100 (need to do them individually).  Click Apply after each 

selection.  

• Change the scale of the y-axis to logarithmic to make plots easier to read. 

Navigate to Plot → Axis Properties. Change the Edit value from X axis to Y 

axis, then change the Scale from Normal to Logarithmic.  Then click Apply.

• Legend box is a little big – change the font size by navigating to Plot → 
Graph appearance.  

• Pick the Legends tab and change the font size from 100 to 75 using the 

slider.  Click on the left or right side of the slider for finer control.  Then 

click Apply.

• To move the legend box, pick the Leg. Box tab and change the Location 

to x=0.75 and y=0.81 or other suitable values.

• Titles and subtitles can be added under the Main tab.
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Plotting with AptPlot
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Plotting with AptPlot

• To save plot, navigate to File → Save and select a suitable location to save 

the plot.  The plot is saved in AptPlot (apf) format.

• Saved plotfile can be used as a template for plotting other datasets –

avoids making many of the formatting settings.  Ex.  Plot the LPZ dose 

results for Test23.

• Open a new AptPlot session from the Model Editor.  From the AptPlot 

window, navigate to the location of the copied .apf file.  Note that the control 

room dose results appear.

• Clear the sets from the Select EXTDATS Channels window.  Switch Time 

units from seconds to hours.

• Plot the LPZ dose results as outlined above.

• Fill in the titles and make other adjustments as desired.

• Save plot under a new filename.

• Can also associate the .apf file type to AptPlot through Windows.

• Many other features are available in AptPlot.  


