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ABSTRACT 

Computational phantoms with articulated arms and legs have been developed to enable radiation 
dose estimation for male and female receptors in different postures. Using a user-friendly 
graphical user interface (GUI), the PIMAL (Phantom wIth Moving Arms and Legs) software can be 
employed to adjust the posture of a phantom, generate a corresponding input file for the Monte 
Carlo N-Particle (MCNP®) radiation transport code, and perform the radiation transport 
simulations for the dose calculations in MCNP®. The MCNP® code can be run natively from the 
PIMAL interface or externally in the MCNP® command prompt via the generated MCNP® PIMAL 
input file.  

Before PIMAL 4.0, previous versions consisted of a single (hermaphrodite) phantom model. 
PIMAL 4.1.0 now includes a separate male and female stylized phantom with articulated limbs, in 
addition to housing the most recent International Commission on Radiological Protection (ICRP) 
Publication 110 reference adult male and female voxel phantoms (no articulation). Both internal 
and external radionuclide sources can be simulated in PIMAL via a dropdown menu in the GUI. 
For external sources, the user can select the ICRP’s standard external exposure geometries (AP, 
PA, LLAT, RLAT, or ISO), in addition to a point source, from the menu options.  

PIMAL 4.1.0 contains an improved user interface. The design of the sliders to control the 
articulation of the limbs is connected with the textbox input, with the bounding conditions of limb 
articulation included. Source modes (i.e., photon, neutron) for Monte Carlo simulation have been 
pre-programmed with the source input (photon, neutron, x-ray, radionuclide) to simplify the 
definition of the radiation source. 

This user manual describes the updates to PIMAL 4.1.0, in addition to aiding the user in installing 
PIMAL, exploring the geometry articulation and visualization capabilities, and radiation source 
definitions, in addition to providing sample tutorials for the PIMAL user for estimating organ doses.
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1    INTRODUCTION 

Computational models of the human anthropomorphic phantom have undergone progressive 
evolution since their initial development in the 1970s [1]. Computational phantoms employed by 
the Nuclear Regulatory Commission (NRC) were largely based on a model published in 1974, 
which did not account for select organs (e.g., neck, esophagus) and tissues. These deficiencies 
were compounded by inaccurate organ placement within the body (e.g., thyroid). Most notably, all 
the computational phantoms were assumed to be in the vertical-upright position, which continues 
to be a trend in the development of current computational phantoms. To assess the radiation dose 
in non-standard positions (e.g., occupational exposure or public exposure in a radiologically 
significant event), the mathematical phantom has been revised to enable articulation of arms and 
legs. The revised phantom is called PIMAL: Phantom wIth Moving Arms and Legs [2], [3].  

In the initial phase of development in 2007, the objectives for developing PIMAL were three-fold: 
(1) update the MIRD-5 mathematical phantom model that was being used by the NRC staff to
improve the assessment of dose for realistic exposure configurations; (2) perform benchmark
computations against International Commission on Radiation Protection (ICRP) Publication 74
values [4] and investigate the reasons behind any identified discrepancies; and (3) develop an
interface to assist the user (or analyst) in using the updated phantom model in dose assessment
activities.

The organs and compositions of anthropomorphic phantom models were updated, and the 
revised computational phantom model was adopted for radiation transport codes, notably the 
Monte Carlo N-Particle (MCNP®) code [5]. Computationally generated results were compared 
against values reported by the ICRP in Publication 74 [4], with identified discrepancies being 
resolved. Although the original PIMAL phantom was developed as an adult hermaphrodite model, 
with both male and female gender-specific organs, the latest revision of PIMAL separates the 
male and female option for calculating doses. Furthermore, extensive benchmarking, in addition to 
sensitivity computations, was performed to determine the sensitivity of the organ doses for certain 
parameters, including composition and cross sections used in the simulations [2]. Finally, a 
graphical user interface (GUI) has been developed to assist the analyst with input preparation and 
output manipulation [6]. The GUI can be used to visualize the positioning of the arms and legs as 
the desired posture is achieved to generate the input file, conduct radiation transport simulations, 
and extract the organ dose values from the MCNP® output file. A phantom model was included in 
the GUI, thus enabling visualization of the arms and legs as they are positioned using slider bars. 
Once the user decides on the posture, an MCNP® input file can be generated and the radiation 
transport simulations using MCNP® can be performed through the GUI. Furthermore, the 
computed organ dose values can be extracted (from the MCNP® output file), displayed, and 
exported as an ASCII file. 
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1.1  Manual Outline 

This user manual describes the updates to PIMAL 4.1.0, in addition to aiding the user in installing 
PIMAL, exploring the geometry articulation and visualization capabilities, and radiation source 
definitions, in addition to providing sample tutorials for the PIMAL user for estimating organ doses. 

The organization of this manual is as follows: 

• Section 2 outlines the updates made to PIMAL version 4.0 and version 4.1.0
• Section 3 details the installation and setup procedures for PIMAL
• Section 4 walks through PIMAL functionality
• Section 5 details the generation of MCNP® input
• Section 6 demonstrates how to run MCNP® with PIMAL
• Section 7 outlines a few examples and tutorials:

o Female Extension Pose (AP Source)  - Beginner User
o Male Voxel Phantom (AmBe Point Source) - Intermediate User
o Water Submersion - Advanced User

• Appendix A provides a detailed explanation of the PIMAL-generated MCNP® input decks
• Appendix B lists the range of motion limitations with the PIMAL appendages
• Appendix C provides references for locating the PIMAL benchmark work

1.2  User Requirements 

PIMAL 4.1.0 employs Java-3D™ and currently only compatible with Microsoft Windows® (7, 8, 
10) operating systems at this time.

Note that PIMAL 4.1.0 has been successfully installed and executed on Parallels Desktop® for 
Mac®. The developers do not endorse any single software product, but only provide feedback 
based on successful test cases. 
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2    PIMAL VERSION 4.0 AND 4.1.0 FEATURES 

PIMAL permits custom articulation of limbs. With both male and female phantom models included, 
PIMAL supports the ability to manipulate the phantom’s position using a simple GUI and generate 
files supporting execution using MCNP® transport code.  

A variety of updates have been implemented in PIMAL Version 4.0. The practical features of the 
software include: 

• Java 3-dimensional (3D)™ interface for PIMAL display;
• Sliders and text options to move appendages;
• ICRP's reference voxel phantoms;
• 2D cross sectional view;
• Organ dose tabulation;
• Source point display; and,
• Saving/loading PIMAL configuration.

In PIMAL Version 4.1.0, the following changes were made: 

• Updated the underlying JAVA 3D™ interface for an optimized user experience;
• Updated the voxel phantoms to the latest ICRP Publication 110 models [7] (male/female

adult, not articulated);
• Updated the Help page to access the PDF Manual;
• Updated the Simulation tab:

o Removed the MODE button; MODE is now automatically selected based on the
emission criteria of the selected nuclide; and,

o Set point source to be 1 m above ground in front of the phantom.
• Made Help file and output windows full screen by default; and,
• Facilitated the link of PIMAL to MCNP®, negating the set DATAPATH step.
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3    INSTALLATION 

Instructions for installing PIMAL on a Microsoft Windows® system are provided below. 

3.1  The PIMAL Installer 

The installation process for PIMAL is similar to that for installing other Windows® programs. 

Step 1. Locate the PIMAL installer file and double click the icon. 

Figure 1  PIMAL Installer 

Step 2. The PIMAL Setup Wizard welcome screen appears. Select Next to continue. 

Figure 2  PIMAL Setup Wizard 
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Step 3. Choose a specific destination folder by selecting Browse or keep the default location. 
Select Next to continue. 

Figure 3  Choose Install Location 

Step 4. Choose a specific Start Menu Folder or keep the default entry and select Install to begin 
the installation. 

Figure 4  Choose Start Menu Folder 
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The PIMAL installer begins setting up the PIMAL application on the machine. 

Figure 5  PIMAL Installation Process 

Note: If needed, the PIMAL installer will install or update Java components as necessary. This 
may add to installation time, but is required to run the Java-based PIMAL application. 
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Step 5. After the PIMAL application itself is installed, two more programs must be installed 
alongside PIMAL. If those programs are already present on the computer, those steps are 
skipped automatically; otherwise, the installers for those programs will start.  

The first of those installers is the Java Development Kit (JDK). In the Java window, select Next to 
start the installation of the JDK. 

Figure 6  Start JDK Installation 



3-5

Step 6. On the next screen, one can choose which components of the JDK should be installed. 
The requirements for PIMAL are pre-selected. Select Next to continue. 

Figure 7  JDK Custom Installation 

Setup Step 7. The JDK installer is extracted. 

Figure 8  JDK Installer Extraction 
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Step 8. Select the Destination folder of the JDK or keep the default one. Begin the installation 
by selecting Next. 

Figure 9  Select Destination Folder for JDK 

Step 9. The JDK installer installs the selected components. 

Figure 10  JDK Installation 
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Step 10. After successful installation of the JDK, select Close to finish this step. 

Figure 11  JDK Installation Complete 
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Step 11. PIMAL also requires Java 3D™. If Java 3D™ is not already installed on the system, 
then the PIMAL installer will install it in this step. 

Review the license agreement and click Accept to begin the installation of Java 3D™. 

Figure 12  Start Java 3D™ Installation 

Step 12. The Java 3D™ installer looks for, and installs in, the same directory as the JDK. Begin 
the installation into that directory by selecting Install. 

Figure 13  Java 3D™ Installation Confirmation 
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Step 13. Once the Java 3D™ installer has completed, select Finish. 

Figure 14  Java 3D™ Installation Complete 
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Step 14. This also completes the PIMAL installation. Click Next to proceed. 

Figure 15  PIMAL Installation Complete 

Step 15. Close the installer by selecting Finish. 

Figure 16  Close PIMAL Setup Wizard 
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3.2  Configuration of PIMAL 

Before using PIMAL for the first time, the user must input a few customization settings. After a 
successful installation, double click the PIMAL icon that was created on the Windows® Desktop. 
PIMAL starts with the basic screen, as shown in Figure 17. 

Figure 17. PIMAL After Installation 

3.2.1  Setting the Working Directory 

The user must define an accessible local working directory to save PIMAL and MCNP® files. 

To do so, navigate to the PIMAL toolbar and select Preferences > Set Working Directory. 

Figure 18  Working Directory Window 

Click Select. In the resulting popup window, navigate to the folder where the files are to be 
saved. It is recommended that this working directory be a location where the user has read/write 
permissions. 
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Figure 19  Second Working Directory Window 

Click on the designated destination folder and press Select. Then click Save on the previous 
window (see Figure 18). The working directory folder is now used as the default save folder for 
PIMAL configurations and MCNP® runtape files. 

3.2.2  Setting the Path for MCNP® Executable 

The path to the MCNP® executable directory must be set in PIMAL so that MCNP® can be 
called from within PIMAL. 

Note: PIMAL assumes that MCNP® has already been installed on the computer system. If 
MCNP® has not yet been installed, please request the code through appropriate channels via 
the Radiation Safety Information Computational Center (https://rsicc.ornl.gov). MCNP® is not 
mandatory for using the PIMAL GUI (e.g., articulating limbs/positions), but radiation transport is 
not possible without the presence of the MCNP® software. 

First, specify the location of the MCNP® executable. On the PIMAL toolbar, select Preferences 
> Set Path for MCNP® Executable. The MCNP® executable pathway can be set by one of two
ways; (1) entered directly in the Executable line (see Figure 20), or (2) by selecting the version
of MCNP® using the Select button (see Figure 21).

Figure 20  MCNP® Executable Window 

https://rsicc.ornl.gov/
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Figure 21  MCNP® Executable Path Selection 

If the MCNP® installation was performed as described in the MCNP® manual, MCNP® is 
installed within a folder named my_mcnp on disk drive C:. 

Figure 22  Location of MCNP6® Executable 

Navigate into the my_mcnp or the user-defined MCNP® folder and highlight the MCNP® 
executable, (e.g., C:\my_mcnp\MCNP_CODE\bin\mcnp6.exe). Press Select.
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4    WORKSPACE 

Once the installation process has been completed and the pathways have been set, PIMAL is 
ready for use. The GUI permits easy customization and display of the phantom. In the following 
sections, the GUI overview, as well as camera controls and other functionalities in PIMAL, will 
be discussed. 

Warning: Breaking the physical limitations of the phantom has the likely effect of causing fatal 
errors in MCNP®. Please do not overlap one portion of the phantom with another (e.g., impale 
the head with the fist, make legs or arms intersect). Treat PIMAL with care. 

4.1  GUI Overview 

A screenshot of the PIMAL GUI is given in Figure 23, with key features of the interface labeled.  

Figure 23  PIMAL Graphical User Interface 

 1 - PIMAL Toolbar 5 - Java 3D™ Environment 
6 - PIMAL Status Bar 
7 - Phantom Parameters Sidebar 

2 - 2D & 3D View Tabs 
3 - Zoom In / Zoom Out / Coordinates 
4 - Phantom Resolution Quality 8 - Minimize/ Maximize/ Close Button 
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4.2  Camera Controls 

Rotation and zooming of the PIMAL phantom is controlled entirely via computer mouse function 
via the following mouse click/drag mechanisms: 

• Mouse left click and drag: Camera rotation
• Mouse right click and drag: Camera translation in that direction
• Mouse middle click and drag: Camera zoom forward and backward
• Mouse middle scroll: Camera zoom forward and backward

4.3  Using the Sliders window 

If the sliders pane is not open on the sidebar, click on the Sliders tab to open it. Clicking and 
dragging a slider for each labeled rotation moves the respective appendage. Experiment with 
each of the 16 sliders to become familiar with their operation.  

To start, each slider is positioned at zero. Some sliders can be moved only in the positive 
direction, while others can move in both positive and negative directions. Click Reset to reset all 
sliders and the phantom posture 

Figure 24 shows the default stance of the phantom, with all sliders at the zero position. 

Figure 24  Default PIMAL Stance - Sliders 
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Figure 25 shows the result of moving the left shoulder rotation slider to 90 degrees; note the 
changed stance.  

Note: The range of motion for the sliders is summarized in Appendix B. 

Figure 25  PIMAL with Left Shoulder Rotated 90 Degrees - Sliders 
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4.4  Using the Text window 

Figure 26 shows the default PIMAL stance with the text window open in the sidebar. To open 
the sidebar in text mode, click on the Text tab. Specific rotation of one or more appendages 
may be obtained by entering the desired value(s) in the text input boxes. 

Figure 26  Default PIMAL Stance - Text 

Figure 27 shows a 90-degree rotation of the left shoulder. This rotation is obtained by entering 
“90” into the left shoulder rotation box. 

Figure 27  PIMAL with Left Shoulder Rotated 90 Degrees - Text 
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4.5  Setting Phantom Transparencies 

To open the transparency pane on the sidebar, select the Set Transparencies tab. When the 
box is checked for each tissue/organ, the tissue/organ becomes transparent in the Java 3D™ 
environment. Note that the bones, lungs, and heart are transparent in the right-hand image. 

Figure 28  Checking the Bones, Lungs, and Heart Transparency Boxes 

Unchecking the box for each tissue/organ makes it opaque. These transparencies can be reset 
to the default setting through the phantom reset button. 

4.6  Resetting the Phantom 

The easiest way to reset the phantom to its initial position is to select the reset button located in 
the bottom right corner of the GUI. (see Figure 29) All appendage rotations are returned to zero, 
the transparencies of tissues and organs are returned to the default settings, and the camera is 
returned to the initial position. 

Figure 29  Phantom and Reset Button 
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4.7  Two-Dimensional View 

Another useful feature of PIMAL is the ability to create cross-sectional, two-dimensional (2D) 
views of the phantom. The dropdown menu seen at the top right corner of Figure 30 defines the 
different planes to be viewed. The text entry boxes control the range of what is drawn in a 
certain direction. The cut plane slider allows the user to move the cross-sectional view in the 
direction perpendicular to the view plane (e.g., in Figure 30, the 2D views are in the xz plane 
and the slider moves the camera in the y-direction). Finally, the resolution controls the detail of 
the drawing. 

After all changes are made to the settings, the Redraw button must be selected to apply the 
changes. The Reset button will return the 2D view to its default settings. 

Figure 30  2D View Workspace 

4.8  Saving Current Configuration 

See Generating MCNP® Inputs, Section 5.4. 
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4.9  Recalling Past Configurations 

After a PIMAL MCNP® input has been saved, the settings used in the input file can be 
reopened (e.g., source definition, appendage rotations). To do so, click on File > Open Input in 
the toolbar. (see Figure 31) In the generated popup window, navigate to the directory containing 
the input file to be reopened and select Open. 

Figure 31  Opening PIMAL Input 

4.10  Exiting PIMAL 

To safely exit the PIMAL software, navigate to the toolbar and select File > Exit. (see Figure 31) 
Be aware that clicking Exit will quit PIMAL without saving the phantom configuration. If you wish to 
save your configuration, do so before exiting PIMAL. 

Figure 32  Exiting PIMAL through Toolbar 
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5    GENERATING MCNP® INPUTS 

Once the positioning of the phantom is complete, the next step of the process is to generate the 
MCNP® input file. This includes defining a source, allowing PIMAL to generate the file, 
displaying source points for source validation, and saving the input. Custom source creation is 
introduced in this section (it is discussed more thoroughly in the Tutorials, Section 7). The 
majority of this section will deal with the simulation tab on the phantom parameters sidebar (see 
Figure 33). 

5.1  PIMAL Built-in Source Settings 

PIMAL contains numerous built-in sources for user convenience under the Simulations tab (see 
Figure 33). 

Figure 33  Depiction of Simulation Tab on Sidebar 

Source energy options are the following: 

• Monoenergetic photon/neutron: Source energy defined in text box (MeV) for
radionuclides were taken from ICRP Publication 107 nuclear decay data [8]:

• I-131: Iodine-131 source spectrum
• Co-60: Cobalt-60 source spectrum
• Cs-134: Cesium-134 source spectrum
• X-ray (60-120) kVp: X-ray source spectrum from machines running at 60-120 kV peak

voltages
• AmBe/PuBe neutron source: AmBe/PuBe energy spectrum (utilizes the n,p reaction)



5-2

• Antero-posterior (AP): Particles enter the phantom through the front (anterior) surface
and exit through the back (posterior) surface.

• Postero-anterior (PA): Particles enter the phantom through the back (posterior) surface
and exit through the front (anterior) surface.

• Left/right lateral (LLAT/RLAT): Particles enter the phantom through the left/right lateral
surface.

• Point source: The point source of particles is defined by the position to be entered in the
text boxes.

• Isotropic: The source is defined on a spherical surface surrounding the phantom (surface
338 for the female phantom and surface 294 for the male phantom).

• Internal sources: Source defined within specified organs.

The last entry is for specifying the number of particles to run in the MCNP® simulation. This 
value can be edited in the next step or in a text editor by looking for the NPS (number of 
particles) line at the bottom of the MCNP® input file. The NPS required for each simulation 
depends on the source and receptor geometry. The required statistics for a Monte Carlo 
problem to converge is unique to each modeled source and receptor. Users are strongly 
recommended to consult the MCNP® manual [9]. 

5.2  Generating MCNP® Input 

To generate the MCNP® input file, select the Generate MCNP Input button shown at the bottom 
of Figure 33. Figure 34 shows an example MCNP® input window that resulted from selecting 
the Generate MCNP Input button. The contents of the MCNP® input file may be edited through 
the input window using the built-in text editor. Changes made to the input file will be saved and 
used from this point. 

The Energy (MeV) dropdown menu is for the selection of a source energy or energy spectrum. 
The second dropdown menu gives options for the source geometry. These source geometry 
options are 
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Figure 34  Generate MCNP® Input Window 

5.3  Displaying Source Points 

Displaying the source points is a convenient way to visualize the geometry of the source in and 
around the phantom (see Figure 35). Selecting Display Source Points will initiate the process. 
MCNP® runs and determines the location of the source points. After MCNP® finishes, the Java 
3D™ environment refreshes and the source points are displayed. 
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Figure 35  Source Point Display of LLAT Geometry 

Adjustable settings for source display are as follows: 

• Source Display Number: The number of source points may be set and changed
in Preferences > Set Source Display Number. Your computer hardware may limit the
number of points that can be displayed.

• Source Display Color: The color of the displayed source points may be set and changed
in Preferences > Set Source Color

• Organ Transparency: When checked, Set all organs transparent, seen in Figure 36,
results in all phantom transparencies being turned on for the source display. Transparent
organs are essential for viewing internal sources.

5.4  Saving Input 

To save an MCNP® input, navigate to the toolbar shown at the bottom of the input screen (see 
Figures 34 and 36). Select Save Input to open the save dialog. 



5-5

Figure 36  Setting Transparent Organs and Save Input Location 

In this window, input the desired file name and select save to complete the process. 

Figure 37  Save Input Window 

5.5  Entering Custom Source Configurations 

PIMAL contains a selection of predefined internal and external sources, but additional sources 
may be needed. In advanced cases, a source may be defined manually outside the PIMAL 
interface and run natively from the MCNP® command line. Note that external customization is 
recommended only for advanced MCNP® users. 

The steps for entering a custom source are outlined below; these steps are detailed thoroughly 
in the Water Submersion Tutorial (Section 7.3): 

(1) Save the MCNP® input file and open the new, custom source file in a text editor, or edit
within the Generate MCNP Input window using the built-in text editor.

(2) Make changes to the Materials card (addition of materials).
(3) Make changes to Cell/Surface cards with inclusion of materials.
(4) Edit the Source definition (SDEF).
(5) If you are editing within PIMAL, display the source points to aid in validation.
(6) Save the new source input file.
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6    RUNNING MCNP® 

An MCNP® input file has been created through PIMAL based on user-provided settings. The 
next step is to run MCNP® using the new input file and extract dose tallies. In this section, the 
options for running a PIMAL-generated MCNP® input file and viewing the organ doses from the 
MCNP® output file are presented. 

6.1  Running MCNP® through PIMAL 

MCNP® may be run through PIMAL without having to use the MCNP® command line. To start, 
generate the MCNP® input file as shown in Section 5.2. 

From the popup menu, select Run MCNP (see Figure 34). 

While MCNP® runs in the background, the MCNP® output is shown in the MCNP Screen 
Output tab. (see Figure 38) Until MCNP® has fully completed its execution, the only way to 
abort the run is by closing the window, regenerating the MCNP® input, and selecting Run 
MCNP again. At that point, the option to display source points becomes available again. 

Figure 38  MCNP® Screen Output 
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The organ dose chart is created automatically when the MCNP® run is finished. See Section 
6.3, Viewing Organ Dose, for more details on this output table. The full “.o” output file can also 
be viewed in the third tab, MCNP Full Output. 

Figure 39  Tabulated Organ Doses 

Note: If fatal errors occur during the MCNP® run, the organ dose chart will not be generated, 
and the reason will be shown in a dialogue box. Select OK to continue. (see Figure 40) 

Figure 40  Fatal Error Warning 

Fatal errors occur if run from the GUI natively if PIMAL is improperly positions (e.g. self-impaling 
position). If the user conducts modifications to the input files outside of the PIMAL GUI options 
independently, the user is responsible for identifying if the additional modifications create the 
fatal error. 
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6.2  Running MCNP® through the Command Prompt 

Another way to run the MCNP® inputs created by PIMAL is through the computer command 
prompt/terminal as shown in Figure 41. 

Figure 41  Command Prompt on Windows® 

First, change the working directory to the folder containing the input file. In Figure 42, the folder 
is named PIMAL IOs. 

Figure 42  Changing Working Directory 

PIMAL outputs were originally made to run in MCNP5®; MCNP5® is also included on the 
MCNP6®/MCNP6.1.1® installation disks. To ensure compatibility with all features, using 
MCNP6® or MCNP6.1.1® is recommended for PIMAL 4.1.0. 
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As seen in Figure 43, the formatting of the command is as follows: 

• MCNP6: start off the command stating which version to use
• i: tells MCNP® what the input file is named (math_female_soil_1.i)
• o: tells MCNP® what to name the output file (output.o)
• tasks 2: optional specification of the number of cores to use in multiprocessing

Figure 43  Running the Input File 

The run may be interrupted at any time by selecting Ctrl + C. An interrupted (paused) run is 
shown in Figure 44. The last line in Figure 44 shows the options that are available by entering 
the chosen character on the command line/terminal. The options are the following: 

• s: check the status of the run (time used, number of particles tracked)
• m: plot the current tally result
• q: quit the execution and save the current results
• k: kill the execution with no results generated

• 
Figure 44  Pausing the Run 
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6.3  Viewing Organ Dose 

After the MCNP® input file runs, the MCNP® output is shown in tabular form. The tallied dose is 
parsed for convenience. To view the tallied dose, navigate to the PIMAL toolbar and 
select Output > View Organ Dose. 

Figure 45  Organ Dose Chart 

In the output selection window, navigate to the folder containing the output files and highlight the 
output file. Select Open. 

Figure 46  Output Selection Window 

The organ dose chart (see Figure 45) appears in a popup window. The tally computed by 
MCNP® is converted to Gy/(source particle) using the energy deposition tally (F6) for each cell 
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and the known organ masses. Relative error for the dose is shown in the column to the right. If 
photonuclear effects are turned on (MODE n p), the neutron dose will be displayed, along with 
total dose from both particle types. 

The columns may be resized. Place the cursor over the dividing lines until the mouse changes 
into a horizontal line. Click and drag in the desired directions to resize. 

The chart may also be exported as an ASCII .dat file, which may be opened in a text editor. To 
save the organ doses as an ASCII file, click on the Export to ASCII button (see Figure 45), and 
save the file. 
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7    TUTORIALS 

These tutorials cover the basics of using PIMAL to accomplish realistic modeling needs. The 
tutorials also cover editing the MCNP® files outside of PIMAL to go beyond the capabilities of 
PIMAL. 

7.1  Female Extension Pose (AP Source) - Beginner User 

Figure 47  Female Phantom in Extension Pose 

The first tutorial describes a female phantom articulated in an extended reaching pose that is 
exposed to an AP source of cobalt-60. This first tutorial details the basic methodology for using 
PIMAL to calculate organ dose from a source defined within PIMAL. 
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Step 1. By default, PIMAL opens the Mathematical FEMALE Phantom; if the Mathematical 
FEMALE phantom is not selected, click on Phantom > Mathematical Phantoms > Mathematical 
FEMALE Phantom model in the toolbar. 

Figure 48  Open Mathematical Female Phantom 

Step 2. In the phantom parameters section, select the Sliders tab. 

Figure 49  Phantom Parameters Window - Female Extension 

Step 3. Appendage rotations set using sliders are shown. The phantom should appear as 
shown at the beginning of the tutorial. 

Figure 50  Phantom Sliders Tab - Female Extension 
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Figure 51  Phantom Simulation Tab - Female Extension 

Step 4. Set the Energy (MeV) dropdown menu selection to Co-60. 

Step 5. Set the Source Geometry dropdown menu selection to Antero-Posterior (AP). 

Step 6. The last entry is for the Number of Particles (NPS) to be run by MCNP®. For this 

tutorial, set the NPS to a small value: 1.0E5. 

Step 7. Select Generate MCNP Input. 

Step 8. To verify the source geometry, display the source points of this setup. Ignore the 
MCNP® input popup menu and click on Preferences > Set Source Display Number in the 
toolbar. Enter in 6000 display points and select Save. 

Figure 52  Set Source Display Number - Female Extension 

Step 9. On the popup menu generated in step 8, deselect Set All Organs Transparent and 
select the Display Source Points button. 
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Figure 53  MCNP® Input - Female Extension 

Step 10. The phantom should now be shown in the main window. Return to the Viewer for 
MCNP window, select the MCNP Input, and select Run MCNP. 
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Figure 54  Female Extension Phantom with Source Point Display (Posterior View) 

Step 11. Be certain that MCNP® runs in another tab of the window. MCNP® requires a short 
amount of time to run the 1.0E5 particles. If fatal errors are encountered at this point, or during 
source point display, ensure that the input in the first tab was not altered. 
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Figure 55  Female Extension MCNP® Run 

Step 12. When the MCNP® is finished, the organ dose table appears. Data could be written and 
entered into another file or exported as an ASCII .dat file. Select the Close Window button to 
complete this tutorial. 
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Figure 56  Female Extension Phantom Computed Organ Dose Values 
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7.2  Male Voxel Phantom (AmBe Point Source) - Intermediate User 

Figure 57  Male Voxel Phantom 

This tutorial covers the modeling of the male anatomy, represented by the built-in ICRP Voxel 
Phantom, exposed to an isotropic AmBe neutron point source. The Voxel Phantom is a closer 
representation of the human body than the Mathematical Model, but it is not possible to move 
the appendages. The MCNP® input file will run outside of PIMAL using MCNP6®, and the 
output file will be viewed within PIMAL. 

Step 1. Click on Phantom > Voxel Phantoms > ICRP's MALE Voxel Phantom Model in the PIMAL 
toolbar. 
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Figure 58  Open ICRP's MALE Voxel Phantom Model 

Step 2. The Simulation tab should be open by default; if not, select it.  

Figure 59  Phantom Simulation Tab - Male Voxel 

Step 3. In the Energy (MeV) dropdown menu, select AmBe Neutron Source. 

Step 4. In the third dropdown menu, select Point source. For this setup, the point source is set 
to be 1 meter from the front of the body. Enter the positioning values as seen in Figure 59. 

Step 5. The last entry is for the Number of Particles to be run by MCNP®. For this tutorial, set 
the NPS to a relatively small value: 1.0E5 

Step 6. Select the Generate MCNP Input button. 

Step 7. For this tutorial, the generated MCNP® input file is taken outside of PIMAL to run in the 
MCNP® command prompt. Select the Save Input button. 
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Figure 60  MCNP® Input - Male Voxel 

Step 8. Name the file and save it in a convenient location, then select the Save button. 

Figure 61  Save MCNP® Input File - Male Voxel 
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Step 9. Open the MCNP® command prompt. Change the working directory to the directory to 
which the file was saved in the previous step. As seen in Section 6.2, “Running MCNP® through 
the Command Prompt,” be sure to use the correct syntax to run the input file. At 1.0E5 particles, 
the run should be quick once initialized. 

Note: Voxel Phantom input files must be run in MCNP6®/MCNP611® or MCNPX® and not in 
MCNP5®. 

Figure 62  MCNP® Command Prompt - Male Voxel 

Step 10. To view the results of the run, open the output file through PIMAL. In the PIMAL toolbar, 
click on Output > View Organ Dose. Select the output file and select the Open button. 

Figure 63  PIMAL View Organ Dose - Male Voxel 

Step 11. The absorbed doses for 28 organs are shown. The total dose is the sum of neutron dose 
and photon dose. The MCNP® output file can also be viewed through PIMAL; in the PIMAL 
toolbar click on Output > View MCNP Output. 
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Figure 64  Male Voxel Phantom MCNP® Output 

Step 12. Select the Close button to conclude this tutorial. 

7.3  Water Submersion - Advanced User 

A practical example would be to use PIMAL to determine the dose to human organs from a 
surrounding body of contaminated water. This tutorial covers complex issues encountered when 
PIMAL is applied to realistic situations - the introduction of new materials and source geometries 
to the model. In this case, a male mathematical phantom is placed into a large body of 
contaminated water, where the contaminant releases photons with energy 0.5 MeV. 
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Figure 65  Water Submersion with Male Mathematical Phantom 

Step 1. Click on Phantom > Mathematical Phantoms > Mathematical MALE Phantom model in the 
PIMAL toolbar. 

Figure 66  Open Mathematical Male Phantom 
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Step 2. Select the Simulation tab in the Phantom Parameters menu. Set the Number of Particles 
to 1.0E5 in this example. 

Figure 67  Phantom Simulation Tab - Water Submersion 

Step 3. No other settings on the Simulation menu are needed; the source definition changes will 
be made outside of PIMAL. Select the Generate MCNP Input button. 

Step 4. The MCNP® input will be edited in PIMAL. The first priority is to add a material card for 
water. As shown, it is important to use material numbers 26 or greater. 

Figure 68  MCNP® Input 1 - Water Submersion 
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Step 5. Navigate to the location in the MCNP® input file as shown, and enter the material for 
water (in this case, material M26) as shown. 

Figure 69  MCNP® Input 2 - Water Submersion 

Step 6. A spherical vacuum around the phantom already exists in the input file generated by 
PIMAL (cell 135 for MALE). Go to the line for cell 133 and change from vacuum 0 to Water with a 
density of 1.00 g/cm3: 26 -1.00. Note that cell 135 is defined as inside surface 294. 

Figure 70  MCNP® Input 3 - Water Submersion 
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Step 7. When an infinite body of water is defined for submersion testing, the spherical water 
volume has to be large enough to contain all source points that could affect dose calculations; at 
the same time, an arbitrarily large sphere of source points may include a majority of source points 
that have no chance of reaching the phantom.  

For this tutorial, make the sphere at least 6 mean free paths away from the body at all points. The 
height of the body from the origin is approximately 100 cm (in positive z direction) and the mean 
free path of a 0.5 MeV photon in water is approximately 10 cm. Therefore, the radius of the 
sphere gets set to 160 cm.  

Navigate to surface 294, and change it to 160 cm. 

Figure 71  MCNP® Input 4 - Water Submersion 
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Step 8. Finally, the photon source has to be defined. In the source definition, a sphere slightly 
larger than cell 135 must be defined as source volume. Using the cell rejection technique, only 
source particles that start within cell 135 are accepted.  

Several changes have to be made in the SDEF section of the input file: 

• ERG defines the source energy in MeV, e.g., 0.5 MeV.
• CEL defines which cell is used to sample, 135 here.
• Add an SI1 card that defines the radius of the source, here 161 cm: SI1 0 161.
• Add an SP1 card that defines radial distribution to equally sample the volume of the

sphere: SP1 -21 2.

Figure 72  MCNP® Input 5 - Water Submersion 

Step 9. Click on Display Source Points to verify the source. 

Step 10. After editing, click on Save Input to save the input file. 
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Step 11. Open up the command prompt and go to the directory containing the input file. Start the 
MCNP® simulation. See Section 6.2, “Running MCNP® through the Command Prompt,” for 
details. 

Figure 73  MCNP® Command Prompt - Water Submersion 

Step 12. Wait for the MCNP® run to complete. 

Step 13. To view the parsed results of the run, open the output file through PIMAL. In PIMAL, 
click on Output > View Organ Dose from the toolbar. Select the output file and select Open. 

Figure 74  PIMAL View Organ Dose - Water Submersion 

Step 14. The data is now accessible in a user-friendly manner. The original output file itself can 
also be viewed through PIMAL in Output > View MCNP Output.  
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Figure 75  Water Submersion MCNP® Output 

Step 15. Select Close to conclude this tutorial. 
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APPENDIX A  DETAILED DESCRIPTION OF PHANTOM INPUT FILES 

This appendix contains a description of the cells and the surfaces that make up the cells for both 
the male and female phantom in PIMAL. A description of the material definitions and tally 
descriptions are also included. 

Figure A-1  Male PIMAL View in the Visual Editor (VisEd) software {Schwarz, 2011 #30} 
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Male Phantom in PIMAL  

Note that cell 135 is vacuum. 

Figure A-2  Male Phantom Head and Neck Area 

Table A-1  Male Phantom Head and Neck Area Cell Descriptions 

Cell Organ/Tissue/Body Part Further descriptions (surfaces) 

1 Skin of Head/Neck 

2 Cranium 

3 Teeth Region between two ellipsoid halves (21&22) 

4 Mandible 

5 Nasal Cavity 

6 Brain Inside ellipsoid bisected by planes 

7,8 Eyes Inside ellipsoids (31,32) *not depicted* 

9 Total Sinuses *not depicted*

10-18 Residual/Mucosa Walls Gastrointestinal walls - pharynx, larynx, trachea 

19 Thyroid 

20,21 Nose Nose contents and nose wall 

22 Oral Cavity Soft tissue behind mouth and teeth 

23 Salivary Glands 

24 Neck muscle 
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Figure A-3  Male Phantom Chest of Body 
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Table A-2  Male Phantom Chest of Body Cell Descriptions 

Cell Organ/Tissue/Body Part Further descriptions (surfaces) 

25,26,27 Vertebra Cervical *not depicted* and thoracic and lumbar 

28 Ribs 

29 Clavicles 

30 Scapulae 

31 Pelvis Bone 

32-34 Main Bronchi Residual/mucosa wall and contents *not depicted* 

35,36 Lungs Left and right lung 

37 Thymus Inside ellipsoid (150) 

38,39 Heart 

40,41 Adrenals Ellipsoids (163,164) bisected by plane 

42,43 Kidneys Ellipsoids (166,167) bisected by planes 

44 Liver Ellipsoid (173) bisected by planes 

45,46 Gall Bladder 

47 Pancreas 

48 Spleen Ellipsoid (187) *not depicted* 

49-52 Esophagus *not depicted*

53-55 Stomach Ellipsoids (195,196,197) 

56 Small Intestine 

57-68 Left & Right Colon 

69-71 Sigmoid Colon 

72-74 Rectum 
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Figure A-4  Male Phantom Chest of Body - Side View 

Table A-3  Male Phantom Chest of Body - Side View Cell Descriptions 

Cell Organ/Tissue/Body Part Further descriptions (surfaces) 

73,74 Rectum 

75-77 Urinary Bladder 

78 Prostate Sphere (227) 

79,80 Testes Ellipsoids (231,232) 

81 Male Genitalia 

82,83 Male Breasts *not depicted*

84 Muscle in Trunk Defined outside all defined organs, inside body 

85 Skin of Trunk Sphere (227) 

86 Skin of Male Genitalia *not depicted*
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Figure A-5  Male Phantom Arms 
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Table A-4  Male Phantom Arm Cell Descriptions 

Cell Organ/Tissue/Body Part Further descriptions (surfaces) 

87-90 Right Arm Bone 

91-94 Right Arm Soft Tissue 93 - Very small soft tissue area *not depicted* 

95-98 Right Arm Skin 

99-102 Left Arm Bone 

103-106 Left Arm Soft Tissue 105 - Very small soft tissue area *not depicted* 

107-110 Left Arm Skin 

Figure A-6  Male Phantom Legs and Surroundings 
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Table A-5  Male Phantom Legs and Surroundings Cell Descriptions 

Cell Organ/Tissue/Body Part Further descriptions (surfaces) 

111-114 Right Leg Bone 

115-118 Right Leg Tissue 117 - Very small tissue area *not depicted* 

119-122 Right Leg Skin 

123-126 Left Leg Bone 

127-130 Left Leg Tissue 129 - Very small tissue area *not depicted* 

131-134 Left Leg Skin 

135 Vacuum Around Phantom Sphere completely encompassing phantom 

136 Particle Graveyard Outside of 135 
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Female phantom in PIMAL  

Note that cell 133 is vacuum. 

Note that geometries are similar between the male and female phantoms, except for what is 
noted below. 

Figure A-7  Female Phantom Lower Chest 

Table A-6  Female Phantom Lower Chest Cell Descriptions 

Cell Organ/Tissue/Body Part Further descriptions (surfaces) 

78 Left Ovary Inside an ellipsoid (272) 

79 Right Ovary Inside an ellipsoid (273) 

80 Uterus Inside an ellipsoid (274) bisected by plane (275) 
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Material Definitions 

Figure A-8  Material Cards 

Materials are designated by the M# cards. New defined materials must have numbers >25, 
PIMAL itself uses materials 1-25. 

Tally Descriptions 

F6 tallies are utilized by PIMAL to find the dose to each of the organs: 

• F116 tally collects the neutron dose contribution.
• F216 tally collects the photon dose contribution.
• F316 tally collects both the neutron and photon dose contribution.
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APPENDIX B  LIMITATIONS IN USING PIMAL 

Physical limitations on appendage rotations are as follows: 

• Left/Right shoulder rotation: 0-180; 0-358
• Left/Right elbow rotation: 0-180; 0-358
• Left/Right hip rotation: −25-79; −39-79
• Left/Right knee rotation: −60-90; −90-90





C-1

APPENDIX C  VALIDATION AND VERIFICATION 

Benchmark computations for PIMAL are fully documented in Section 3 of the following 
document:  

H. Akkurt and K. Eckerman. Development of PIMAL: Mathematical Phantom with Moving Arms
and Legs, ORNL/TM-2007/14, Oak Ridge National Laboratory (May 2007). Available at:
https://crpk.ornl.gov/documents/ORNL_TM-2007_14.pdf.

https://crpk.ornl.gov/documents/ORNL_TM-2007_14.pdf
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Computational phantoms with articulated arms and legs have been developed to enable radiation dose estimation for 
male and female receptors in different postures. Using a user-friendly graphical user interface (GUI), the PIMAL 
(Phantom wIth Moving Arms and Legs) software can be employed to adjust the posture of a phantom, generate a 
corresponding input file for the Monte Carlo N-Particle (MCNP®) radiation transport code, and perform radiation 
transport simulations for dose calculations in MCNP®. The MCNP® code can be run natively from the PIMAL interface 
or externally in the MCNP® command prompt via the generated MCNP® PIMAL input file.  

PIMAL 4.1.0 includes separate male and female stylized phantoms with articulated limbs and houses the International 
Commission on Radiological Protection (ICRP) Publication 110 reference adult male and female voxel phantoms (no 
articulation). Internal and external radionuclide sources can be simulated in PIMAL via a dropdown menu in the GUI, 
and users can select the ICRP’s standard external exposure geometries or a point source from the menu options.  

This user manual describes the updates to PIMAL 4.1.0, aids users in installing PIMAL, explores geometry articulation 
and visualization capabilities and radiation source definitions, and provides sample tutorials for PIMAL users for 
estimating organ doses. 
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PIMAL: Phantom with moving arms and Legs 
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