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Objective

• The objective of this training is to show participants how to use the 

SNAP/RADTRAD code for performing licensing dose analysis for 

nuclear power plants.  

• This presentation focuses on accident dose analysis and the methods 

coded into SNAP/RADTRAD and is intended to provide 

participants with the background needed to perform dose analysis 

using SNAP/RADTRAD.

• The training presentation is based on a representative PWR plant 

and is intended to provide participants with the background needed 

to perform dose analysis for LOCA and non-LOCA accidents using 

SNAP/RADTRAD.
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Purpose of SNAP/RADTRAD

• Purpose of SNAP/RADTRAD is to determine the dose from a 

release of radionuclides during a design basis accident to the 

following locations:

• Exclusion Area Boundary (EAB)

• Low Population Zone (LPZ)

• Control Room (or Emergency Offsite Facility)

• Focus of SNAP/RADTRAD is dose analysis for licensing 

applications to show compliance with nuclear plant siting and 

control room dose limits for various LOCA and non-LOCA 

accidents. 
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SNAP/RADTRAD Overview

• Symbolic Nuclear Analysis Package – suite of applications that 

interface with nuclear analysis/safety computer codes:

• Developed by Applied Programming Technology, Inc.

• Initial focus was the thermal hydraulics codes (TRACE, 

RELAP5)

• Later, other codes added (MELCOR, FRAPTRAN, FRAPCON, 

etc.)

• Current version is V2.5.4 as of 4/6/2017

• SNAP provides a standard graphical user interface to simplify the 

development of models for the supported analytical codes.  SNAP is 

used to:

• Construct, maintain and document models

• Run analyses and analyze results
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SNAP/RADTRAD Overview

• The primary apps in SNAP for RADATRAD analysis are:

• Model Editor – primary interface for developing models.

• Configuration Tool – used to configure SNAP for operation on 

a given computer.

• Job Status Tool – used to check job progress and view results,

• Calculation Server – operates in the background and controls 

code execution.  Allows current jobs on multicore processors.

• SNAP is developed in JAVA and is platform-independent.  

• Uses a plug-in architecture.

• Can be adapted to any engineering code.
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SNAP/RADTRAD Overview

• RADTRAD was incorporated into SNAP in two parts:

• RADTRAD plugin to SNAP which, along with the Model Editor interface, 

provides the user with the ability to prepare RADTRAD models. This code is 

referred to as the RADTRAD plugin and is maintained by APT.  The current 

version is V4.11.5.

• A separate analytical code that actually performs the calculations and 

generates the output. This code is maintained by ISL, Inc.  The current version 

is V4.5.5.

• Documentation is available on SNAP/RADTRAD and the RADTRAD analytical 

code from the RAMP website.  Link is:

https://www.usnrc-ramp.com/content/snapradtrad-overview
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SNAP/RADTRAD Installation

• SNAP - obtained from the Applied Programming Technology website at: 

https://www.snaphome.com/

https://www.appliedprog.com/

• Files needed to run SNAP/RADTRAD:

• Java Standard Edition (SE) 7.0 or later.  This package is currently available on 

http://www.oracle.com/technetwork/java/javase/downloads/index.html.

• SNAP/RADTRAD plugin – distributed with SNAP during the download progress from 

the APT site.

• APTPlot – plotting package.  See APT website (addresses above).

• jedit – although not required, jedit adds some user conveniences in SNAP.  This 

package is available from www.jedit.org. 

• RADTRAD analytical code packaged separately, available through the RAMP 

website for registered users.

https://www.snaphome.com/
https://www.appliedprog.com/
http://www.oracle.com/technetwork/java/javase/downloads/index.html
http://www.jedit.org/
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SNAP/RADTRAD Installation

• Installation begins with downloading 

the snapinstaller.jar file from the APT 

website to a convenient directory.  Once 

that file is downloaded, click on the 

SnapInstaller.jar file to start the 

installation.

• Alternately, you can navigate to the 

directory where the SnapInstaller.jar 

file is located and enter:

java –jar SnapInstaller.jar

• There are three installation options 

available as shown in the adjacent 

screenshot. 

• Installing from the internet is the 

easiest. I prefer to download the 

installation packages to a local directory 

and then perform the installation.
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SNAP/RADTRAD Installation

• Initial installer screen 

analyzes installation and 

checks for pre-existing 

plugins.

• Plugin Manager allows the 

user to select plugins to be 

installed or updated.

• Select the plugins required 

and continue.  Installation 

should proceed to 

completion.

• Plug-ins required for 

SNAP/RADTRAD are AVF, 

ENGTMPL, EXTDATA, 

RADTRAD and Uncertainty.
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SNAP/RADTRAD Installation

• The SNAP Installation is written to the /users/homedir where homedir is 

the home directory for the login ID being used unless you specified a 

different location.

• If you are not sure of where you home directory is, open a command 

window by going to Start and typing in “command” in the Search 

textbox.  A command prompt window should appear (select 

“Command Prompt” from menu above if necessary). Then, type in 

echo %USERPROFILE% and your home directory will be 

displayed.

• The SNAP installer creates two directories: snap and .snap under 

/users/homedir.  The code files are written to snap and files needed to use 

SNAP on a given system are written to .snap.

• Ex: the location of the root folder on a given computer is written to 

.snap.
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SNAP/RADTRAD Installation

• Once the SNAP/RADTRAD package is installed, the RADTRAD 

analytical code is installed.  

• RADTRAD analytical code files are listed below: 

radtrad.jar castor-xml.jar

castor-codegen.jar castor-xml-schema.jar

castor-core.jar commons-logging.jar

• Basically, the user copies these files to a suitable directory and sets a link to 

the radtrad.jar file using the SNAP Configuration Tool.

• Most users create a “radtrad” subdirectory in the /users/homedir/snap 

subdirectory and copy the files to that location.  Then, the user opens the 

configuration tool and sets the path to the radtrad.jar file:

${SNAPINSTALL}/radtrad/radtrad.jar

• Alternately, the user can copy the files to any location and set the path 

appropriately in the Configuration Tool.
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SNAP/RADTRAD Installation

To start the Configuration Tool, enter 

Start->AllPrograms->Snap->Configuration Tool

Click here to show the available 

applications.

Type the location path here 

or

click here to navigate to the 

radtrad.jar file location 

(select tool).
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AptPlot Installation

• AptPlot Installation – same idea as SNAP. 

• Download the AptPlotInstaller.jar file and then either install from the 

internet or from a local directory.
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SNAP/RADTRAD Model Development

• To start the Model Editor, click 

on 

Start->All Programs->

SNAP->Model Editors

Alternately, you can type Model

Editor in the “Search Programs

and Files” textbox under Start.

• A “splash screen” will 

appear with NRC credit, 

code version, etc.  Then the 

Model Editor opens.
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SNAP/RADTRAD Model Development

• Five options available as shown on 

the Welcome Screenshot – typical of 

Windows programs

• Most of the time, users will create a 

new model, open an existing model or 

import a existing model from a .psx 

file.  

• There are multiple ways that you can 

perform any of the above functions.  

Some examples:

• File->New to create a new model

• File->Open to open a previously 

saved model

• File->Import to import a model
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SNAP/RADTRAD Model Development

• We’ll start by opening a previously created model Test23.  The test23.med 

file is found in Samples/Test23.  Steps are as follow:

1. Open the Model Editor as before.

2. Select Continue under Open a Model Document on the Welcome 

Screen.  Navigate to the location of the Test23 subdirectory under 

the Samples directory.

3. Click on Test23.med.  The Model Editor rendering of Test23 will 

open.
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SNAP/RADTRAD Model Development

Lock 

Navigator 

Window

View WindowProperties 

Window

Message Window
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Component Navigator Window

Current Model

Categories

Components

Connections

Job Streams

2D Views
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SNAP/RADTRAD Model Options

• Model Options node is where various options are available.  Includes:

• Title/Description

• Plant Power Level (MW)

• Decay Options: 

• no decay, 

• decay only, 

• decay and daughter production

• Onset of Gap Release (hrs) – typically 0.

• Start of Accident (hrs) – typically 0.

• Duration of Accident (hrs) – typically 720 

hrs

• Dose Conversion Factors: FGR 11&12 or 

User-Specified

• Dose Conversions: allows user to view FGR 

defaults or specify alternate DCFs.

• Time Step Algorithm: 

• Adaptive

• Default

• Default with error calculation.

• Output Parameters

• Dose/Activity Output Units

• Activity/Dose Units (Ci, Rem)

• Si Activity/Dose Units (MBq, mSv)

• Echo Model Definition (T, F)

• Show event results (T, F)
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SNAP/RADTRAD Model Options

• Model Options - continued

• NRC Output:

• Dose results listed by nuclide for 

various dose components.

• Formatted output (page layout) to 

allow insertion into a Word 

document.

• Lines per page can be set as well as 

a tolerance for displaying output.

• Diagnostic Flags:

• Used for debugging
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SNAP/RADTRAD Model Editor

• Click on Default View to see model nodalization. Click on Test23View 

tab to see the job stream representation.

• Click on Lock icon (     ) to unlock the model.  Note the change in the 

toolbar.

• Click on Expand icon (   ) to expand each node in the Model Navigator 

Window to see the input fields for SNAP/RADTRAD.

• Click on Tools -> Check Model to perform an input check on the model.  

Note the message “Note: Model check complete.  No errors found” in the 

Messages Window at the bottom of the screen.



22

SNAP/RADTRAD Model Editor

• Click on the Expand node icon (   )) next 

to Compartments, then click on 

Compartment 1.  

• Note that the compartment 1 input 

appears in the Properties Window

• To switch units to English, right-click on 

the “black bar” in the Navigator 

Window, select Engineering Units -> 

British to change the units. 

• Experiment with other input groups –

approach is the same – we’ll get to 

specifying input later.
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SNAP/RADTRAD Model Development

Compartment Types in RADTRAD that are principally used:

• Normal compartment:

• Used to model plant structures (ex containment).

• Radionuclides can be released to the compartment, transferred 

to/from other compartments and removed (filtered, sprays, natural 

deposition).

• Various removal processes models available for normal (other) 

compartments.

• Control Room Dose compartments:

• Used to model control rooms.

• Control room intake and exhaust is from the environment (release at 

intakes is X/Q dependent).

• Can model filtration in control room (both direct and recirculation 

filters).
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SNAP/RADTRAD Model Development

• Environment Compartment

• Compartment used to model the Exclusion Area Boundary (EAB) and 

Low Population Zone (LPZ) doses.  

• Control room HVAC intake draws from the environment compartment.

• Coupling with the EAB and LPZ locations as well as the control room 

intake is through X/Q values. 

• Normal dose compartment – used to compute the dose at an arbitrary dose 

point (ex. in containment).
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SNAP/RADTRAD Model Development

Compartment

Source

Filter Indicator

Spray Indicator
Flow Pathway Connection

Natural Deposition Indicator
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SNAP/RADTRAD Model Development

• Case execution – depends on the Job Stream.  Job streams are used to pass input 

and output data from one code to another.  Mostly of interest to thermal hydraulic 

analysts.  A default job stream is automatically set up by the Model Editor for 

SNAP/RADTRAD.

• The default job stream for RADTRAD passes input from the Model Editor to the 

RADTRAD analytical code.  Plot file results are passed from RADTRAD  

analytical code output to APTPlot input.

SNAP plugin to 

RADTRAD analytical code.
RADTRAD analytical code

to AptPlot.
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SNAP/RADTRAD Model Development

• Job stream settings can be checked in the 

Model Editor.  In the case of Test23, expand 

the Job Stream node,  select Test23 and 

right-click, then select “Check Stream”.  A 

Error Report window will appear.

• Common error (for me) is to forget to set the 

Root Folder, which, in combination with the 

Relative Location is where the output files 

are written.

• To set the Root Folder, click on     .  An 

“Edit Calculation Server Root Folders” 

window will appear.  Click on the New (    ) 

icon and  navigate to the desired location in 

the “Select Folder Location” window.  The 

Root Folder name will change to the last 

folder name in the directory path.

• If you don’t like that name, click on     , then 

double click in the Name field, then change 

the name as desired.  The Root Folder name 

will be changed.
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SNAP/RADTRAD Model Development

• Relative location can also be reset.  You 

should reset this to a name more 

nmemonic so you can track your cases. 

• To change the name, highlight the 

Relative Location Name and type in a 

new name (Ex. Test23).

• Note the / is automatically appended, so 

no need to add it.

• Run a Job Stream check to determine if 

everything is OK.  Expand the Job 

Stream Node (     ), then right-click on 

the Job Stream Name (Test23) and select 

Check Stream.  An Error Report window 

will appear displaying the error status.
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SNAP/RADTRAD Model Development

• Note that multiple root folders are allowed – handy for organizing 

SNAP/RADTRAD case files.  

• To add a root folder, navigate to Tools->Job Status or click on the Job 

Status icon (    )and expand Local.

• Right-click on Local and select Root Folders.

• Click on New icon (left on Toolbar) and navigate to where you want 

the root folder (ex. NPP Dose Analysis).

• The root folder path will be created.

• A couple of points:

• The root folder directory needs to exist – otherwise you’ll get a 

warning that the directory doesn’t exist and the root folder will not be 

defined.

• Overlapping paths are not allowed and will generate an error. 
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SNAP/RADTRAD Model Development

• Before we continue, confirm the 

link to the analytical code                  

by navigating to 

Tools->Configuration Tool

and then expand the Applications

node by clicking on the      icon. 

Then click on RADTRAD.  

• This link is to the RADTRAD 

analytical code.

• Note that this location is 

installation-dependent.
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SNAP/RADTRAD Model Development

• To run the Test23 case, click on Tools -> Submit Job.  A Submit Job Stream 

window appears.  

• Click OK and a confirmatory “Submit Stream” window appears.  

• Click OK and the run will start.  The SNAP Job Status window will appear.  In 

this case, the run is completed.
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SNAP/RADTRAD Model Development

• Note the relationship between the RADTRAD 

stream, the Navigator Window and the Job 

Status Window.

• Two Job Stream steps
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SNAP/RADTRAD Model Development

• Output Review – Click on the RADTRAD Job Type in the Job Status Window, then click on 

the File Viewer (     ) icon and then select Text Files.  A list of files will appear.  Select the 

file of interest to open the file in the File Viewer to review the file data (reminiscent of 

V3.03)

• Key output files are listed below (there are others as well).

Name Description

radtrad.psx plant information file in xml format (input)

radtrad.nix nuclide information file in xml format (input)

radtrad.dfx dose conversion factors file in xml format (input)

radtrad_1.icx, 

radtrad_2.icx, etc.

initial inventory file for each source (input)

radtrad_1.srx, 

radtrad_2.icx, etc.

source term file for each source (input)

radtrad.out RADTRAD output in original output format (output)

radtradNRC.out RADTRAD output in NRC output format (output)

radtrad.screen RADTRAD screen output file (output)
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SNAP/RADTRAD Output File Description

• radtrad.out – original output format in V3.03/3.10 format.  Major sections 

are:

• Input echo – provides an edited input summary of plant description 

(model), scenario (radionuclide source term/DCF) information, 

compartment/pathway data, X/Q, etc. 

• Breakdown of dose results at various time points generally selected 

by changes in events (ex. time at which flow rate changes, time at 

which X/Q changes).  Activity balance information also given.

• I-131 Summary, Cumulative Dose Results, Worst Two-Hour Doses 

and Final Doses at the end of the file.  

• Contents can be controlled from Model Options -> Output Parameters 

in the Model Editor. Output units in cgs (Rem/Ci) or SI units (mSv, 

MBq) available (under Model Options->Output Parameters).
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SNAP/RADTRAD Output File Description

• radtradNRC.out – provides time-dependent summary of dose by nuclide -

• Input echo – provides an edited input summary of plant description (model), 

scenario (radionuclide source term/DCF) information, compartment/pathway 

data, X/Q, etc. 

• Output – activity distribution, cumulative and dose difference (delta-dose) for 

each dose component (inhalation, cloudshine, skin, thyroid, and TEDE).  

Output units in cgs (Rem/Ci) or SI units (mSv, MBq) available (under Model 

Options->Output Parameters).

• I-131 Summary, Cumulative Dose Results, Worst Two-Hour Doses and Final 

Doses at the end of the file.  

• Contents can be controlled from Model Options -> NRC Output Flags in the 

Model Editor.  

• Note that this file is designed to be imported into a word processor (page 

breaks, etc.).  Lines/page and output cutoff (so that the file doesn’t get too 

large) can be set in the Model Editor.

• radtrad.screen – summarizes time step information.
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SNAP/RADTRAD Model Editor/AptPlot

• Note that context of the job stream step affects the output available for 

display through the File Viewer.

• Click on Test23 – only the stream log is available for display.

• Click on RADTRAD – all files listed on the previous chart are 

available for display.  Time step history is displayed in the window.

• To display a plot, click on Plot Files and select “plot – radtrad.plt.”  

AptPlot will open.  Alternately, click on the (     ) icon and AptPlot will 

open.

• In the Select EXTDATA Channels window, scroll down to desired results 

to be plotted.  For example, scroll to “ControlRoom.tede.”  A plot of the 

TEDE dose for the control room will appear.

• If you don’t want to scroll, type “ControlRoom.tede” in the Filter text box 

and then click on Control.Room.tede at the top of the data channel 

window.
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SNAP/RADTRAD Model Editor/AptPlot

• Wildcards can be used to identify the results of interest.  For example:

• L*P*Z* - isolates the LPZ dose results for all dose categories.

• L*P*Z*th* - isolates the LPZ dose results for the thyroid dose for all nuclides 

and the total dose (LowPopulationZone.thyroid).

• Note that case counts.

• Click on the Clear Sets button to clear the plot.

• To change the units of the x-axis from seconds to hours, navigate to the Time units 

drop-down mend and pick hours.

• Note you have the option of using fortnights as a x-axis time unit.  However, 

hours are preferred.

• Suppose you want to plot the Control Room dose for all dose categories.  

Available dose categories are whole body, cloudshine, skin, TEDE, and thyroid.  

Type in the desired result in the Filter window, then pick the result from the 

Channels window and finally click on the Plot button to add the data plot.

• C*R*body – whole body dose

• C*R*cloudshine – cloudshine dose

• etc.
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SNAP/RADTRAD Model Editor/AptPlot

• Note that as each data set is added to the plot, AptPlot adds it to the Data sets 

window (number in brackets are x-y array dimensions).

• G0.S0[2][1664] – control room cloudshine dose

• G0.S1[2][1664] – control room inhalation dose

• etc.

• Double-click on the desired dataset to see the actual data.  Note that you can cut 

and paste the data into a spreadsheet.  

• Suppose you close the Select EXTDATA Channels window.  Navigate to 

Window->Select EXTDATA Channels window to reopen.

• The plotted data is hard to see and distinguish.  Let’s plot all of the control room 

dose components as illustrated above and make some changes:

• Navigate to Plot->Set Appearance to change the appearance of each line.

• Main tab – select each data set under Line properties and change the color 

of the line to black.  Other line-formatting changes are available.  Note 

that the datasets can be grouped.

• Main tab – select a data set and then a symbol for each dataset under 

Symbol Properties.  Click the Apply button after each selection.
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SNAP/RADTRAD Model Editor/AptPlot

• More changes:

• Navigate to Plot->Set Appearance to change the appearance of each line 

(continued).

• Click on the symbols tab and then input a value for Symbol skip for each 

line – use a value of 100.  Click Apply after each selection.  

• Change the scale of the y-axis to logarithmic to make plots easier to read. 

Navigate to Plot->Axis Properties. Change the Edit value from X axis to Y 

axis, then change the Scale from Normal to Logarithmic.  Then click Apply.

• Legend box is a little big – change the font size by navigating to Plot->Graph 

appearance.  

• Pick the Legends tab and change the font side from 100 to 75 using the 

slider.  Click on the left or right side of the slider for finer control.  Then 

click Apply.

• To move the legend box, pick the Leg. Box tab and change the Location 

to x=0.75 and y=0.81 or other suitable values.

• Titles and subtitles can be added under the Main tab.
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SNAP/RADTRAD Model Editor/AptPlot
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SNAP/RADTRAD Model Editor/AptPlot

• To save plot, navigate to File->Save and select a suitable location to save 

the plot.  The plot is saved in AptPlot (apf) format.

• Saved plotfile can be used as a template for plotting other datasets –

avoids making many of the formatting settings.  Ex.  Plot the LPZ dose 

results for Test23.

• Open a new AptPlot session from the Model Editor.  From the 

AptPlot window, navigate to the location of the copied .apf file.  Note 

that the control room dose results appear.

• Clear the sets from the Select EXTDATS Channels window.  Switch 

Time units from seconds to hours.

• Plot the LPZ dose results as outlined above.

• Fill in the titles and make other adjustments as desired.

• Save plot under a new filename.

• Many other features are available in AptPlot.  
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SNAP/RADTRAD Model Editor

• A useful feature is the Model Notebook feature.  This feature generates a 

initial Model Notebook that you can modify.

• To generate an initial Model Notebook, right-click on the “black bar” in 

the Navigator Window, select Export -> Model Notebook.  Click on 

Export and provide a filename in the File Name textbox. A notebook is 

generated in .docx (Microsoft Word) or .odt (Open Office document) 

format

• An odt formatted file can be read and edited using Microsoft Word.

• You can append the Test23NRC.out file to the initial notebook to get 

an editable notebook that you can modify as needed.

• If you prefer, you can select File -> Export -> Model Notebook to 

generate a model notebook.
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SNAP/RADTRAD Model Editor

• RADTRAD Data are built into the Model Editor

• Dose conversion factors (FGR 11, 12 based on ICRP 30)

• Radionuclide data (ICRP-38)

• Core inventory data (RADTRAD 3.03 for PWR, BWR)

• Release fractions and release timings (Regulatory Guide 1.183)

• Iodine chemical form fractions (Regulatory Guide 1.183, 1.195)

• Data file export – above data can be exported from SNAP/RADTRAD by 

selecting File -> Export -> RADTRAD ASCII and specifying a 

CaseName.  CaseName is Test23 in this situation.



44

SNAP/RADTRAD Model Editor

Name Description

CaseName.psx Plant information file in ASCII (XML) format.  

Note that the suffix was added when the export 

was done.

CaseName.dfx Dose conversion factors file in ASCII (XML) 

format.

CaseName.nix Nuclide data file in ASCII format for each source 

(x is source number).

CaseName_x.srx Release fraction file in ASCII format for each 

source (x is source number).

CaseName_X.icx Nuclide inventory file in ASCII (XML) format.

• The following files are exported:
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RADTRAD Mathematical Models

(for RADTRAD-AC)

• RADTRAD utilizes a multi-compartment model with radionuclide 

release to one or more compartments, flow pathways to account for 

transfer among compartments, and models for removal within a 

compartment.   

• A key assumption is that the airborne activity in each non-

environment compartment is assumed to be uniformly mixed.

• Models for filtration and deposition within a flow pathway can be 

specified.  

• Within a compartment, removal due to decay, natural deposition and 

sprays can be modeled.

• Daughter product buildup can also be accounted for.
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RADTRAD Governing Equations
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RADTRAD Governing Equations

𝑑𝑁1
𝑖

𝑑𝑡
= 𝑅1

𝑖 − Λ1,1
𝑖 𝑁1

𝑖 + Λ1,2
𝑖 𝑁2

𝑖 + Λ1,3
𝑖 𝑁3

𝑖 + Λ1,4
𝑖 𝑁4

𝑖   

where 

  𝑅1
𝑖  = the source release rate of species i in compartment 1 in atoms/s 

 Λ1,1
𝑖  = the removal rate of species i within compartment 1 in 1/s 

 𝑁1
𝑖  = the inventory of species i in compartment 1 in atoms 

 Λ1,2
𝑖  = the transfer rate of species i from compartment 2 to compartment 1 in 1/s 

 𝑁2
𝑖  = the inventory of species i in compartment 2 in atoms 

 Λ1,3
𝑖  = the transfer rate of species i from compartment 3 to compartment 1 in 1/s 

 𝑁3
𝑖  = the inventory of species i in compartment 3 in atoms 

 Λ1,4
𝑖  = the transfer rate of species i from compartment 4 to compartment 1 in 1/s 

 𝑁4
𝑖  = the inventory of species i in compartment 4 in atoms. 

For, compartment 1, the rate of change in the number of atoms is:
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RADTRAD Governing Equations

For compartment 2, a similar equation is used which is:

𝑑𝑁2
𝑖

𝑑𝑡
= 𝑅2

𝑖 − Λ2,2
𝑖 𝑁2

𝑖 +  Λ2,1
𝑖 𝑁1

𝑖 + Λ2,3
𝑖 𝑁3

𝑖 + Λ2,4
𝑖 𝑁4

𝑖  

where 

 𝑅2
𝑖  = the source release rate of species i in compartment 2 in atoms/s 

 Λ2,2
𝑖  = the removal rate of species i within compartment 2 in 1/s 

 Λ2,1
𝑖  = the transfer rate of species i from compartment 1 to compartment 2 in 1/s 

 Λ2,3
𝑖  = the transfer rate of species i from compartment 3 to compartment 2 in 1/s 

 Λ2,4
𝑖  = the transfer rate of species i from compartment 4 to compartment 2 in 1/s. 
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RADTRAD Governing Equations

𝑑𝑁𝑘
𝑖

𝑑𝑡
= 𝑅𝑘

𝑖 −   𝜆𝑗 ,𝑗
𝑖 𝑁𝑘

𝑖

𝑛

𝑗=1

+  𝜆𝑘 ,𝑗
𝑖 𝑁𝑗

𝑖

𝑛

𝑗=1,𝑗≠𝑘

 

More generally, the rate of change in the number of atoms in the

kth compartment in a set of n interconnected compartments is given by

𝑅𝑘
𝑖

is the source release rate of species i in compartment k in atoms/s

The first summation represents the removal terms from compartment 

k due either to removal within the compartment or transfer to another 

compartment.  The second summation represents transfer from 

compartment j to compartment k. 
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A matrix formulation can be used to represent the above equations for n 

compartments as follows:

 

  
 

𝑁 1
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Off-diagonal terms in the matrix are transfer terms.

• Calculated as f/V where f is the flow rate out of a compartment (vol (or 

mass) units/time) and V is the compartment volume (vol (or mass) units), 

yielding units of time-1.  

• This ratio is multiplied by the radionuclide inventory in the upstream 

connecting compartment to provide a source to the connecting 

downstream compartment.  

• Uniform mixing throughout each volume is assumed.

Diagonal terms in the matrix are removal terms.  

• Idea is the same in that a removal coefficient expressed in units of time-1 is 

multiplied by the radionuclide inventory to yield a removal rate.  
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• The terms included in the diagonal removal coefficients each have units of 1/sec 

and are:

Λ𝑗,𝑗
𝑖 = 𝜆𝑗,𝑠𝑝𝑟

𝑖 + 𝜆𝑗,𝑑𝑒𝑝
𝑖 + 𝜆𝑗,𝑓𝑖𝑙𝑡𝑒𝑟

𝑖 + 
𝑘=1
𝑘≠𝑗

𝑛

𝜆𝑘,𝑗
𝑖

𝜆𝑗,𝑠𝑝𝑟
𝑖 = the spray removal coefficient in 1/s

𝜆𝑗,𝑑𝑒𝑝
𝑖 = the natural deposition removal rate in 1/s

𝜆𝑗,𝑓𝑖𝑙𝑡𝑒𝑟
𝑖 = the filtered removal rated within compartment in 1/s

𝜆𝑘,𝑗
𝑖 = the removal rate from compartment j toward compartment k in 1/s.
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The removal rate is given by the following equation and includes a few 

different types of transfer between compartments.

𝜆𝑘,𝑗
𝑖 = 𝜆𝑘,𝑗,𝑙𝑒𝑎𝑘

𝑖 + 𝜆𝑘,𝑗,𝑓𝑖𝑙𝑡𝑒𝑟
𝑖 +

𝑓𝑘,𝑗

𝑉𝑗

𝜆𝑘,𝑗,𝑙𝑒𝑎𝑘
𝑖 = the transfer via leakage paths in 1/s.

𝜆𝑘,𝑗,𝑓𝑖𝑙𝑡𝑒𝑟
𝑖 = the transfer through a filtered path in 1/s.

𝑓𝑘,𝑗 = the flow in m3/s from j to k through a path with a DF.

𝑉𝑗 = the volume of compartment j in m3.
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Matrix equation solved in RADTRAD using a matrix exponential based on 

Lee and Wilson:

• Matrix exponential methods are used to solve systems of linear differential 

equations of the form  𝑋 = 𝐴𝑋 + 𝑆 subject to an initial condition 𝑋0. 

• Note that the coefficient matrix is invariant within a time interval.  As a 

result, the initial condition at the start of a given time interval is adjusted 

based on the quantity of material in each compartment at the end of the 

previous time interval. 

Decay is not explicitly included in the matrix equation. 

• Decay is accounted for in RADTRAD by dividing the solution of the 

differential equations into two parts:  (1) radioactive decay and daughter 

in-growth, and (2) radionuclide transport.  

• Used to overcome the limitations of personal computers available at the 

time the original version of RADTRAD was developed and has been 

retained to the present time. 
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Radioactive decay and daughter production occur within a compartment, so 

no intercompartmental transfer needs to be considered.  The governing 

equation is:

𝑑𝑁𝑗
𝑖

𝑑𝑡
= 

𝜈=1

𝑛−1

𝜆𝜈𝛽𝜈
𝑖 𝑁𝑗

𝜈 + 𝜆𝑑𝑒𝑐𝑎𝑦
𝑖 𝑁𝑗

𝑖

𝛽𝜈
𝑖 = the fraction of nuclide 𝜈 that decays to nuclide 𝑖 (dimensionless).

𝜆𝜈 = the decay rate associated with 𝛽𝜈
𝑖 in 1/s.

𝑁𝑗
𝜈 = the quantity of nuclide 𝜈 in compartment 𝑗.

𝜆𝑑𝑒𝑐𝑎𝑦
𝑖 = the rate of decay of nuclide 𝑖 in 1/s.
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Decay and transport calculations are performed alternately in RADTRAD.

• Code begins its integration over a time step by analyzing the effect of 

radioactive decay and daughter in-growth on the inventory of all 

compartments.  

• Code then calculates the effect of radionuclide transport between 

compartments during that same time step.  

• Process of alternating between radioactive decay and daughter in-growth 

and radionuclide transport continues until the specified end time is 

reached.  

• Calculations where radioactive decay is not modeled, the solution 

algorithm is simplified to the single step of calculating radionuclide 

transport.
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By default RADTRAD uses a predetermined time step size algorithm that 

starts at 2 seconds and gradually increases to a maximum of 4 hours after 

about 12.5 hours into the simulation. The time step size can be specified 

manually as well. 

Numerical error is a function of the time step size, and by adjusting the time 

step size it was found that the default time step size algorithm resulted in 

notable error for some simulations.

An adaptive time step algorithm was added to RADTRAD in order to control 

the time step size in order to limit the numerical error.
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The adaptive time stepper uses the following algorithm to calculate error over 

a single time step:

• Starting from solution point P take a full time step to get the time step solution S1.

• Starting again from P take two half time steps to get the time step solution S2.

• Calculate the error by dividing |S2-S1|

(the difference in the two solutions) by 

|S1-P| + |S2-P| (the magnitude of the 

change in S1 and S2 over the time step).

• The maximum error is 1 and the minimum 

error is 0.

• To get the percent error in relation to the 

average of |S1-P| and |S2-P|, multiply the 

error by 200. (The plot shows 28% error)
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Adaptive Time Step Algorithm

A simple adaptive time stepping algorithm is used:

• A max error limit is specified for the model.  If the error over a time step exceeds 

the max error, the time step size is cut in half and the time step is repeated.

• If the error is less than max error/10, the time step size is doubled for the next 

time step.

This simple algorithm does not always work and in some cases, more complex logic is 

used. The adaptive time step algorithm is considered experimental at present since it 

has had limited use.

Adaptive time step simulations can take significantly longer to complete. On average 

the adaptive time step logic takes about twice as long to perform a solution step and 

performs 3 solution steps per time step. For the same number of time steps, it takes 6 

times longer on average. In addition, the adaptive time step logic can take many more 

time steps in order to limit the error. Notably there are some optimizations that are not 

currently implemented that could significantly improve runtime.
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To activate adaptive time stepping, select Model Options. In the properties 

dialog set Time Step Algorithm to Adaptive. The maximum error is used to 

control the simulation accuracy. A maximum of between 0.001 and 0.0001 is 

recommended for most models. A Default with Error Calculation Time 

Step Algorithm is also available. This uses the default time step algorithm 

but calculates error to determine if the error is acceptable. An error plot 

variable is available for examining the error over the simulation.
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4 Node Model Demo

• Start the Model Editor and click on Create a New Model in the Welcome 

screen.  Select RATRAD model in the Select Model Type screen.

• You should see the basic model nodes in the Navigator Window.  

• If you expand one of the model categories using the (     ) icon, and 

click on Compartment 1 (Environment), data fields will appear in the 

Properties Window.  

• To build a model, you need to set up an array of compartments, flow 

pathways, source scenarios, and other components and then specify key 

parameters in various components in the model.  

• For sources, compartments, and pathways that ultimately appear in the 

View Window, the basic pattern is to expand the node using the (   ) icon,  

right-click on the component category, and select New.  A new model 

component is created.
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4 Node Model

• Ex.  Create a new compartment by right-

clicking on Compartments, and selecting 

New.  A new Compartment component is 

created. 

• Note that the new Compartment is 

highlighted and the data for that 

compartment appears in the Properties 

Window.

• Note that an Environment compartment is 

automatically included in the model.

• Now, add the new Compartment 2 to the View Window by right-clicking on 

the new compartment and selecting Add to View -> Default View.  

Compartment 2 is added to the View Window.  Alternately, the Compartment 

2 icon can be dragged to the View window.

• The new component is unnamed.  In the Name field in the Properties View, 

type in a name (Ex. Comp 1) and the name will appear in the Component 2 

node in the View Window.
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4 Node Model

• Add the pre-defined Environment 

Compartment to the view as was done 

for Compartment 2.

• Define a flow pathway by right-

clicking on Pathways [0] -> New in 

the Navigator Window.  Pathway 1 

appears.

• Add Pathway 1 to the View Window 

(Right-click on Pathway 1 -> Add to 

View -> Default View).

• Name the flow pathway in the 

Properties View window (Ex. FP 1).

• Should now have Comp 1, Environment and FP 1 in the View Window.

• The next step is to connect them.
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4 Node Model 

• Looking at the icons, you will note 

flow pathway connection points 

indicated by the little circles on each 

edge.

• The square on the upper left corner 

of each icon is a source connection 

point.

• The connection tool is used to make 

connections – activate the connection 

tool, then move the connection tool 

pointer to the first connection point, 

then left-click and drag to the second 

connection point.  Connection should 

be made.Selection Tool

Pan Tool

Zoom Tool

Connection Tool

Annotation Tool
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4 Node Model

• A source component can be added in the same way as the compartment 

and flow pathway – right-click on Sources [0] -> New, then add to the 

View.  Name the source S1.

• Connect the Source to Compartment 1 using the connect tool –

“connecting the squares.”

• Use the Selection tool to move the icons within the View Window – left-

click and drag.

• Note that the EAB and LPZ are automatically included in the Environment 

compartment.

• Save the model using “Save As” and a suitable filename (I used sample1a) 

after the connections are made (usual Windows approach).
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Connection Animation (1m 41s) 

ConnectionTool.wmv
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Initial Model Building Animation  (6m 8s) 

2-4CompartmentInitialNoding.wmv
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• Once you’ve complete the initial noding, save file as “sample1a.”

• Next step – adding data to the various model components.

• Start with Comp 1 – set the volume to 2.5 x 106 ft3.  Note that default units are SI.  

• To switch units to English, right-click on the “black bar” in the Navigator Window, select 

Engineering Units -> British to change the units.

• Click on the Comp 1 icon in the View window or on the Navigator window and enter 2.5E6 in 

the Volume textbox.

• Note that deposition, filter, and sprays models are not used.  We’ll get to those later.

• For Pathway 1 – expand Pathway node:

• Change the pathway type from Piping 

(default) to Air leakage (typically used 

for containments). 

• For leakage rate specification, click on 

the      icon adjacent to the Leakage Rate 

row.  A data entry table will appear.

• Click on the Add button and add a 

leakage rate of 1.0E9 %/day for 0 to 720 

hrs (essentially bypassing the 

compartment).  Click OK when 

completed.
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• Complete X/Q tables for the EAB and LPZ – similar approach as for the leakage from 

Compartment 1. 

Location 0-2 hr 2-8 hrs 8-24 hrs 1-4 days 4-30 days

EAB 1.40E-4 1.40E-4 1.40E-4 1.40E-4 1.40E-4

LPZ 4.50E-5 2.39E-5 1.29E-5 5.49E-6 1.61E-6

• The final item to be completed is the source specification.  For this illustration, we 

will use the generic PWR core inventory with a power level of 3637 MWth and the 

alternative source term release fractions from R.G 1.183.

• Left-click on Model Options in the Navigator Window, locate Plant Power Level 

and set the plant power level to 3637 MWth.

• Expand the Sources node and left-click on Source 1 (S1), locate Source 

Scenarios and left-click on     .

• In the Edit Inventory Scenarios window, add a new Scenario by clicking on the 

New (     ) icon under Scenarios in the Edit Inventory Scenarios window that 

appears. Pick PWR from the Available Total Inventories.  Enter PWR-AST in the 

Scenario Name text box.

• In the Accident Parameters tab, pick DBA AST under the Accident Type list and 

pick the PWR button under Defaults Type.
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• The final item …

• Click on the Adjusted Inventory tab and review the inventories listed.

• Click on the Release Fractions and Timings tab and review the release 

fractions used.  Note the release durations in hours.

• Click on the Source Term tab and review the gap and early releases.

• Change name to PWR Fuel Release in the Scenario Name Textbox.

• Click on OK.

• In the Properties View, locate and set the Source Term Fraction to 1.0 and 

set the Iodine Physical Form to NUREG-1465.
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Incorporating Model Data Animation (9m 34s)

3-4CompartmentAddNumbers.wmv
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• Probably a good idea to resave the model now.

• Check the model using Tools -> Check Model.  Look in 

Messages window to confirm that there are no errors.

• Expand Job Stream node in the Navigator window and click 

on Simple Stream.   Change the Relative Location to 

Sample1/Results.

• Perform Job Stream check.

• Go to Tools -> Submit Job to submit job.

• Job Status window will appear with the current run status of 

each step of the job stream.
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Job Execution Animation (8m 17 s)

4-4CompartmentJobExecution
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• If you exit the Job Status window from the Model Editor, you can get it 

back by clicking on the       icon on the topmost toolbar (I do this all the 

time!)

• You can also review your output for cases you have run by expanding the 

Job List navigator in the Job Stream window.  

• Note that you need to navigate to the stream folder to see the results.

• Clicking on the Base_Job will activate the toolbar and you can select 

the output you want to examine as before using the File Viewer (    ).

• If you forget what an icon means, you can lay the mouse cursor on top of 

the icon and a descriptive text box will appear.
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• RADTRAD uses a combination of a radionuclide inventory (generally within the 

reactor core) and a release fraction model to determine the source term

• Two pre-defined inventory files are available by clicking on Nuclide Data in the 

Navigator Window, then on the Total Inventories     icon.  Available inventory 

files are displayed.

• PWR - normalized MACCS sample 3412 MWth PWR core inventory 

(60 nuclides)

• BWR - normalized MACCS sample 3578 MWth BWR core inventory 

(60 nuclides)

• Note that the plant power level under Model Options needs to be specified in order 

to obtain the total core inventory.

• The PWR and BWR core inventory files are not editable.  However, to make 

changes, click on the Copy (    ) icon.  This action will make a copy of the selected 

inventory file, appending a number after the filename.
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• The user can also add a new file clicking on the 

Add New File.

Add Nuclide

Delete Nuclide

Move Nuclide Up/Down in List

Import Nuclide File

Export

Nuclide File

Nuclide Editing Icons

File Editing Icons

Add New File

Copy Existing File

Delete Existing File

Open RCS Activity 

Calculator
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• Ex.  Add H-3 to PWR 2 file.

• Click on Add Nuclide Icon.  The Select Nuclides window will appear.

• Scroll to H-3, click on H-3 and then click on OK.

• H-3 will be added to the bottom of the list.  Click on the Move Nuclide icon to move H-3 

to the top of the list.  Alternately, click on the nuclide where you want H-3 inserted and it 

will be added below that nuclide.

• Provide value for the amount of H-3 (Ci/MWth).
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• Note that there are three inventory units that can be used: Ci/MWth, Ci/cc 

and Ci/hr. 

• Easiest way to build a core inventory file is to either:

1. Define a new file, then develop the radionuclide inventory using the 

editing features of SNAP.  Note that most SAR documents give core 

inventories in Ci, so you need to define the core power and then the 

core inventory.  Code will calculate the specific core inventory 

(Ci/MWth).

2. Duplicate an existing file and add/delete nuclides as needed, then 

update inventories.

• Once the inventory file is completed, it can be exported for subsequent 

use.

• Save your sample problem under a new name so that we can model a 

waste gas decay tank rupture.
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• Use the following radionuclide data (Waste Gas Decay Tank Source Term):

Nuclide Activity (Ci) Nuclide Activity (Ci)

Kr-85m 1.49E+2 Xe-135 1.02E+3

Kr-85 5.52E+3 Xe-138 4.06E+0

Kr-87 3.00E+1 I-130 0.0

Kr-88 1.79E+2 I-131 3.99E-2

Xe-131m 1.07E+3 I-132 2.50E-2

Xe-133m 1.27E+3 I-133 4.28E-2

Xe-133 8.12E+4 I-134 4.96E-3

Xe-135m 5.97E+1 I-135 1.94E-2

Keystrokes can be used to navigate to a particular group of nuclides. Also, 

cntl-click to select individual nuclides and shift-click to select multiple 

nuclides can also be done.  Also, the release fractions will be changed to user-

specified values of 1.0 for NG & I.  Use a 2 hour release time for this 

exercise.
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(Build a Nuclide Inventory File (3m 37 s)

5-4CompartmentsWGDTSource.wmv
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• Set the location that you want the results written to in the Job Stream

• Perform the Model Check.  Correct any errors.

• Perform the Job Stream Check.  Correct any errors.

• Run case by submitting the job.

• When job completes, review the results.

• Results that I got:

SNAP/RADTRAD 

(TEDE, rem)

SNAP/RADTRAD 

(thyroid, rem)

EAB (2 hours) 8.12E-2 2.50E-3

LPZ (720 hrs) 2.61E-2 8.05E-4

• These are the results for the Waste Gas Decay Tank Case.
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• New release models have been incorporated into SNAP/RADTRAD to model both LOCA 

and non-LOCA accidents.  

• These release models set the release fractions which applied to an inventory file give the 

source term.

• User-specified release fraction files can be specified.

Accident Type Description

Total Inventory Uses total inventory in conjunction with user-specified release 

fractions and timings.

DBA-TID Design basis (LOCA) accident with TID-14844 release models 

(RG 1.3, 1.4, instantaneous release).

DBA-AST Design basis (LOCA) accident with Alternative Source Term (AST) 

release models based on RG 1.183.

Gap Release Gap release based either on RG 1.25 (RG 1.3/1.4) or RG 1.183.

REA-CRDA Rod Ejection Accident or Control Rod Drop Accident – based on 

RG 1.188.

FHA Fuel handling accident parameters based on RG 1.183.
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• Nuclides are grouped according to their chemical and transport properties in 

RADTRAD.  Grouping is based on NUREG-1465.

• Note that the chemical grouping was revised to permit the use of the ICRP-38 

nuclides in the source term calculations.

No Group RG 1.183 Chemical 

Grouping

Additional Nuclides

1 Noble Gases Kr, Xe H (as H-3), Ne, Ar, Rn, N, O

2 Halogens I add Br

3 Alkali Metals Cs, Rb

4 Tellurium Group Te, Sb add Se

5 Barium, Strontium

(Alkaline Earth Metals)

Sr, Ba combine Sr, Ba

6 Noble Metals Ru, Rh, Mo, Tc, Co add Pd

7 Cerium Group Ce, Pu, Np

8 Lanthanides La, Zr, Nd, Nb,  Pr, 

Y, Cm, Am

add Eu, Pm, Sm    

9 Others Ac, Ag, Al, As, At, Au, Be, Bi, Bk, C, Ca, 

Cd, Cf, Cl, Cr, Cu, Dy, Er, Es, F, Fe, Fm, Fr, 

Ga, Gd, Ge, Hf, Hg, Ho, In, Ir, K, Lu, Md, 

Mg, Mn, Na, Ni, Os, P, Pa, Pb, Po, Pt, Ra, 

Re, S, Sc, Si, Sn, Ta, Tb, Th, Ti, Tl, Tm, U, 

V, W, Yb, Zn 

10 Non-Radioactive Aerosols No change

Notes:  Fl and Cl are gaseous halogens.  They are included in the other group since they likely do not 

behave like iodine.
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Release Fractions for LOCA – NUREG-1465 (Tables 3.12 and 3.13), also Tables 1 

and 2 of RG 1.183, and RG 1.3, 1.4.

Chemical 

Group

Elements NUREG-1465 TID-14844

PWR BWR (RG 1.3, 1.4)

Gap Release Early In-

Vessel

Gap Release Early In-

Vessel

Noble Gases Xe, Kr 0.05 0.95 0.05 0.95 1.0

Halogens I, Br 0.05 0.35 0.05 0.25 0.25

Alkali Metals Cs, Rb 0.05 0.25 0.05 0.20 Note 1

Tellurium 

Group

Te, Sb, Se 0 0.05 0 0.05

Barium, 

Strontium

Ba, Sr 0 0.02 0 0.02

Noble Metals Ru, Rh, Pd, Mo, 

Tc, Co

0 0.0025 0 0.0025

Cerium Group Ce, Pu, Np 0 0.0005 0 0.0005

Lanthanides La, Zr, Nd, Eu, 

Nb, Pm, Pr, Sm, Y, 

Cm, Am

0 0.0002 0 0.0002

Release

Duration

(hours)

0.5 1.3 0.5 1.5 instantaneous

Note 1: TID-14844 considered a 0.01 release fraction for the solid mixed fission products (See Table IV of TID-14844).

Note 2:  RG 1.183 permits a 30 s delay for the onset of the gap release for PWRs and 2 min delay for BWRs
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• Gap Release model incorporated into SNAP/RADTRAD.  Two models provided:

RG 1.25 RG 1.183

I-131 0.12 0.08

Kr-85 0.3 0.1

Other NG 0.1 0.05

Other I 0.1 0.05

Alkali Metals 0.0 0.12

• FHA – fuel handling accident.  

• Basically a drop of a lifted fuel assembly onto the core or spent fuel rack. 

Models in RADTRAD requires an estimate of the extent of damage, that 

is the number of assemblies or fuel rods damaged.  Peaking factors and 

iodine DF for the overlying pool needed.

• Release fractions are the same as above.
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• Rod Ejection Accident (REA) for a PWR or Control Rod Drop Accident 

(CRDA) for a BWR.  

• Basically a control rod is ejected causing a power spike and cladding 

rupture.  Some fuel melting is possible.  

• Models in RADTRAD requires an estimate of the extent of damage, 

that is the fraction of clad breached, fraction of breached fuel that 

melts, and the peaking factor.

• Release fractions are listed below (Appendix H of RG 1.183).
Failed Fuel 

Release 

Fraction

Melted Fuel 

Release to 

Containment

Melted Fuel Release to Reactor 

Coolant for Secondary System 

Release Pathway

Noble Gases 0.1 1.0 1.0

Iodine 0.1 0.25 0.5

Alkali Metals 0.0 0.0 0.0
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• Iodine exists in three chemical forms: aerosol (particulate), elemental and 

organic iodine.  The actual fractions of each form depends on the accident 

and analytical assumptions being used.  

Accident Model Iodine Form

Aerosol Elemental Organic

DBA-

LOCA

TID-14844 5 91 4 RG 1.195

DBA-

LOCA

RG 1.183 95 4.85 .15 RG 1.183

• Other scenarios assume other fractions, for example 97% elemental and 

3% organic for an SGTR (RG 1.183, Appendix F).
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SNAP/SNAP/RADTRAD Exercises

• The first set of exercises are to set up a fuel handling accident (FHA) for a 

representative PWR plant and determine the EAB and LPZ dose. As noted 

earlier the FHA is basically a drop of a lifted fuel assembly onto the core 

or spent fuel rack.  Then an normal-mode control room model will be 

added to the model.

• The rod ejection accident (REA) will be based on the FHA and will be 

done by changing the source model and adding components to the control 

room for emergency mode operation.

• Refer to the SNAP/RADTRAD Training Exercises for directions.
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SNAP/RADTRAD RCS Activity Calculator

• SNAP/RADTRAD allows user to consider events that involve reactor 

coolant system (RCS) activity.  Two approaches available:

• User can specify the coolant activity directly and then adjust for pre-

incident and co-incident iodine spiking.

• User can utilize reactor coolant system activities based on the RN 

Editor formulation, and is similar to GALE code formulation and 

based on ANSI/ANS 18.1.  The original RNEditor was developed by 

Steve LaVie about 15 years ago.  Steve works for NRC.

• To specify the coolant activity directly, click on Nuclide Data, then click 

on Total Inventories (   ), then on the Add RCS Inventory icon (   ).  The 

window on the next slide appears (may have some number in the various 

fields – can be cleared by clicking on the Reset Button (lower left)).
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SNAP/RADTRAD RCS Activity Calculator

• RCS Activity Calculator – can be 

calculated by the code or user-

specified.

• Can consider various Equilibrium 

Activities Level based on the 

Technical Specification values.

• Can also consider pre-incident or 

coincident iodine spiking.

• Values in this window based on 

66,000 lb/hr letdown flow (all other 

RCS Activity Inputs – PWR set to 

0).
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SNAP/RADTRAD RCS Activity Calculator

• Known values for RCS Coolant Activity in 

µCi/gm can be used to determine the equilibrium 

concentration. Enter the following parameters in 

the RCS Activity Calculator screen:

• Plant Power must be set. Use 3637 MWt 

for Plant Power Level in Model Options.

• RCS Mass in grams – use value of 

3.819E5 kg as shown.  

• Enter Activity Values listed in the table.  

Note the RCS Inventory is calculated by 

SNAP/RADTRAD in Ci.

• Check the Use RCS equilibrium activity 

box

• T/S Equilibrium Activity values for DE I-

131and DE Xe-133 in µCi/gm.  Values of 

1 µCi/gm for DE I-131 and 500 µCi/gm 

DE Xe-133 are OK.

• Click on OK – do not click on Calculate 

Activities.  

RCS Conc 

(uCi/g)

Kr-83m 0.000E+00

Kr-85  7.510E+00

Kr-85m 1.370E+00

Kr-87  8.940E-01

Kr-88  2.470E+00

Xe-131m 2.810E+00

Xe-133 2.310E+02

Xe-133m 4.160E+00

Xe-135 6.100E+00

Xe-135m 4.620E-01

Xe-138 5.700E-01

I-131  7.770E-01

I-132  8.030E-01

I-133  1.190E+00

I-134  1.730E-01

I-135  6.750E-01

Cs-134 4.820E+00

Cs-136 4.350E+00

Cs-137 2.680E+00

Rb-86  0.000E+00
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SNAP/RADTRAD RCS Activity Calculator

• RCS Equilibrium Activity Results
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SNAP/RADTRAD RCS Activity Calculator

• To calculate the equilibrium nuclide 

concentration in the coolant, enter 

the following parameters in the 

RCS Activity Calculator screen:

• Set Plant Power Level to 

3637 MWth in Model 

Options (if not set).

• Use value of 3.8192E5 kg for 

RCS mass. 

• Check the Use RCS 

equilibrium activity box.

• Input values of 1 µCi/gm for 

DE I-131 and 500 µCi/gm 

DE Xe-133 for T/S 

Equilibrium Activity.

• Click on Calculate Activities 

and use a value of 66,000 

lbm/hr for the letdown flow 

in the RCS Activity Input 

Window.   Set all other fields 

to 0.  Then click OK.  

• Results in adjacent 

screenshot should appear.
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SNAP/RADTRAD RCS Activity

• To add the effect of the pre-incident 

spike, check the box next to the Use 

pre-incident spike label.  Technical 

Specification spike activity of 60 

µCi/gm is typical.

• To add the effect of the co-incident 

spike, check the box next to the Use 

co-incident spike label and add the 

Iodine Appearance Rate as shown 

here. A spike duration of 8 hours is 

typical.
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SNAP/RADTRAD RCS Activity

• Calculating RCS coolant activity 

based on ANSI/ANS 18.1 for the 

PWR requires additional information 

to determine the effect of letdown 

and boron recovery system (BRS).  

Default input shown.

• Calculating RCS coolant activity 

based on ANSI/ANS 18.1 for the 

BWR also requires additional 

information to include the effect of 

RWCU and condensate 

demineralizers.  Also note that 

separate calculations are performed 

for steam and liquid activity. Default 

input shown.
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SNAP/RADTRAD RCS Activity

• Use the RCS mass and T/S 

Equilibrium Activities shown.  

Click on the Calculate Activity 

button to refresh the equilibrium 

activity values.

• Check the Use-co-incident spike 

box and then the Calculate 

Appearance button. The window 

shown below appear.  Set values 

as shown.  Then click OK.

• Use 66,000 lbm/hr for letdown 

flow.

Co-incident Spike Illustration

Results
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SNAP/RADTRAD Exercise 

• The next exercise is to model a steam generator tube rupture. A 

description of the accident is presented in the Exercise writeup.
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SNAP/RADTRAD Compartment Removal Models

Natural Deposition

• Two natural deposition models for aerosols in RADTRAD – Powers 

and Henrys in addition to user defined coefficients.  For elemental 

iodine, user must define removal coefficients.

Henry’s Model

• Based upon observation of experiments concerned with aerosol 

decontamination – sedimentation driven model.

• Coefficients were determined from experimental data from liquid metal 

reactor tests.  

• Time-dependent fall height (ft) and particle density (g/cc) needs to be 

specified by the user for aerosols.  For elemental iodine, removal 

coefficients are specified in units of 1/hr.
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SNAP/RADTRAD Compartment Removal Models

Figure 1 - IDCOR Technical Report 11.7 FAI Aerosol Correlation, March 1985

Removal Rate Based on Henry’s Natural Deposition Model 
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SNAP/RADTRAD Compartment Removal Models

Power’s Aerosol Decontamination Model

• Based on the observation of a self-preserving aerosol size distribution 

as a key component in predicting aerosol behavior.  

• Effects due to turbulence and to the multiple aerosol releases specified 

in NUREG-1465.  

• Uncertainties were accounted for by running a large number of 

calculations the modified mechanistic model, with specific values for 

the type of reactor containment, reactor power, and the source term 

release phase, while varying the values of the uncertain parameters.

• Uncertainty parameters included were the containment pressure during 

the various release phases, the floor and wall surface areas, the 

zirconium inventory, the ratio of containment volume to thermal power, 

and the properties of the concrete.  In all, over 20 parameters that were 

related to the phenomena were varied.
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SNAP/RADTRAD Compartment Removal Models

Power’s Aerosol Decontamination Model - Input

User specified the Power’s Model Accident Type from the following 

options:

Power’s Model Percentile - User selects from the following values:

User can specify time dependent elemental iodine removal coefficients 

(units of 1/hr). 

See NUREG/CR-6189 for further details on this model.

PWR-Design Basis Accident BWR-Severe Accident

PWR-Severe Accident APWR-Design Basis Accident

BWR-Design Basis Accident

10% 50% 90%
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SNAP/RADTRAD Compartment Removal Models
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SNAP/RADTRAD Compartment Removal Models

Recirculating Filters:

• Recirculating filters can be modeled in a control room (CR) dose 

compartment.

• Input required is

• Forced flow rate through the filter (cfm)

• Filter efficiencies for aerosols, elemental iodine and organic iodine 

(percent)

Note that an overlying pool model was started in RADTRAD, but never 

completed and is disabled.
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SNAP/RADTRAD Compartment Removal Models

Sprays:

• RADTRAD has the Power’s model for aerosol removal.  For elemental 

and organic iodine, user must define removal coefficients (units of 

1/hr).

• User defined coefficients can also be specified for all forms (units of 

1/hr).

• SRP 6.5.2, Section III.4 provides other approaches for determining 

removal.

Power’s model for aerosol removal:  

• Correlates the removal coefficient for an aerosol to the spray water flux, 

W (m3 H2O/m2 s) and the fall height of the spray droplets H (m).  These 

parameters must be specified by the user.

• Considers uncertainty in the various parameters affecting spray removal.
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SNAP/RADTRAD Compartment Removal Models

Power’s model for aerosol removal – continued:

• User specifies a percentile.  

• Typical spray removal rate:

Further information on the Power’s model can be found in NUREG/CR-

5966

50th percentile Best-estimate (median DF)

10th percentile Lower bound (minimum DF)

90th percentile Upper bound (maximum DF)

α - fraction of containment sprayed. 8.00E-01

Q - spray water flux (m3∙H2O/m2∙s) 2.00E-04
mf - mass fraction of aerosol suspended as a function of 
time. 5.00E-01
H - droplet fall height (m) 25.908

Removal Rate (1/sec)

10 Pct 50 Pct 90 Pct
1.32E-05 4.49E-05 4.21E-04
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SNAP/RADTRAD Flow Pathway Removal Models

Flow Pathways Types –filter pathway,  air leakage, generic with non-iodine 

aerosols:

• Filtered Pathway – in line filter in an HVAC duct.  

• Commonly used in control rooms.

• Air leakage – expressed in %/day.  Used to model leakage from 

containments. 

• Typically ~0.1 %/day for large, dry PWR (listed in SAR, DCD).

• Generic, Generic with non-iodine aerosols

• Variation on filter pathway.

• Piping – Brockman/Bixler model for aerosol deposition or user-defined 

DFs.  



107

SNAP/RADTRAD Flow Pathway Removal Models

• Filtered Pathway

• Time dependent flow rate (cfm) and filter efficiencies (percent) for aerosols 

and elemental and organic iodine

• Filter efficiency is related to decontamination factors as

where η is the filter efficiency expressed as a fraction.

• Air Leakage

• User specifies time-dependent leakage rate in units of percent/day

• Piping – User-specified removal coefficients

• Input required are flow rate through the pipe (cfm) and decontamination 

factors for aerosols, elemental iodine and organic iodine.




1

1
FD
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SNAP/RADTRAD Dose Conversion Factors

• Dose Conversion Factors:

• Built-in dose conversion factors are based on FGR 11&12.  DCF data 

extracted from the Radiological Toolbox developed by NRC.

• At one point, ICRP 60 based DCFs were included, but were removed at the 

request of NRC.

• User-defined dose conversion factors are permitted.

• Many individual organ doses are listed in FGR 11 and 12.  However, in 

SNAP/RADTRAD, the only DCF values used are:

• Whole body (Sv per Bq-s-m-3) – from air submersion tabulations (effective) -

FGR-12 

• Thyroid (Sv/Bq) – from inhalation tabulations (thyroid) – FGR-11

• Inhaled Effective (Sv/Bq) – from inhalation tabulations (effective) – FGR 11

• Skin (Sv per Bq-s-m-3) – from air submersion tabulations (skin) - FGR-12

• TEDE dose is calculated as the sum of the inhaled effective and whole body dose 

in RADTRAD. 
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SNAP/RADTRAD Dose Models

EAB and LPZ – immersion dose from each nuclide n:

DCF/Q)(A = D nc,n
env

nc, 

env

ncD ,
 air immersion (cloudshine) dose due to nuclide n in the environment 

compartment (Sv)  

 

nDCF  FGR 11 and 12 air immersion (cloudshine) dose conversion factor for 

nuclide n (Sv m
3
 / Bq s) 

 

 Q  user-provided atmospheric dilution factor (s/m
3
)  

 

niA ,  integrated release of nuclide n (Bq) 
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SNAP/RADTRAD Dose Models

EAB and LPZ – inhalation dose from each nuclide n

The activity is related to the number of atoms of nuclide n as:

nnn NA  where λn is the radiological decay constant for 

nuclide n.

  nn

env

ni DCFBRQAD ,

env

niDi ,
 inhalation dose commitment due to nuclide n in the environment 

compartment (Sv) 

 

BR  user-provided breathing rate (m
3
 / s) 

 

nDCF  user-provided inhalation dose conversion factor for nuclide n (Sv/Bq) 
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SNAP/RADTRAD Dose Models

Control Room Dose Analysis

• Dose computed from the time-integrated concentration of radionuclides in 

the control room.











t

n

F

ncCR

nc dCOF
G

DCF
D  )(,

,

where:

𝐶𝑛(τ)  is the instantaneous concentration of radionuclide n in the control 

room compartment.  

OF is the control room occupancy factor, which is user defined.  

GF is the Murphy Campe geometric factor, which relates the dose from an 

infinite cloud to the dose from a cloud of volume V (units of 1/m3). 
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SNAP/RADTRAD Dose Models

Murphy-Campe factor is given as:

Inhalation dose to an individual in the control room is:

338.0

6.351

V
GF 


t

n

CR

ni dCDCFOFBRD  )(,
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SNAP/RADTRAD Dose Models

X/Q Data - Values required for each location (usually generated in a separate 

analysis).  Set in the X/Q Tables node in the Navigator Window.

Breathing Rates/Occupancy Factors – default values listed below (from RG 1.183 

and 1.195).  

Offsite Breathing Rates (m3/s)

0-8 hours 3.5x10-4

8-24 hours 1.8x10-4

24 – end of accident 2.3x10-4

Control Room Breathing Rates/Occ Factors

3.5x10-4 m3/s for the duration of the event 

Occupancy Factors Fraction of time present in CR

0 – 24 hours 1

1 – 4 days 0.6

4 to 30 days 0.4
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SNAP/RADTRAD Final Exercise - LOCA

• The final exercise is to model a LOCA.  A description of the 

accident is presented in the Exercise writeup.


