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Objective

The objective of this training is to show participants how to use the
SNAP/RADTRAD code for performing licensing dose analysis for
nuclear power plants.

This presentation focuses on accident dose analysis and the methods
coded into SNAP/RADTRAD and is intended to provide
participants with the background needed to perform dose analysis
using SNAP/RADTRAD.

The training presentation is based on a representative PWR plant
and is intended to provide participants with the background needed
to perform dose analysis for LOCA and non-LOCA accidents using
SNAP/RADTRAD.



Iﬂ-l Purpose of SNAP/RADTRAD

* Purpose of SNAP/RADTRAD is to determine the dose from a
release of radionuclides during a design basis accident to the
following locations:

« Exclusion Area Boundary (EAB)
« Low Population Zone (LPZ)
« Control Room (or Emergency Offsite Facility)

» Focus of SNAP/RADTRAD is dose analysis for licensing
applications to show compliance with nuclear plant siting and
control room dose limits for various LOCA and non-LOCA

accidents.




Iﬂ-l SNAP/RADTRAD Overview

« Symbolic Nuclear Analysis Package — suite of applications that
Interface with nuclear analysis/safety computer codes:
« Developed by Applied Programming Technology, Inc.
« Initial focus was the thermal hydraulics codes (TRACE,
RELAPS)
 Later, other codes added (MELCOR, FRAPTRAN, FRAPCON,

etc.)
e Current version is V2.6.0 as of Nov. 9, 2017

« SNAP provides a standard graphical user interface to simplify the
development of models for the supported analytical codes. SNAP is

used to:
e Construct, maintain and document models

* Run analyses and analyze results




Iﬂ-l SNAP/RADTRAD Overview

« The primary apps in SNAP for RADATRAD analysis are:
« Model Editor — primary interface for developing models.
« Configuration Tool — used to configure SNAP for operation on
a given computer.
 Job Status Tool — used to check job progress and view results,
 Calculation Server — operates in the background and controls
code execution. Allows current jobs on multicore processors.

 SNAP is developed in JAVA and is platform-independent.
« Uses a plug-in architecture.
« (Can be adapted to any engineering code.




Iﬂ SNAP/RADTRAD Overview

« RADTRAD was incorporated into SNAP in two parts:

« RADTRAD plugin to SNAP which, along with the Model Editor interface,
provides the user with the ability to prepare RADTRAD models. This code is
referred to as the RADTRAD plugin and is maintained by APT. The current
version is V4.11.6.

« Aseparate analytical code that actually performs the calculations and
generates the output. This code is maintained by ISL, Inc. The current version

IS V4.5.6.

* Documentation is available on SNAP/RADTRAD and the RADTRAD analytical

code from the RAMP website. Link is:
https://www.usnrc-ramp.com/content/snapradtrad-overview




SNAP/RADTRAD Model Development

« To start the Model Editor, click
on
Start->All Programs->
SNAP->Model Editors

Alternately, you can type Model
Editor in the “Search Programs
and Files” textbox under Start.

* A “splash screen” will
appear with NRC credit,
code version, etc. Then the

i Model Editor opens.




Welcome to ModelEditor 2.6.0
Open a Recent File Create a New Model

No History Create an empty model for an installed plug-in.  Continue ==

Open a Model Document

Open a document saved in a previous session. Continue ==

Import a New Model

Import an existing model into the ModelEditor.  Continue ==

Start an Empty Session

Start the application without an open document. Continue ==

SNAP Version Updates

% Failed to contact update semver.

Show welcome screen at startup

Five options available as shown on
the Welcome Screenshot — typical of
Windows programs

Most of the time, users will create a
new model, open an existing model or
import a existing model from a .psx
file.

There are multiple ways that you can
perform any of the above functions.
Some examples:

 File->New to create a new model

* File->Open to open a previously
saved model

* File->Import to import a model
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SNAP/RADTRAD Model Development

* We’ll start by opening a previously created model Test23. The test23.med
file is found in Samples/Test23. Steps are as follow:

1.
2.

Open the Model Editor as before.

Select Continue under Open a Model Document on the Welcome
Screen. Navigate to the location of the Test23 subdirectory under
the Samples directory.

Click on Test23.med. The Model Editor rendering of Test23 will
open.
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SNAP/RADTRAD Model Development
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SNAP/RADTRAD Model Options

* Model Options node is where various options are available. Includes:

Title/Description
Plant Power Level (MW)
Decay Options:

* no decay,

« decay only,

» decay and daughter production
Onset of Gap Release (hrs) — typically 0.
Start of Accident (hrs) — typically 0.
Duration of Accident (hrs) — typically 720
hrs
Dose Conversion Factors: FGR 11&12 or
User-Specified
Dose Conversions: allows user to view FGR
defaults or specify alternate DCFs.

« Time Step Algorithm:
» Adaptive
» Default
» Default with error calculation.

e Output Parameters
» Dose/Activity Output Units
« Activity/Dose Units (Ci, Rem)
« Si Activity/Dose Units (MBg, mSv)
« Echo Model Definition (T, F)
» Show event results (T, F)
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SNAP/RADTRAD Model Options

* Model Options - continued

* NRC Output: « Diagnostic Flags:

» Dose results listed by nuclide for « Used for debugging
various dose components.

» Formatted output (page layout) to
allow insertion into a Word
document.

» Lines per page can be set as well as
a tolerance for displaying output.
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SNAP/RADTRAD Model Editor

Click on Default View to see model nodalization. Click on Test23View
tab to see the job stream representation.

Click on Lock icon ( & ) to unlock the model. Note the change in the
toolbar.

Click on Expand icon (=) to expand each node in the Model Navigator
Window to see the input fields for SNAP/RADTRAD.

Click on Tools -> Check Model to perform an input check on the model.
Note the message “Note: Model check complete. No errors found” in the
Messages Window at the bottom of the screen.
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SNAP/RADTRAD Model Editor

§= Model Options

A& Nucide Dat * Click on the Expand node icon (= ) next

o @ Sources [1]
¢ [ Compartments [9]

7 1) Compariment 1 Spraied Region to Compartments, then click on

o~ «F Path Connections
o= «F Source Connections
o= [J Compartment 2 (Unsprayed Region) \ COI I lpartl I lent 1.
o= ] Compartment 2 (Annulus)
o= [] Compartment 4 (Environment)

= I Compatimen s Contl Room) * Note that the compartment 1 input

o &7 Pathways 10} ) ) ]
gg_‘l;tffmf:ﬂzzﬁiéﬂm appears in the Properties Window
S @it \To switch units to English, right-click on

o= «fF Connections [26]
E%ﬁfj“f‘m"ﬁm ! the “black bar” in the Navigator

Window, select Engineering Units ->
British to change the units.

[J Compartment 1 (Sprayed Region ] 1 1 1
—Comemeniee e T » Experiment with other input groups —
Sprajed Region ik, approach is the same — we’ll get to
Component Number | 1| [ P . . .

B specifying input later.
Type INormal Raliak;
Output Detail Level || Full Edit at Time Steps Raliak;
volume | 7.758816E4| (m3)| 1 ||
Deposition 4 =none= S:‘ Nl
Filter T <none= S:‘ Vil
Spray = Spray 1 (Sprayed Region Spray) E ™ ?




Iﬂ.l SNAP/RADTRAD Model Development

Compartment Types in RADTRAD that are principally used:

«  Normal compartment:

«  Used to model plant structures (ex containment).

» Radionuclides can be released to the compartment, transferred
to/from other compartments and removed (filtered, sprays, natural
deposition).

» Various removal processes models available for normal (other)
compartments.

«  Control Room Dose compartments:
» Used to model control rooms.
» Control room intake and exhaust is from the environment (release at
intakes is X/Q dependent).
« Can model filtration in control room (both direct and recirculation

filters).
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SNAP/RADTRAD Model Development

* Environment Compartment

« Compartment used to model the Exclusion Area Boundary (EAB) and
Low Population Zone (LPZ) doses.

 Control room HVAC intake draws from the environment compartment.

« Coupling with the EAB and LPZ locations as well as the control room
Intake is through X/Q values.

* Normal dose compartment — used to compute the dose at an arbitrary dose
point (ex. in containment).




SNAP/RADTRAD Model Development
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SNAP/RADTRAD Model Development

» Case execution — depends on the Job Stream. Job streams are used to pass input
and output data from one code to another. Mostly of interest to thermal hydraulic
analysts. A default job stream is automatically set up by the Model Editor for
SNAP/RADTRAD.

» The default job stream for RADTRAD passes input from the Model Editor to the
RADTRAD analytical code. Plot file results are passed from RADTRAD
analytical code output to APTPIot input.

Sample RADTRAD Stream

Test23

RADTRA
2 RADTRAD
AptPlot

1 PlotStep

RADTRAD madel St output [
1 Base_Model NRC-out f =
input “Vinpu log 1.

| plot

stats .=

eeeeeee

SNAP plugin to RADTRAD analytical code
RADTRAD analytical code. to AptPlot.




SNAP/RADTRAD Model Development

£y L
" -
2 magrenet™

— > == E— »  Job stream settings can be checked in the
Name Test23 fme Model Editor. In the case of Test23, expand
;mmm T % Ez the Job Stream node, select Test23 and
RS Fy— e right-click, then select “Check Stream”. A
Piatform [Coca ~]me Error Report window will appear.

RootFolder | NoRoof Polders Available =hd] Common error (for me) is to forget to set the
f;ift :T’:D:":m K\‘\A:@__\ Root Folder, which, in combination with the
ol e v o =9 | —— Relative Location is where the output files
Linear Execution | (3 Yes @ No ™ P are written.

- To set the Root Folder, click on E*. An
— o e Dsm —_— “Edit Calculation Server Root Folders”

Name Testz e window will appear. Click on the New ()
Ztm‘“m e % Ez icon and navigate to the desired location in
FieGrops |0 Groups Elme the “Select Folder Location” window. The
Pratorm [Local Bl Root Folder name will change to the last
RootFolder  [samples  g——[~||E'| 1 folder name in the directory path.

T::f::“m" :::;:: HE: *  Ifyou don’t like that name, click on £, then
TP Pw e ey double click in the Name field, then change
Linear Execution | O Yes ® No Iak) the name as desired. The Root Folder name

will be changed.



SNAP/RADTRAD Model Development
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<> Test23

i

¥ General

[ ] Show Disabled

Name

Test23

hal 1

Description

=nane=

jalk 7

Stream Type

Basic Job Stream

halk 7

File Groups

0 Groups

7

Platform

‘Lucal

[ [m]m]m]

yalk 7

Root Folder

‘Samples

Ll 4

Relative Location

Test23/

«
(=]

Ll 4

Log Level

‘Infﬂrmation

Lal 1

(4]

View in Job Status

® Yes ' No

Ll 4

Linear Execution

) Yes @ No

hal

Error Report
Q P

= 1

| © Notes (1) ||

Q Alerts (0) || /A Warnings ... || © Errors (0)

¢ Stream

7 Test23
Referenced model Test23.med - (unnamed) contains no errors.

Export

/ A€
%’/’M.nnna“"\

Relative location can also be reset. You
should reset this to a name more
nmemonic so you can track your cases.

To change the name, highlight the
Relative Location Name and type in a
new name (EXx. Test23).

Note the / is automatically appended, so
no need to add it.

Run a Job Stream check to determine if
everything is OK. Expand the Job
Stream Node (e= ), then right-click on
the Job Stream Name (Test23) and select
Check Stream. An Error Report window
will appear displaying the error status.
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SNAP/RADTRAD Model Development

* Note that multiple root folders are allowed — handy for organizing
SNAP/RADTRAD case files.

To add a root folder, navigate to Tools->Job Status or click on the Job
Status icon ( @ )and expand Local.

Right-click on Local and select Root Folders.

Click on New icon (left on Toolbar) and navigate to where you want
the root folder (ex. NPP Dose Analysis).

The root folder path will be created.

« A couple of points:

The root folder directory needs to exist — otherwise you’ll get a

warning that the directory doesn’t exist and the root folder will not be
defined.

Overlapping paths are not allowed and will generate an error.
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»  Before we continue, confirm the
link to the analytical code

E hO@T & v HDH ¢

File Edit Help ‘

¢ .- Personal Settings ‘| = General [ 'Sk ad | |
& Platforms [0] E — — = R R
+ B Applications [7] Eé Plotting To@ C\Userswarcieri\AptPlotibin\AptPlot. exe S_ ? | b naVI atl n tO
EACAP :| JEdit Executable waualid [Edit Folder jedit 5|9 y g g
kA AptPiot i -
AptBatch : Matlab Path Matlab is not configured. 4|9 T I C f. - T I
4© Extract Data Use System Look & Feel| () True @ False ? 00 S-> On Iguratlon OO

AVF

o i '
| @ DAKOTA | v CalcuigionSerer

| & R [sontaus smeren 1] (] [8] 0] Sl and then expand the Applications
m@*&g ! node by clicking on the = icon.
s senoromatcaty | @ vos o v Then click on RADTRAD.
i : «  This link is to the RADTRAD
e B adl analytical code.
e — * Note that this location is

File Edit Help inSta“ation'dependent.
(= T & & v D@

¢ L Personal Seftings * General ["] Show Disabled
€9 Platforms [0] i
¢ B Applications [7] [name  [[rRaDTRAD ||?
ACAP | Tyoe 4% RADTRAD ?
AptPlot i
AptBatch “| Description | The Radionuclide Transport and Removal And Dose estimation p...|EY ||
® Bdract Data éi Arguments | = none = F 2
i AvF i =
@ DAKOTA :| Options <none = E'(| %
- ] —
- “| * Application Locations
| Additional Setup | [Nons ~]|®
’ Local Location ‘C'\Users\warcieri\radtraﬂ—ac\ramradjar \ ||E| ?




SNAP/RADTRAD Model Development

) SNAP Job Status 2.6.0 —

] Il DE

O *
File View Tools Help
Job List
" N Local i
© submit Job Stream == ¢ & Training_March_2018_Abu_Dhabi/| -
o B Distributions/ ‘| calcsenviiLocalTraining_March_2018_Abu_DhabiiSamplesTest2 3Test23/
Submit Job Stream o B Exercises/ B
s B Export/ i [Job A Priarity Job Type |Status Submitted |Started Completed|Calc Time |Loaded Evaluation
o Impart/ i| [PlotStep AptPlo omplete 44 44 45: o Data|No
g3 Test23 v B Imp i| |PlotSt 5 AptPlot C let 17:44:59) 17:44:59) 17.45:04] No Data|N
B3 MWiscellaneous/ i| [RADTRAD |5 RADTRAD |Complete 17:44:44) 17:44.44| 174455 MNo Data|No
Submit To Platform B Presentations/ Test23 4 Stream Running 17:44:42) 174442 nfa| Mo Data|No
|L | | | ¢ §& Samples/ B
oca h o B samplet/
9 |8 Test23/
Test23/
0K || Cancel | o B WeDT/
————————————————————————————————————

« Torun the Test23 case, click on Tools -> Submit Job. A Submit Job Stream
window appears.

* Click OK and a confirmatory “Submit Stream” window appears.

* Click OK and the run will start. The SNAP Job Status window will appear. In
this case, the run is completed.




SNAP/RADTRAD Model Development

Sample RADTRAD Stream ) SMAP Job Status 2.6.0 - m] ®

File View Tools Help

(TovTar |

Local :
¢ & Training_March_2018_Abu_Dhabi E
o [ Distributions! :

| caleserv/iLocaliTraining_March_2018_Abu_Dhabi/Samples/Test23/Test23/

RADTRAD o B3 Exercises/ :
2 RADTRAD = Export! i[[Job_a |Priority |JobType |Status Submitted |Started | Completed|Calc Time |Loaded  |Evaluation
= ] ] e etste B Import/ il [PlotStep |5 AptPlot  [Complete | 17:44.50] 17.4450] 17:45.04] NoDataNo
RADTRAD mode| ‘& output = g & Miscellaneous/ | |RADTRAD [5 RADTRAD [Complete | 17:44:44] 17:4444] 17:4455] NoDataNo
1 Base_Model NRC-out > [0 param B Presentations/ 4 |Test23 4 Stream Running AT:44:42| 174442 n/a| Mo DataNo
; log f> - - i
input O input ) ¢ &% Samples/
31 plot RO B e parf- o B Sample/
stats > ¢ |85 Test23/
sereen [ Test23/
o B WGDT/
Test23.med - (unnamed)
lodel Options
& Muclide Data
&
@ Sources [1] ] 1 D

o [ Compartments [5]

o 5 Pathways [10]

o € Dose Locations [3]
o @& Matural Deposition [1]
o Y Filters [4]

& & sprays 1] * Note the relationship between the RADTRAD

o [ wa Tables [3]

T % Sonnectons 2 stream, the Navigator Window and the Job
gy =tm— Status Window.
o= AptPlot 1 (PlotStep)
5 s «  Two Job Stream steps
[ CD)- :;I:J:Selmrjlodes [1]
& b Mumerics [0]
o= = Views [2]
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SNAP/RADTRAD Model Development

Output Review — Click on the RADTRAD Job Type in the Job Status Window, then click on
the File Viewer ((J) icon and then select Text Files. A list of files will appear. Select the
file of interest to open the file in the File Viewer to review the file data (reminiscent of
V3.03)

« Key output files are listed below (there are others as well).

Name Description

radtrad.dfx dose conversion factors file in xml format (input)
radtrad.nix nuclide information file in xml format (input)
radtrad.plt plot file read by AptPlot plotting program (output)
radtrad.psx plant information file in xml format (input)
radtrad_1.icx, initial inventory file for each source (input)
radtrad_2.icx, etc.

radtrad_1.srx, source term file for each source (input)
radtrad_2.icx, etc.

radtrad.out RADTRAD output in original output format (output)
radtradNRC.out RADTRAD output in NRC output format (output)

radtrad.screen RADTRAD screen output file (output)
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SNAP/RADTRAD Output File Description

radtrad.out — original output format in VV3.03/3.10 format. Major sections

are.

Input echo — provides an edited input summary of plant description
(model), scenario (radionuclide source term/DCF) information,
compartment/pathway data, X/Q, etc.

Breakdown of dose results at various time points generally selected
by changes in events (ex. time at which flow rate changes, time at
which X/Q changes). Activity balance information also given.

[-131 Summary, Cumulative Dose Results, Worst Two-Hour Doses
and Final Doses at the end of the file.

Contents can be controlled from Model Options -> Output Parameters
In the Model Editor. Output units in cgs (Rem/Ci) or Sl units (mSv,
MBq) available (under Model Options->Output Parameters).
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SNAP/RADTRAD Output File Description

» radtradNRC.out — provides time-dependent summary of dose by nuclide -

* Input echo — provides an edited input summary of plant description (model),
scenario (radionuclide source term/DCF) information, compartment/pathway
data, X/Q, etc.

« Output — activity distribution, cumulative and dose difference (delta-dose) for
each dose component (inhalation, cloudshine, skin, thyroid, and TEDE).
Output units in cgs (Rem/Ci) or Sl units (mSv, MBq) available (under Model
Options->Output Parameters).

* [-131 Summary, Cumulative Dose Results, Worst Two-Hour Doses and Final
Doses at the end of the file.

« Contents can be controlled from Model Options -> NRC Output Flags in the
Model Editor.

» Note that this file is designed to be imported into a word processor (page
breaks, etc.). Lines/page and output cutoff (so that the file doesn’t get too
large) can be set in the Model Editor.

» radtrad.screen — summarizes time step information.
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SNAP/RADTRAD Model Editor/AptPlot

Note that context of the job stream step affects the output available for
display through the File Viewer.

* Click on Test23 — only the stream log is available for display.

* Click on RADTRAD - all files listed on the previous chart are
available for display. Time step history is displayed in the window.

To display a plot, then click on the File Viewer ([g]) icon, then click on
Plot Files and select “plot — radtrad.plt.” AptPlot will open. Alternately,
click on the (® ) icon and AptPlot will open.

In the Select EXTDATA Channels window, scroll down to desired results
to be plotted. For example, scroll to “ControlRoom.tede.” A plot of the
TEDE dose for the control room will appear.

If you don’t want to scroll, type “ControlRoom.tede” in the Filter text box
and then click on Control.Room.tede at the top of the data channel
window.
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SNAP/RADTRAD Model Editor/AptPlot

Wildcards can be used to identify the results of interest in the Filter text box. EX:
o L*P*Z* - isolates the LPZ dose results for all dose categories.

« L*P*Z*th* - isolates the LPZ dose results for the thyroid dose for all nuclides
and the total dose (LowPopulationZone.thyroid).

* Note that case counts.
Click on the Clear Sets button to clear the plot.

To change the units of the x-axis from seconds to hours, navigate to the Time units
drop-down menu and pick hours.

If you accidently close the “Select EXTDATA Channels” window, navigate to
Window-> Select EXTDATA Channels to reopen the window.

Suppose you want to plot the Control Room dose for all dose categories.
Available dose categories are whole body, cloudshine, skin, TEDE, and thyroid.
Type in the desired result in the Filter window, then pick the result from the
Channels window and finally click on the Plot button to add the data plot.

- C*R*cloudshine — cloudshine dose - C*R* - inhalation
- C*R*skin — skin dose - C*R*tede — TEDE dose
- C*R*thyroid — thyroid dose
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SNAP/RADTRAD Model Editor/AptPlot

Note that as each data set is added to the plot, AptPlot adds it to the Data sets
window (number in brackets are x-y array dimensions).

« (0.S0[2][1664] — control room cloudshine dose

« (G0.S1[2][1664] — control room inhalation dose

« efc.
Double-click on the desired dataset to see the actual data. Note that you can cut
and paste the data into a spreadsheet. You can also export the date, but cut and
paste works better.

Suppose you close the Select EXTDATA Channels window. Navigate to
Window->Select EXTDATA Channels window to reopen.

The plotted data is hard to see and distinguish. Let’s plot all of the control room
dose components as illustrated above and make some changes:
» Navigate to Plot->Set Appearance to change the appearance of each line.

« Main tab — select a data set and then go to Line properties and change the color of
the line to black. Other line-formatting changes are available. Note that the
datasets can be grouped.

« Main tab — select a data set and then a symbol for each dataset under Symbol
Properties (one at a time). Click the Apply button after each selection.
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SNAP/RADTRAD Model Editor/AptPlot

More changes:

Navigate to Plot->Set Appearance to change the appearance of each line.
Click on the symbols tab and then input a value for Symbol skip for each line
— use a value of 100 (need to do them individually). Click Apply after each
selection.

Change the scale of the y-axis to logarithmic to make plots easier to read.
Navigate to Plot->Axis Properties. Change the Edit value from X axisto Y
axis, then change the Scale from Normal to Logarithmic. Then click Apply.

Legend box is a little big — change the font size by navigating to Plot->Graph
appearance.

 Pick the Legends tab and change the font size from 100 to 75 using the
slider. Click on the left or right side of the slider for finer control. Then
click Apply.

« To move the legend box, pick the Leg. Box tab and change the Location
to x=0.75 and y=0.81 or other suitable values.

e Titles and subtitles can be added under the Main tab.



SNAP/RADTRAD Model Editor/AptPlot

File Edit Data Plot View Window Tools Help
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SNAP/RADTRAD Model Editor/AptPlot

« To save plot, navigate to File->Save and select a suitable location to save
the plot. The plot is saved in AptPlot (apf) format.

« Saved plotfile can be used as a template for plotting other datasets —
avoids making many of the formatting settings. Ex. Plot the LPZ dose
results for Test23.

* Open a new AptPlot session from the Model Editor. From the AptPlot
window, navigate to the location of the copied .apf file. Note that the control
room dose results appear.

e Clear the sets from the Select EXTDATS Channels window. Switch Time
units from seconds to hours.

* Plot the LPZ dose results as outlined above.

» Fill in the titles and make other adjustments as desired.

« Save plot under a new filename.

« Can also associate the .apf file type to ApTPlot through Windows.

« Many other features are available in AptPlot.
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SNAP/RADTRAD Model Editor

A useful feature is the Model Notebook feature. This feature generates a
Initial Model Notebook that you can modify.

To generate an initial Model Notebook, right-click on the “black bar” in
the Navigator Window, select Export -> Model Notebook. Click on
Export and provide a filename in the File Name textbox. A notebook is

generated in .docx (Microsoft Word) or .odt (Open Office document)
format

« An odt formatted file can be read and edited using Microsoft Word.

* You can append the Test23NRC.out file to the initial notebook to get
an editable notebook that you can modify as needed.

If you prefer, you can select File -> Export -> Model Notebook to
generate a model notebook.



SNAP/RADTRAD Model Editor

RADTRAD Data are built into the Model Editor
* Dose conversion factors (FGR 11, 12 based on ICRP 30)
« Radionuclide data (ICRP-38)
« Core inventory data (RADTRAD 3.03 for PWR, BWR)
* Release fractions and release timings (Regulatory Guide 1.183)
* lodine chemical form fractions (Regulatory Guide 1.183, 1.195)

Data file export — above data can be exported from SNAP/RADTRAD by
selecting File -> Export -> RADTRAD ASCII and specifying a
CaseName. CaseName is Test23 in this situation.

Import of RADTRAD 3.03 models also available. RADTRAD 3.03 imput
sample from report SAND2008-6601 (Appendix B).
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SNAP/RADTRAD Model Editor

The following files are exported:

Name

Description

CaseName.psx

Plant information file in ASCII (XML) format.
Note that the suffix was added when the export
was done.

CaseName.dfx

Dose conversion factors file in ASCII (XML)
format.

CaseName.nix

Nuclide data file in ASCII format for each source
(x 1s source number).

CaseName_Xx.srx

Release fraction file in ASCII format for each
source (x Is source number).

CaseName_X.icx

Nuclide inventory file in ASCII (XML) format.
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RADTRAD Mathematical Models
(for RADTRAD-AC)

RADTRAD utilizes a multi-compartment model with radionuclide
release to one or more compartments, flow pathways to account for
transfer among compartments, and models for removal within a
compartment.

A key assumption is that the airborne activity in each non-
environment compartment is assumed to be uniformly mixed.

Models for filtration and deposition within a flow pathway can be
specified.

Within a compartment, removal due to decay, natural deposition and
sprays can be modeled.

Daughter product buildup and decay can also be accounted for.
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RADTRAD Governing Equations

For,

where

compartment 1, the rate of change in the number of atoms is:
dNi i i i i i i i i i
FT Ry — Ay Ni + Aj Ny + Ay 3N3 + Aq 4Ny
R: = the source release rate of species 7in compartment 1 in atoms/s
‘1 = the removal rate of species 7within compartment 1 in 1/s
N} = the inventory of species 7in compartment 1 in atoms
"1'2 = the transfer rate of species 7/from compartment 2 to compartment 1 in 1/s
N = the inventory of species /in compartment 2 in atoms
Y3 = the transfer rate of species 7from compartment 3 to compartment 1 in 1/s
N = the inventory of species 7in compartment 3 in atoms
{4 = the transfer rate of species 7from compartment 4 to compartment 1 in 1/s

N = the inventory of species 7in compartment 4 in atoms.
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RADTRAD Governing Equations

where

For compartment 2, a similar equation is used which is:

R}
i
2,2
i
2,1
i
2,3
i
2,4

d_tz = Ry — Ay N+ AL Ni + AL sNi + AL 4N

= the source release rate of species 7/in compartment 2 in atoms/s
= the removal rate of species 7 within compartment 2 in 1/s

= the transfer rate of species 7 from compartment 1 to compartment 2 in 1/s
= the transfer rate of species 7 from compartment 3 to compartment 2 in 1/s
= the transfer rate of species 7 from compartment 4 to compartment 2 in 1/s.
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RADTRAD Governing Equations

More generally, the rate of change in the number of atoms in the
kth compartment in a set of n interconnected compartments is given by

dN" z/v Ni + z A N
7.J 'k k,j

j=1,j#k

Ry is the source release rate of species i in compartment k in atoms/s

The first summation represents the removal terms from compartment
k due either to removal within the compartment or transfer to another
compartment. The second summation represents transfer from
compartment j to compartment k.
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RADTRAD Governing Equations
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A matrix formulation can be used to represent the above equations for n
compartments as follows:
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Off-diagonal terms in the matrix are transfer terms.

« Calculated as f/V where f is the flow rate out of a compartment (vol (or
mass) units/time) and V is the compartment volume (vol (or mass) units),
yielding units of time-L.

« This ratio is multiplied by the radionuclide inventory in the upstream
connecting compartment to provide a source to the connecting
downstream compartment.

* Uniform mixing throughout each volume is assumed.

RADTRAD Governing Equations

Diagonal terms in the matrix are removal terms.

 ldea is the same in that a removal coefficient expressed in units of time-! is
multiplied by the radionuclide inventory to yield a removal rate.
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RADTRAD Governing Equations

« The terms included in the diagonal removal coefficients each have units of 1/sec

and are:
x x x . n
l — L l l l
£y = Yspr  Adep t Ajputer + ) oy Ak
k#j
A},Sp,, = the spray removal coefficient in 1/s
idep = thenatural deposition removal rate in 1/s

]‘-, riter = the filtered removal rated within compartment in 1/s
};) i = the removal rate from compartment j toward compartment k in 1/s.
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RADTRAD Governing Equations

The removal rate is given by the following equation and includes a few
different types of transfer between compartments.

o | fej
l — 1 l 7
kj = Ak jieak ¥ Ak jritter T+ v

J

};} iteax = the transfer via leakage paths in 1/s.

Al ; ruter = the transfer through a filtered path in 1/s.
k. = the flow in m3/s from j to k through a path with a DF.

Vi = the volume of compartment j in m3,
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RADTRAD Governing Equations

Matrix equation solved in RADTRAD using a matrix exponential based on
Lee and Wilson:

« Matrix exponential methods are used to solve systems of linear differential
equations of the form X = AX + S subject to an initial condition X,.

* Note that the coefficient matrix Is invariant within a time interval. As a
result, the initial condition at the start of a given time interval is adjusted
based on the quantity of material in each compartment at the end of the
previous time interval.

Decay is not explicitly included in the matrix equation.

» Decay is accounted for in RADTRAD by dividing the solution of the
differential equations into two parts: (1) radioactive decay and daughter
In-growth, and (2) radionuclide transport.

« Used to overcome the limitations of personal computers available at the
time the original version of RADTRAD was developed and has been
retained to the present time.
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RADTRAD Governing Equations

Radioactive decay and daughter production occur within a compartment, so
no intercompartmental transfer needs to be considered. The governing
equation is:

dN} n-1 ;
dt — zv—l V.Bv NV + Adecay j

BL = the fraction of nuclide v that decays to nuclide i (dimensionless).
A, = the decay rate associated with £, in 1/s.
= the quantity of nuclide v in compartment j.

iiecay = the rate of decay of nuclide i in 1/s.
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RADTRAD Governing Equations

Decay and transport calculations are performed alternately in RADTRAD.

« Code begins its integration over a time step by analyzing the effect of
radioactive decay and daughter in-growth on the inventory of all
compartments.

« Code then calculates the effect of radionuclide transport between
compartments during that same time step.

» Process of alternating between radioactive decay and daughter in-growth
and radionuclide transport continues until the specified end time is
reached.

« Calculations where radioactive decay is not modeled, the solution
algorithm is simplified to the single step of calculating radionuclide
transport.
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RADTRAD Adaptive Time Step

By default RADTRAD uses a predetermined time step size algorithm that
starts at 2 seconds and gradually increases to a maximum of 4 hours after
about 12.5 hours into the simulation. The time step size can be specified
manually as well.

Numerical error is a function of the time step size, and by adjusting the time
step size it was found that the default time step size algorithm resulted in
notable error for some simulations.

An adaptive time step algorithm was added to RADTRAD in order to control
the time step size in order to limit the numerical error.
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RADTRAD Adaptive Time Step Error

The adaptive time stepper uses the following algorithm to calculate error over
a single time step:

« Starting from solution point P take a full time step to get the time step solution S1.

« Starting again from P take two half time steps to get the time step solution S2.

« Calculate the error by dividing

(the difference in the two solutions) by e dosexyrodnst
S1-P| + |S2-P| (the magnitude of the e 2T
change in S1 and S2 over the time step). | Error - e =014 :

|S2-P|+|S1-P|
2.0F i : :

e  The maximum error is 1 and the minimum
error is 0. g

d-15

» To get the percent error in relation to the i |
average of [S1-P| and [S2-P|, multiply the | 2 =7 ||
error by 200. (The plot shows 28% error)

0.0000 0.0005 0.0010 0.0015 00020 0.0025 0.0030 0.0035
Time (s)




ISL

Adaptive Time Step Algorithm

A simple adaptive time stepping algorithm is used:

« A max error limit is specified for the model. If the error over a time step exceeds
the max error, the time step size is cut in half and the time step is repeated.

» If the error is less than max error/10, the time step size is doubled for the next
time step.

This simple algorithm does not always work and in some cases, more complex logic is
used. The adaptive time step algorithm is considered experimental at present since it
has had limited use.

Adaptive time step simulations can take significantly longer to complete. On average
the adaptive time step logic takes about twice as long to perform a solution step and
performs 3 solution steps per time step. For the same number of time steps, it takes 6
times longer on average. In addition, the adaptive time step logic can take many more
time steps in order to limit the error. Notably there are some optimizations that are not
currently implemented that could significantly improve runtime.
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RADTRAD Adaptive Time Step Input

To activate adaptive time stepping, select Model Options. In the properties
dialog set Time Step Algorithm to Adaptive. The maximum error is used to
control the simulation accuracy. A maximum of between 0.001 and 0.0001 is
recommended for most models. A Default with Error Calculation Time
Step Algorithm is also available. This uses the default time step algorithm
but calculates error to determine if the error is acceptable. An error plot
variable is available for examining the error over the simulation.

'-'TU “*TBRoof.med - (TBRoofFinal provided by BF)**
s— Kodel Options -
:fb Nuclide Data
P [ e e T >
I"
5— Model Options H'a
Time Step Algorithm Adaptwe H'a ‘? —
Time Step Table Rows: 0] H'a ‘?
Use Full Time Step ® True . False H'a ?
Plot All Points i) True ® False vl
Max Error m b.oo1|() Ll
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SNAP/RADTRAD Model Building
4 Node Model Demo

Start the Model Editor and click on Create a New Model in the Welcome
screen. Select RATRAD model in the Select Model Type screen.

* You should see the basic model nodes in the Navigator Window.

» If you expand one of the model categories using the (- ) icon, and
click on Compartment 1 (Environment), data fields will appear in the
Properties Window.

To build a model, you need to set up an array of compartments, flow
pathways, source scenarios, and other components and then specify key
parameters in various components in the model.

For sources, compartments, and pathways that ultimately appear in the
View Window, the basic pattern is to expand the node using the (=) icon,
right-click on the component category, and select New. A new model
component is created.




SNAP/RADTRAD Model Building
4 Node Model

o  Ex. Create a new compartment by right-
y O el e < clicking on Compartments, and selecting

el New. A new Compartment component is
" 2 @ bose cocaton 1 Excuson wrea Bouncary created.

o () Dose Location 2 (Low Population Zone)
" ;a“”  Note that the new Compartment is
- O X Taee 2 highlighted and the data for that
"8 i eamar compartment appears in the Properties
Coen Window.

* Note that an Environment compartment is
automatically included in the model.

* Now, add the new Compartment 2 to the View Window by right-clicking on
the new compartment and selecting Add to View -> Default View.
Compartment 2 is added to the View Window. Alternately, the Compartment
2 icon can be dragged to the View window.

« The new component is unnamed. In the Name field in the Properties View,
type in a name (Ex. Comp 1) and the name will appear in the Component 2
node in the View Window.




SNAP/RADTRAD Model Building
4 Node Model

S=R » Add the pre-defined Environment

E— Wodel Uplions ]

& Nucide Dt Compartment to the view as was done
L B Cormpanment Enronment for Compartment 2.

[J compartment 2 (Comp 1)
¢ & Pathways [1]

S P * Define a flow pathway by right-

o= Dose Locations [2] - - -
§ frspmostar cllcklng_on Pathways [0] -> New in

- [ i Taoies 2 the Navigator Window. Pathway 1

o= 4 Connections [4]

& i appears.

o= = \iews [1]

* Add Pathway 1 to the View Window
(Right-click on Pathway 1 -> Add to
View -> Default View).

» Name the flow pathway in the
Properties View window (Ex. FP 1).

« Should now have Comp 1, Environment and FP 1 in the View Window.
» The next step is to connect them.




Iﬂ-l SNAP/RADTRAD Model Building
4 Node Model

00O » Looking at the icons, you will note
q “¥' p \ flow pathway connection points
— indicated by the little circles on each
e edge.
g —— i «  The square on the upper left corner
i of each icon is a source connection
point.
» The connection tool is used to make
C[FT >D connections — activate the connection

tool, then move the connection tool
pointer to the first connection point,
then left-click and drag to the second
connection point. Connection should
Selection Tool / Zoom Tool be made.
Q

Annotation Tool

Connection Tool
Pan Tool
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SNAP/RADTRAD Model Building
4 Node Model

A source component can be added in the same way as the compartment
and flow pathway — right-click on Sources [0] -> New, then add to the
View. Name the source S1.

Connect the Source to Compartment 1 using the connect tool —
“connecting the squares.”

Use the Selection tool to move the icons within the View Window — left-
click and drag.

Note that the EAB and LPZ are automatically included in the Environment
compartment.

Save the model using “Save As” and a suitable filename (I used samplela)
after the connections are made (usual Windows approach).

Sometimes users forget to activate the connection tool and can’t make
connections.

A Connection Tool video and an Initial Noding video is available from the
RAMP website.



SNAP/RADTRAD Model Building

Once you’ve complete the initial noding, save file as “samplela.”
*  Next step — adding data to the various model components.

»  Start with Comp 1 — set the volume to 2.5 x 108 ft3(7.079212x10% m3). Note that default
units are Sl.

 To switch units to English, right-click on the “black bar” in the Navigator Window,
select Engineering Units -> British to change the units.

 Click on the Comp 1 icon in the View window or on the Navigator window and enter
2.5E6 in the Volume textbox.

» Note that deposition, filter, and sprays models are not used. We’ll use those later.

»  For Pathway 1 — expand Pathway node:

( @ Editing Leakage Rate [&f

= Patnway 1 (2 1) B »  Change the pathway type from Piping
¥ General ["] Show Disabled e aak Rate . .
— T 1Y o ity (default) to Air leakage (typically used
Component Mumber | 1| ™ P ?233 g:: for ContainmentS).
Description =none= % ?
From Compartment | L] Compatment2 Comp 1) B » For leakage rate specification, click on
To Compartment [J compariment 1 (Environment) £ ‘? . .
atwayTpe | |NirLeakage Fme the g icon adjacent to the Leakage Rate
Prntoutgeai evel[Noe [|ne row. A data entry table will appear.
Leakage Rate Rows: 0] % ? .
*  Click on the Add button and add a
PRI — leakage rate of 1.0E9 %/day for 0 to 720
| | | _ _
hrs (essentially bypassing the

compartment). Click OK when
completed.
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Complete X/Q tables for the EAB and LPZ — similar approach as for the leakage from

SNAP/RADTRAD Model Building

Compartment 1. Units are sec/m?,

Location 0-2 hr 2-8 hrs 8-24 hrs 1-4 days 4-30 days
(24-96 hrs) : (96-720 hrs)

EAB 1.40E-4 ' 1.40E-4 1.40E-4 1.40E-4 1.40E-4

LPZ 450E-5 | 2.39E-5 1.29E-5 5.49E-6 1.61E-6

« The final item to be completed is the source specification. For this illustration, we
will use the generic PWR core inventory with a power level of 3637 MWth and the
alternative source term release fractions from R.G 1.183.

« Left-click on Model Options in the Navigator Window, locate Plant Power Level
and set the plant power level to 3637 MWith.

« Expand the Sources node and left-click on Source 1 (S1), locate Source
Scenarios and left-click on " .

* In the Edit Inventory Scenarios window, add a new Scenario by clicking on the
New ([3 ) icon under Scenarios in the Edit Inventory Scenarios window that
appears. Pick PWR from the Available Total Inventories. Enter PWR-AST in the
Scenario Name text box.

* In the Accident Parameters tab, pick DBA AST under the Accident Type list and
pick the PWR button under Defaults Type.




SNAP/RADTRAD Model Building

The final item ...
»  Click on the Adjusted Inventory tab and review the inventories listed.

» Click on the Release Fractions and Timings tab and review the release fractions used.
Note the release durations in hours.

» Click on the Source Term tab and review the gap and early releases.
« Change name to PWR Fuel Release in the Scenario Name Textbox.
* Click on OK.

* A Model Check is performed at this point to illustrate how errors are identified (Tools-
>Check Model)

Complete the Source Scenario input:
* Source Term Fraction — 1.0
» lodine Physical Form — NUREG-1465
* Note that the aerosol, elemental, and organic fractions are input (greyed out).

A video illustrating data entry for the 4-node problem is available from the RAMP
website.
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SNAP/RADTRAD Model Building

Probably a good idea to resave the model now.

* Check the model using Tools -> Check Model. Look in
Messages window to confirm that there are no errors.

« Expand Job Stream node in the Navigator window and click
on Simple Stream. Change the Relative Location to
Samplel/Results.

« Perform Job Stream check.
« Go to Tools -> Submit Job to submit job.

 Job Status window will appear with the current run status of
each step of the job stream.

* Video on Job Execution is available from the RAMP website.
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SNAP/RADTRAD Model Building

If you exit the Job Status window from the Model Editor, you can get it
back by clicking on the @ icon on the topmost toolbar (I do this all the
time!)
You can also review your output for cases you have run by expanding the
Job List navigator in the Job Stream window.
* Note that you need to navigate to the stream folder to see the results.
« Clicking on the Base Job will activate the toolbar and you can select
the output you want to examine as before using the File Viewer ((w).
If you forget what an icon means, you can lay the mouse cursor on top of
the icon and a descriptive text box will appear.
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SNAP/RADTRAD Source Term Models

RADTRAD uses a combination of a radionuclide inventory (generally within the
reactor core) and a release fraction model to determine the source term

Two pre-defined inventory files are available by clicking on Nuclide Data in the
Navigator Window, then on the Total Inventories & icon. Available inventory
files are displayed.
*  PWR - normalized MACCS sample 3412 MWth PWR core inventory
(60 nuclides)
« BWR - normalized MACCS sample 3578 MWth BWR core inventory
(60 nuclides)
Note that the plant power level under Model Options needs to be specified in order
to obtain the total core inventory.
The PWR and BWR core inventory files are not editable. However, to make
changes, click on the Copy () icon. This action will make a copy of the selected
inventory file, appending a number after the filename.
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Nuclide Editing Icons

°Edit Total Inventories X
W @ | Name [PwR02 | Delete Nuclide  Import Nuclide File
g;’“vz :ze:a“:zsi | Plant Power 3500.0 MW(1) N N
efaulis 3
PWR 02 | Inventory Units : E @ & @ & EXpOI"t
\ Dmav &@ 7E Nuclide File
: Nuclide Amount (CilMWt) Inventory (Ci) .
|co58 2553 8 935565~ Add Nuclide . . .
[co60 1953 6635565 Move Nuclide Up/Down in List
:|Kr-85 196.0 6.86E5!
|Kr-85m 9181.0 3.21335E7| =
||Kr-87 1.678E4] 5.873E7]
||Kr-88 2.269E4 7.9415E7
:|Rb-86 14.96 5.236E4}—
‘[sr-89 2.844E4 9.954E7
o0 15550 sa7ases The user can also add a new file clicking on the
:[Sr-91 3.656E4 1.2796E8
:[Sr-92 3.805E4] 1.33175E8 H
:[Y-90 1647.0 5.7645E6 Add NEW FI Ie'
:[Y-91 3.465E4 1.21275E8
y-92 3.819E4 1.33665E8
[v-93 432E4 1512E8
:|Zr-95 4.377E4 1.53195E8
:|Zr-97 4.562E4 1.5967E8
:[Nb-95 4.138E4 1.4483E8
:[Mo-99 4.83E4 1.6905E8|—
Display zero values
Close

File Editing Icons

/ Delete Existing File
Add New File

p b T 0 <— Open RCS Activity
Calculator
Copy Existing File
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vy ma Mlﬂ"i’\

"0 Select Nudlides M‘ @ Edit Total Inventories X
Select nuclide(s) ODha o Name [PWR 02 ‘
Gd-153 HL2.00088E7 mass:152.9217 ~] BWR [defaults] e 3500.0 MW
Gd-159 HL6.6816E4 mass 158 9264 PWR [defaults]

Ge-66 HL:8172.0 mass:65.92385 PWR 02 Inventory Units ﬂ
Ge-67 HL:1122.0 massi66.03274
Ge-68 HL:2.48332E7 mass 67.9281 DEav &&
Ge-68 HL1.4058E5 mass:68.92797 = Nuclide Amount (CilIWt) Inventory (Ci)
Ge-T1 HL1.01952E6 mass:70.92495 — H-3 1000 35E6|a
Ge-75 HL:49668 mass74.02286 Co-58 2563 8.9355E5
Ge77 HLA4.06BE4 massT76.92355 Co-60 1953 6.8355E5
Ge-78 HL'52200 mass77 92285 Kr-85 196.0 B.86ES|—
H-3 HL3.894696E8 mass:3.016049 E::g?m 195178ng 32513?35
HE-T0 HL57636E4 massi169.9397 Kros > 26004 + 0415671
HFEAT2 HL5.897232E7 mass:171.9395 RD-86 1495 523664
HFEAT3 HLBBAEL mass:172.9407 Sr-89 2 B44E4 9.954E7,
HF-A75 HL:G.048E6 mass 1749415 Sr-90 1535.0) 5.3725E6
HEATTm HL:2084.0 mass:176.9432 Sr-91 3.656E4 1.2796E8
HEAT8mM HL9.77616E8 mass 177.9437 3’9%2 3:3;5;:; 1:?;:;5:
HEAT9m HL:2 16864E6 mass 1789458 = ol Sarees 15197508
v-92 3.819E4] 1.33665E8
v-93 43264 15128
7r-95 4377E4 15319568
zr-97 4562E4 1.5967E8
NbB-95 4.138E4 1.4483E8|—|
Mann 0000000001 00000 anara 4 @ANSE O b
Display zero values
Close

 Ex. Add H-3to PWR 2 file.
*  Click on Add Nuclide Icon. The Select Nuclides window will appear.
« Scroll to H-3, click on H-3 and then click on OK.

e  H-3 will be added to the bottom of the list. Click on the Move Nuclide icon to move
H-3 to the top of the list. Alternately, click on the nuclide where you want H-3
inserted and it will be added below that nuclide.

*  Provide value for the amount of H-3 (Ci/MWth).




SNAP/RADTRAD Source Term Models

* Note that there are three inventory units that can be used: Ci/MWth, Ci/cc
and Ci/hr.

« Easiest way to build a core inventory file is to either:

1. Define a new file, then develop the radionuclide inventory using the
editing features of SNAP. Note that most SAR documents give core
Inventories in Ci, so you need to define the core power and then the
core inventory. Code will calculate the specific core inventory
(Ci/MWth).

2. Duplicate an existing file and add/delete nuclides as needed, then
update inventories.

* Once the inventory file is completed, it can be exported for subsequent
use.

« Save your sample problem under a new name so that we can model a
waste gas decay tank rupture.
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» Use the following radionuclide data (Waste Gas Decay Tank Source Term):

Nuclide Activity (Ci) Nuclide Activity (Ci)
Kr-85m 1.49E+2 Xe-135 1.02E+3
Kr-85 5.52E+3 Xe-138 4.06E+0
Kr-87 3.00E+1 1-130 0.0
Kr-88 1.79E+2 1-131 3.99E-2
Xe-131m 1.07E+3 1-132 2.50E-2
Xe-133m 1.27E+3 1-133 4.28E-2
Xe-133 8.12E+4 1-134 4.96E-3
Xe-135m 5.97E+1 1-135 1.94E-2

Keystrokes can be used to navigate to a particular group of nuclides. Also, cntl-click to
select individual nuclides and shift-click to select multiple nuclides can also be done.
Also, the release fractions will be changed to user-specified values of 1.0 for NG & I.
Use a 2 hour release time for this exercise. A video illustrating specifying the data for
the WGDT problem is available from the SNAP website.
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SNAP/RADTRAD Source Term Models

Set the location that you want the results written to in the Job Stream
Perform the Model Check. Correct any errors.

Perform the Job Stream Check. Correct any errors.

Run case by submitting the job.

When job completes, review the results.

Results that I got:

SNAP/RADTRAD SNAP/RADTRAD
(TEDE, rem) (thyroid, rem)
EAB (2 hours) 8.11E-2 2.50E-3
LPZ (720 hrs) 2.61E-2 8.05E-4

These are the results for the Waste Gas Decay Tank Case.
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SNAP/RADTRAD Source Term Models

* New release models have been incorporated into SNAP/RADTRAD to model both LOCA
and non-LOCA accidents.

» These release models set the release fractions which applied to an inventory file give the
source term.

«  User-specified release fraction files can be specified.

Accident Type Description

Total Inventory Uses total inventory in conjunction with user-specified release
fractions and timings.

DBA-TID Design basis (LOCA) accident with TID-14844 release models
(RG 1.3, 1.4, instantaneous release).

DBA-AST Design basis (LOCA) accident with Alternative Source Term (AST)
release models based on RG 1.183.

Gap Release Gap release based either on RG 1.25 (RG 1.3/1.4) or RG 1.183.

REA-CRDA Rod Ejection Accident or Control Rod Drop Accident — based on
RG 1.183.

FHA Fuel handling accident parameters based on RG 1.183.
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* Nuclides are grouped according to their chemical and transport properties in
RADTRAD. Grouping is based on NUREG-1465.

No i Group RG 1.183 Chemical Additional Nuclides
Grouping
1 Noble Gases Kr, Xe H (as H-3), Ne, Ar, Rn, N, O
2 Halogens I add Br
3 Alkali Metals Cs, RDb
4 Tellurium Group Te, Sb add Se
5 Barium, Strontium Sr, Ba combine Sr, Ba
(Alkaline Earth Metals)
6 Noble Metals Ru, Rh, Mo, Tc, Co add Pd
7 Cerium Group Ce, Pu, Np
8 Lanthanides La, Zr, Nd, Nb, Pr, add Eu, Pm, Sm
Y, Cm, Am
9 Others Ac, Ag, Al, As, At, Au, Be, Bi, Bk, C, Ca,
Cd, Cf, ClI, Cr, Cu, Dy, Er, Es, F, Fe, Fm, Fr,
Ga, Gd, Ge, Hf, Hg, Ho, In, Ir, K, Lu, Md,
Mg, Mn, Na, Ni, Os, P, Pa, Pb, Po, Pt, Ra,
Re, S, Sc, Si, Sn, Ta, Th, Th, Ti, TI, Tm, U,
V, W, Yb, Zn
10 | Non-Radioactive Aerosols : No change

Notes: Fl and Cl are gaseous halogens. They are included in the other group since they likely do not
behave like iodine.

» Note that the chemical grouping was revised to permit the use of the ICRP-38
nuclides in the source term calculations.
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Release Fractions for LOCA — NUREG-1465 (Tables 3.12 and 3.13), also Tables 1

and 2 of RG 1.183, and RG 1.3, 1.4.

Chemical Elements NUREG-1465 TID-14844
Group
PWR BWR (RG 1.3, 1.4)
Gap Release Early In- Gap Release Early In-
Vessel Vessel
Noble Gases Xe, Kr 0.05 0.95 0.05 0.95 1.0
Halogens I, Br 0.05 0.35 0.05 0.25 0.25
Alkali Metals Cs,Rb 0.05 0.25 0.05 0.20 Note 1
Tellurium Te, Sb, Se 0 0.05 0 0.05
Group
Barium, Ba, Sr 0 0.02 0 0.02
Strontium
Noble Metals Ru, Rh, Pd, Mo, 0 0.0025 0 0.0025
Tc, Co
Cerium Group Ce, Pu, Np 0 0.0005 0 0.0005
Lanthanides La, Zr, Nd, Eu, 0 0.0002 0 0.0002
Nb, Pm, Pr, Sm, Y,
Cm, Am
Release 0.5 1.3 0.5 1.5 instantaneous
Duration
(hours)

Note 1: TID-14844 considered a 0.01 release fraction for the solid mixed fission products (See Table IV of TID-14844).
Note 2: RG 1.183 permits a 30 s delay for the onset of the gap release for PWRs and 2 min delay for BWRs
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» Gap Release model incorporated into SNAP/RADTRAD. Two models provided:

RG 1.25 RG 1.183
1-131 0.12 0.08
Kr-85 0.3 0.1
Other NG 0.1 0.05
Other | 0.1 0.05
Alkali Metals 0.0 0.12

 FHA — fuel handling accident.
« Basically a drop of a lifted fuel assembly onto the core or spent fuel rack.
Models in RADTRAD requires an estimate of the extent of damage, that
Is the number of assemblies or fuel rods damaged. Peaking factors and
iodine DF for the overlying pool needed.
» Release fractions are the same as above.
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* Rod Ejection Accident (REA) for a PWR or Control Rod Drop Accident
(CRDA) for a BWR.

« Basically a control rod is ejected causing a power spike and cladding
rupture. Some fuel melting is possible.

« Models in RADTRAD requires an estimate of the extent of damage,
that is the fraction of clad breached, fraction of breached fuel that
melts, and the peaking factor.

* Release fractions are listed below (Appendix H of RG 1.183).

Failed Fuel Melted Fuel Melted Fuel Release to Reactor
Release Release to Coolant for Secondary System
Fraction Containment Release Pathway

Noble Gases 0.1 1.0 1.0

lodine 0.1 0.25 0.5

Alkali Metals 0.0 0.0 0.0
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 lodine exists in three chemical forms: aerosol (particulate), elemental and
organic iodine. The actual fractions of each form depends on the accident
and analytical assumptions being used.

Accident Model lodine Form

Aerosol | Elemental | Organic

DBA- TID-14844 5 91 4 RG 1.195
LOCA
DBA- RG 1.183 95 4.85 15 RG 1.183
LOCA

« Other scenarios assume other fractions, for example 97% elemental and
3% organic for an SGTR (RG 1.183, Appendix F).
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The first set of exercises are to set up a fuel handling accident (FHA) for a
representative PWR plant and determine the EAB and LPZ dose. As noted
earlier the FHA is basically a drop of a lifted fuel assembly onto the core
or spent fuel rack. Then an normal-mode control room model will be
added to the model.

The rod ejection accident (REA) will be based on the FHA and will be

done by changing the source model and adding components to the control
room for emergency mode operation.

Refer to the SNAP/RADTRAD Training Exercises for directions.
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SNAP/RADTRAD allows user to consider events that involve reactor
coolant system (RCS) activity. Two approaches available:

« User can specify the coolant activity directly and then adjust for pre-
Incident and co-incident iodine spiking.

» User can utilize reactor coolant system activities based on the RN
Editor formulation, and is similar to GALE code formulation and
based on ANSI/ANS 18.1. The original RNEditor was developed by
Steve LaVie almost 20 years ago. Steve works for NRC.

To specify the coolant activity directly, click on Nuclide Data, then click
on Total Inventories (), then on the Add RCS Inventory icon (&2). The
window on the next slide appears (may have some number in the various
fields — can be cleared by clicking on the Reset Button (lower left)).



SNAP/RADTRAD RCS Activity Calculator

o RCS Activity Calculator X
Defaults Type:
OBWR @ PWR Plant Power 3637.0 MW(1)
* RCS Activity Calculator — can be - -
Activity Parameters RCS Activity ?
CaICUIated by the COde or user- RCSMass  [& 38192E5| kg % Nuclide Activity EquilibiumRCS | Spike RCS Total RCS
- g Symbol Cil Inventory (Ci Inventory (Ci Inventory (Ci
SpeC|f|ed_ TSEquiibiumAcivity | 10| uCilgmDEF31 @ KFBmym g wCiigm) 00 mveriory {Ci) o LEL ‘:w ventorp I)nu
TS Equilibrium Activity 280.0| pCilgmDEXe-133 @  [Kr85 367.18475 1.184771EG 0.0 1.184771E6
Kr-85m 001184744 38 226332 0.0 38226332
. . . - - Kr-87 0012092347 39016534 0.0 39.016534
. Use RCS equilibrium activity Kr-88 0.013060158 42139225 0.0 42139225
Can COﬂSlder various EquIlbrlum Use preincident apike g [emm 2.4051274 7760.2584 0.0 7760.2584
e Xe-133 0053460307 172.49224 0.0 172.49224
Activities Level based on the ) | g [etaom 0.082381495 265.80783 0.0 265.80783
. v . Tsspikeact | 600 wCilgmDEF131 Xe-135 0.052417415 169.1273 0.0 169.1273
TeChn|Ca| SpeC|f|Cat|0n ValueS_ Xe-135m 0.091269855 204.48655 0.0 204.48655
[] Use co-incident spike 9 [xe13s 0.04281591 138.14758 0.0 138.14758
131 0027502804 27052795 1.623168E4) 1.650221E4
SToCT - g |32 0.051319889 504.8018 3.028811E4| 3.079291E4
- I 1133 0.054772967 538.76758 3.232605E4| 3.286482E4
« Can also consider pre-incident or 13 Oo7so0s707 TdscaTie  4d7oszael 4ssessres
.. .- o odine Appearance Rate } B EES 0.06307684 620.4476 3.722686E4 3.78473E4)
COIﬂCIdent IOdlne Splklng_ F— — Cs-134 0.027708136 27254768 0.0 272.54768
RIS - £ Cs-136 0.011930389 117.35181 0.0 117.35181
: 9 [cs1ar 057694506 5675.0494 0.0 5675.0434
: Rb-86 0.0 0.0 0.0 0.0
* Values in this window based on
0
66,000 Ib/hr letdown flow (all other
RCS Activity Inputs — PWR set to Calculate Appearance
O) . Table Cell Color Coding:
[ calculated Activity/Appearance Values (editable) || Additional Calculated Values || User Entered Values




SNAP/RADTRAD RCS Activity Calculator

Known values for RCS Coolant Activity in RCSC SO”C
pCi/gm can be used to determine the equilibrium (uCi/g)
concentration. Enter the following parameters in Kr83m | 0.000E+00

o _ Kr-85 7.510E+00
the RCS Activity Calculator screen: wrgem T 1 3708+00

*  Plant Power must be set. Use 3637 MWt Kr-87 8.940E-01
for Plant Power Level in Model Options. Kr-88 2.470E+00
«  RCS Mass in grams — use value of iegém 2'213?82
e- . +

3.819E5 k_g_as shown. | _ VAT R
«  Enter Activity Values listed in the table. Xe-135  6.100E+00
Note the RCS Inventory is calculated by Xe-135m  4.620E-01
SNAP/RADTRAD in Ci. Xe-138  5.700E-01

*  Click on OK —do not click on Calculate
Activities 1-131 7.770E-01
—_— 1-132 8.030E-01
1-133 1.190E+00
1-134 1.730E-01
1-135 6.750E-01

Cs-134 4.820E+00
Cs-136 4,350E+00
Cs-137 2.680E+00
Rb-86 0.000E+00




SNAP/RADTRAD RCS Activity Calculator

RCS Activity Results

© RCS Activity Calculator X
Defaults Type:
(O BWR @ PWR Plant Power 3637.0 MW(t)
Activity Parameters RCS Activity ?
RCSMass [ 3.8192E5 kg % Nuclide Activity RCS Spike RCS Total RCS
~ Symbol (uCilgm) Inventory (Ci) Inventory (Ci) Inventory (Ci)
TS Equilibrium Activity % Kr83m 00 00 00 00
TS Equilibriumn Activit g [K85 751 2868.2192 0.0 2868.2192
Kr-85m 1.37 523.2304 0.0 523.2304
Kr-87 0.894 341.43648 0.0 34143648
[[] Use RCS equilibrium activity ? Kr-88 247 943.3424 0.0 943.3424
- : Xe-131m 281 1073.1952 0.0 1073.1952
Tl Dl ? eam: 231.0  8.822352E4 0.0  8.822352E4
TS soike ad Ciforn DEL131 7 Xe-133m 416 1588.7872 0.0 1588.7872
= SPIKe act plfgm LR Xe-135 6.1 2320712 0.0 2320712
Xe-135m 0.462 176.44704. 0.0 176.44704
[] Use co-incident spike ? Ae-138 0.57 217.6944 0.0 217.6944
131 0777 296.75184 0.0 296.75184
Spike duration hr 9 |32 0.803 306.68176 0.0 306.68176
-133 1.19 454 4848 0.0 454 4848
I-134 0173 66.07216 0.0 66.07216
odine Appearance Rate ? 1-135 0.675 257.796 0.0 257.796
P - Cs-134 4.82) 1840.8544) 0.0 1840.8544
ce Sl | [cs-136 135 1661.352 0.0 1661.352
. Cs-137 268 1023.5456 0.0 1023.5456
— Ro86 0. 0.0 0.0 0.0
0.0
0.0

Calculate Appearance ‘ Calculate Activity

Table Cell Color Coding:
[] calculated Activity/Appearance Values (editable) [_] Additional Calculated Values  [_| User Entered Values

[ox ][ cuen
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SNAP/RADTRAD RCS Activity Calculator

To calculate the equilibrium nuclide

. ; O RCS Activity Calculator X
concentration in the coolant, enter et Ty
the following parameters in the OBiR @ PR Plant Power 3637.0 ()
RCS Activity Calculator screen: Actiy Parameters RCs Actuty ?
RCSMass [&] | 3.8192E5| kg ? Nuclide [ Activity Equilibrium RCS |  Spike RCS Total RCS
) Set Plant POWer Level to . Equ‘l\lnﬁumAcﬁvﬁyl 1,D| SEATEEYE ? Kr-BB:\:rmbol (uCifgm) — Inventory (Ci) — Irl\tenmr\,'(C\;n Invenmry{Cij;n
3637 MWth in Model om0 soumoerena ¢SS | Srems srme o s
. . Kr-87 | 0.012082347 £9.672383 0.0 69.672383
OptlonS (|f not Set). [¥] Use RCS equilibrium acivity P |krss 0.013060158 75.248615 0.0 75.248615
SH—— P — 7 ——
° Use Value Of 38192E5 kg for - ) _— g Xe133m 0.082331495 474 65685 00 47465685
Ll A5 o Xe-135 | 0.052417415 302.01303 0.0 30201303
Xe-135 0.091269855 52586884 0.0 52586884
RCS mass. [] Use co-incident spike ? xZ-ﬂsm | 0.04281501 24660211 0.0 246.69211
1-131 0.027502804 27052795 0.0 27052795
»  Check the Use RCS L= QoserToeer  S376758 oo sarerss
equilibrium activity box. v L — oo sznais
Hucide i Caras Dorioa0ses| g7 a8t D017 35181
H — - S 1 B I .
® Input ValueS Of 1 MC|/gm fOI’ : : Cs-137 0.57694506 5675.0494 0.0 5675.0494
. = Rb-86 0.0 0.0 0.0 0.0
DE 1-131 and 500 pCi/gm o
-135
DE Xe-133 for T/S
Equilibrium Activity.
*  Click on Calculate Activities able Cell Ceor Coding: _ .
d Iue of 66 OOO [[] calculated Activity/Appearance Values (editable) || Additional Calculated Values || User Entered Values
anda use a va .
Ibm/hr for the letdown flow

in the RCS Activity Input
Window. Set all other fields
to 0. Then click OK.

* Results in adjacent
screenshot should appear.




To add the effect of the pre-incident
spike, check the box next to the Use
pre-incident spike label. Technical
Specification spike activity of 60
HCi/gm is typical.

*  To add the effect of the co-incident
spike, check the box next to the Use
co-incident spike label and add the
lodine Appearance Rate as shown
here. A spike duration of 8 hours is
typical.

SNAP/RADTRAD RCS Activity

@ RCs Activity Calculator X
Defaults Type:
OBWR @ PWR Plant Power 3637.0 MW(t)
Activity Parameters RCS Activity 7
RCSMass [&] 3.8192E5| kg ? Nuclide Activity Equilibium RCS| Spike RCS Total RCS
Symbol (uCilgm) Inventory (Ci) Inventory (Ci) Inventory (Ci)
TS Equilibrium Activity 10| WCigmDEM31 9 [ 0.0 o0 o0 o0
TS Equilibrium Activity 500) uCigmDEXe-133 @  |Kr-85 367.19475| 2.115663E6 0.0 2.115663E6
Kr-85m 0.01184744| 68261308 0.0 58261308
Kr-87 0.012092347 69672383 0.0 £9.672383
Use RCS equilibrium activity ? Kr-88 0.013060158 75.248615 0.0, 75.248615
- : Xe-131m 2.4051274) 1.38576E4 0.0 1.38576E4
v
Use pre-indident spike ?  |xe133 0.053460307 308.02185 0.0 308.02185
) ] [Xe-133m 0.082381485| 474 65685 0.0 474 65685
Tsspikeact | 60.00 yCilgmDEH31 e 0.052417415 302.01303 0.0 302.01303
Xe-135m 0.091269855| 525.86884) 0.0] 525.86884
[[] Use co-incident spike ? [xe-138 0.04281591 24669211 0.0 246.69211
1131 0.027502804 27052795 1.623168E4) 1.650221E4
Epi it P |32 0.051319889 5048018 3028811E4) 3.079291E4|
133 0.054772967 538.76758 3.232605E4) 3.286482E4
I-134 0.075906707 746.63718 4.479823E4) 4.554487E4|
lodine Appearance Rate ? |35 0.06307684] 620.4476 3.722686E4 3.78473E4
: = Cs-134 0.027708136 27254768 0.0| 27254768
e S Cs-136 0.011930389 117.35181 0.0 11735181
5N Cs-137 0.57694506 5675.0494 0.0 5675.0494
:',f Rb-36 0.0 0.0 0.0 0.0
13
135
Calculate Appearance Calculate Activity
Table Cell Color Coding:
|:| Calculated Activity/Appearance Values (editable) [:I Additional Calculated Values |:| User Entered Values

Reset

OK Cancel




SNAP/RADTRAD RCS Activity

@y ot * « Calculating RCS coolant activity
RCS letdown flow rate - purification (FD \ 3‘7E4\ lomihr (FD
RCScauondemlnerallzerﬂowrate([FA)) \ 3700.0/ Iomian(FAi : based On ANSI/ANS 18'1 for the
S | e PWR requires additional information

to determine the effect of letdown
RCS cation demineralizer removal fraction (NA) : 0'0: 0.9 : and boron reCOVery System (BRS).
RCS purification demineralizer removal fraction (NE) 0.99] 05 .

Default input shown.
@ Res Activiy Inputs - BWR «| * Calculating RCS coolant activity
Steam flow rate (FS) | ‘1.5E?| lbmmr  F based on ANSI/ANS 18'1 for the
Cleanup demineralizer flow rate (FA) | 1365 bmmr P BWR also requires additional
Condensate demineralizer flow rate | 1567 lbmmr  F Informatlon to |nclude the effect Of
lodines Cs&RY RWCU and condensate

Ratio of concentration in reactor steam to water (NS) | 0.02] | 1.0E-3] 9 . .
Reactor cleanup system demineralizer fraction (MA) | U.Q| | 0.5| 2 demlnerallzers AISO nOte that
Condensate demineralizer removal fraction (NB) | [].Q| | [J.5| ? Separate Ca|CU|at|0nS are performed
Caleiteaciviynseam i © Seamagvy  Olqudacwty 9 for steam and liquid activity. Default
| input shown.




SNAP/RADTRAD RCS Activity

Co-incident Spike Illustration
*  Use the RCS mass and T/S

Equilibrium Activities shown. @ RS Actvity Caluotor x
Click on the Calculate Activity Defauits Type:
T OBWR @ PWR Plant Power 3637.0 MW(t)
button to refresh the equilibrium
T Activi RCS Activity
activity values. Lo Pe— ?
RCSMass (2] = 3819265 kg ? Nuclide Activity EquilibiumRCS|  Spike RCS Total RCS
° CheCk the U Se'CO' i nC i dent Spi ke TS Equilibrium Activity *71@ LCilgm DE 131 ? TR ymbol (uCilgm) . Inventory (Ci) 5 Inventory (CI)U_O Inventory (Cl)o_o
s B o o K@) 367.19475|  2.115663E6) 0.0 2115663E6
box an d the n the Calcu |ate 5 EQunum Aty SSECHImRERE S B oo 0.01184744 68.261308 0.0 58.261308
s Kr-87 0.012092347] 69.672383 0.0 59.672383
. [¥] Use RCS equm Kr-88 0.013060158 75248615 0.0 75248815
Appearance button. The window £ - e 13im 2avst2rd 1 3e50Ed 00 138570t4
L 2 ? e 0.053460307 308.02185| 0.0 308.02185
o ) Xe-133m 0.082381495 47465685 0.0 474.65685
shown below appear. Set values s spike’ S— v Dot senees oL ssens
. Xe-135m 0.091269855 52586884 0.0 52586884
as shown. Then click OK. ] Use co-incident spike 9 |xe13s 0.04281591 246.69211 0.0 246.60211
1131 0.027502804] 27052795 6.368908E4|  6.39596E4
on [ 80 1132 0.051319889 504.8018| 521693E5  5.221978E5
® Use 66 ) 000 Ibm/hr for letdown Spikeduration |80/ fr U = 0.054772967 53876758  1.697698E5  1.703086E5
1134 | 0.075905707, 746.63718 1750706E6] _ 1.751453E6
flow lodine Appearance Rate ? |93 0.06307684| 6204476]  3.144643E5|  3.150848E5
. Cs-134 0.027708136| 272.54768| 0.0 27254768
Lol 2L | [cs138 0.011930389 117.35181 0.0 117.35181
F131 7961.1345|  [5537 057694506 5675.0494 0.0 5675.0494
H132 65211634 |25 g5 0.0 0.0 0.0 0.0
133 2122122E4| - .
134 2188383E5
- S 1135 3.930804E4
@ Calculate Iodine Appearance | = | /
Marmal letdown flow rate 1320/ apm ‘?
Table Cell Color Coding:
RCS TIS leakage 11.0] agpm ? Iculated Activity Values (edi [] Additional C values [ ] Yder Entered Values
Mixed bed demin DF 100.0 7 (
? \

Spike multiplier 335.0 \/ /

Results

| OK H Cancel |
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SNAP/RADTRAD Exercise

« The next exercise Is to model a steam generator tube rupture. A
description of the accident is presented in the Exercise writeup.




Iﬂ.l SNAP/RADTRAD Compartment Removal Models

Natural Deposition

«  Two natural deposition models for aerosols in RADTRAD — Powers
and Henrys in addition to user defined coefficients. For elemental
iodine, user must define removal coefficients.

Henry’s Model

« Based upon observation of experiments concerned with aerosol
decontamination — sedimentation driven model.

» Coefficients were determined from experimental data from liquid metal
reactor tests.

« Time-dependent fall height (ft) and particle density (g/cc) needs to be
specified by the user for aerosols. For elemental iodine, removal
coefficients are specified in units of 1/hr.
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SNAP/RADTRAD Compartment Removal Models

Removal Rate Based on Henry’s Natural Deposition Model

52
10 ! g T T T

Removal Rate, sec-!

104 103 1072 0™ 100 10! 102

Particle Concemrotion,g/m3

Figure 1 - IDCOR Technical Report 11.7 FAI Aerosol Correlation, March 1985




Iﬂ-l SNAP/RADTRAD Compartment Removal Models

Power’s Aerosol Decontamination Model

« Based on the observation of a self-preserving aerosol size distribution
as a key component in predicting aerosol behavior.

«  Effects due to turbulence and to the multiple aerosol releases specified
in NUREG-1465.

«  Uncertainties were accounted for by running a large number of
calculations the modified mechanistic model, with specific values for
the type of reactor containment, reactor power, and the source term
release phase, while varying the values of the uncertain parameters.

*  Uncertainty parameters included were the containment pressure during
the various release phases, the floor and wall surface areas, the
zirconium inventory, the ratio of containment volume to thermal power,
and the properties of the concrete. In all, over 20 parameters that were
related to the phenomena were varied.
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SNAP/RADTRAD Compartment Removal Models

Power’s Aerosol Decontamination Model - Input

User specified the Power’s Model Accident Type from the following
options:

PWR Design Basis Accident

BWR Design Basis Accident

APWR Design Basis Accident

Power’s Model Percentile - User selects from the following values:
10% 50% 90%

User can specify time dependent elemental iodine removal coefficients
(units of 1/hr).

See NUREG/CR-6189 for further details on this model.




ISL

SNAP/RADTRAD Compartment Removal Models

Removal Rate Based on Power’s Natural Deposition Model
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Recirculating Filters:

SNAP/RADTRAD Compartment Removal Models &

« Recirculating filters can be modeled in a control room (CR) dose
compartment.

* Input required is
« Forced flow rate through the filter (cfm)

 Filter efficiencies for aerosols, elemental iodine and organic iodine
(percent)

Note that an overlying pool model was started in the original version of
RADTRAD, but never completed and is disabled.




Iﬂ.l SNAP/RADTRAD Compartment Removal Models

Sprays:

e RADTRAD has the Power’s model for acrosol removal. For elemental
and organic iodine, user must define removal coefficients (units of

1/hr).

«  User defined coefficients can also be specified for all forms (units of
1/hr).

« SRP6.5.2, Section I11.4 provides other approaches for determining
removal.

Power’s model for aerosol removal:

« Correlates the removal coefficient for an aerosol to the spray water flux,
W (m3 H,0/m? s) and the fall height of the spray droplets H (m). These
parameters must be specified by the user.

« Considers uncertainty in the various parameters affecting spray removal.
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SNAP/RADTRAD Compartment Removal Models

Power’s model for aecrosol removal — continued:

» User specifies a percentile.

50t percentile Best-estimate (median DF)
10" percentile Lower bound (minimum DF)
90t percentile Upper bound (maximum DF)

« Typical spray removal rate:

a - fraction of containment sprayed. 8.00E-01 Removal Rate (1/sec)

Q - spray water flux (m3-H20/m2:s) 2.00E-04

m, - mass fraction of aerosol suspended as a function of 10Pct  50Pct 90 Pct
time. 5.00E-01 1.32E-05 4.49E-05 4.21E-04
H - droplet fall height (m) 25.908

Further information on the Power’s model can be found in NUREG/CR-
5966



Iﬂ.l SNAP/RADTRAD Flow Pathway Removal Models

Flow Pathways Types —filter pathway, air leakage, generic with non-iodine
aerosols:
 Filtered Pathway — in line filter in an HVAC duct.
e Commonly used in control rooms.
« Air leakage — expressed in %/day. Used to model leakage from
containments.
« Typically ~0.1 %/day for large, dry PWR (listed in SAR, DCD).
« Generic, Generic with non-iodine aerosols
 Variation on filter pathway.
* Piping — Brockman/Bixler model for aerosol deposition or user-defined
DFs.
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* Filtered Pathway

« Time dependent flow rate (cfm) and filter efficiencies (percent) for aerosols
and elemental and organic iodine

 Filter efficiency is related to decontamination factors as

SNAP/RADTRAD Flow Pathway Removal Models

1

DF =—
1-n

where 1 is the filter efficiency expressed as a fraction.

» Air Leakage
» User specifies time-dependent leakage rate in units of percent/day
» Piping — User-specified removal coefficients

» Input required are flow rate through the pipe (cfm) and decontamination
factors for aerosols, elemental iodine and organic iodine.
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SNAP/RADTRAD Dose Conversion Factors

Dose Conversion Factors:

e Built-in dose conversion factors are based on FGR 11&12. DCF data
extracted from the Radiological Toolbox developed by NRC.

« Atone point, ICRP 60 based DCFs were included, but were removed at the
request of NRC.

« User-defined dose conversion factors are permitted.

« Many individual organ doses are listed in FGR 11 and 12. However, in
SNAP/RADTRAD, the only DCF values used are:

« Whole body (Sv per Bg-s-m-3) — from air submersion tabulations (effective) -
FGR-12

« Thyroid (Sv/Bq) — from inhalation tabulations (thyroid) - FGR-11
» Inhaled Effective (Sv/Bq) — from inhalation tabulations (effective) - FGR 11
« Skin (Sv per Bg-s-m3) — from air submersion tabulations (skin) - FGR-12

« TEDE dose is calculated as the sum of the inhaled effective and whole body dose
in RADTRAD.
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SNAP/RADTRAD Dose Models

EAB and LPZ — immersion dose from each nuclide n:
on = An( Q) DCF

D& = air immersion (cloudshine) dose due to nuclide n in the environment
compartment (Sv)

DCF, = FGR 11 and 12 air immersion (cloudshine) dose conversion factor for
nuclide n (Sv m®/ Bq s)

X/Q= user-provided atmospheric dilution factor (s/m°)

A, = integrated release of nuclide n (Bq)
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SNAP/RADTRAD Dose Models

The activity is related to the number of atoms of nuclide n as:

A =AN_ where %, is the radiological decay constant for
nuclide n.

EAB and LPZ — inhalation dose from each nuclide n
D' = A, (X/Q)BR * DCF,

DIt = inhalation dose commitment due to nuclide n in the environment
compartment (Sv)

BR = user-provided breathing rate (m*/ s)

DCF, = user-provided inhalation dose conversion factor for nuclide n (Sv/Bq)
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Control Room Dose Analysis

« Dose computed from the time-integrated concentration of radionuclides in
the control room.

SNAP/RADTRAD Dose Models

c,n —

DCF
DCR—( c C’”jOF j C.(r)dr
t

F

where:

C,(t) Is the instantaneous concentration of radionuclide n in the control
room compartment.

OF is the control room occupancy factor, which is user defined.

Ge Is the Murphy Campe geometric factor, which relates the dose from an
infinite cloud to the dose from a cloud of volume V (units of 1/m3).
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SNAP/RADTRAD Dose Models

Murphy-Campe factor is given as:

G, - 35L6

" \70.338
V

Inhalation dose to an individual in the control room is:

DY = BR-OF - DCF [ C,(z)dz
t
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X/Q Data - Values required for each location (usually generated in a separate
analysis). Set in the X/Q Tables node in the Navigator Window.

Breathing Rates/Occupancy Factors — default values listed below (from RG 1.183

and 1.195).
Offsite Breathing Rates (m?3/s) Control Room Breathing Rates/Occ Factors
0-8 hours 3.5x10* 3.5x10* m3/s for the duration of the event
8-24 hours 1.8x104 Occupancy Factors | Fraction of time present in CR
24 — end of accident | 2.3x10* 0-—24 hours 1
1 -4 days 0.6
4 to 30 days 0.4
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SNAP/RADTRAD Final Exercise - LOCA

« The final exercise is to model a LOCA. A description of the
accident is presented in the Exercise writeup.
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SNAP/RADTRAD Installation

 SNAP - obtained from the Applied Programming Technology website at:
https://www.snaphome.com/

https://www.appliedprog.com/ 9 A PT

* Files needed to run SNAP/RADTRAD:

« Java Standard Edition (SE) 7.0 or later. This package is currently available on
http://www.oracle.com/technetwork/java/javase/downloads/index.html.

«  SNAP/RADTRAD plugin — distributed with SNAP during the download progress from
the APT site.

« APTPlot — plotting package. See APT website (addresses above).

« jedit — although not required, jedit adds some user conveniences in SNAP. This
package is available from www.jedit.org.

« RADTRAD analytical code packaged separately, available through the RAMP
website for registered users.



https://www.snaphome.com/
https://www.appliedprog.com/
http://www.oracle.com/technetwork/java/javase/downloads/index.html
http://www.jedit.org/
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SNAP/RADTRAD Installation

Installation begins with downloading
the snapinstaller.jar file from the APT
website to a convenient directory. Once
that file is downloaded, click on the
Snaplnstaller.jar file to start the
installation.

« Alternately, you can navigate to the
directory where the Snaplnstaller.jar
file is located and enter:

java —jar Snaplnstaller.jar
« There are three installation options

|£ | SNAP Installation Options - x

Please select your installation method:

Install or Update Directly from the
Internet

(Recommended for most users.)

OR

Download Installation Packages to a
Local Folder

Note: This option does not install the software.

Install or Update from a Local Folder

Run after downloading the packages to a local folder.

available as shown in the adjacent -
ScreenShOt APT Installer (2.8.0) Copyright @ 2001-2015, All rights reserved.

* Installing from the internet is the
easiest. | prefer to download the
installation packages to a local directory
and then perform the installation.




SNAP/RADTRAD Installation

L ~ O
« Initial installer screen
analyzes installation and —
checks for pre-existing
plugins.

* Plugin Manager allows the
user to select plugins to be

installed or updated. |/ Plugin Manager %

«  Select the plugins reqm eeleEel) , R L
Package Status Available

and continue. Installation L 231

should proceed to Hroraes s

completion. e -
* Plug-ins required for

SNAP/RADTRAD are AVF,

ENGTMPL’ EXTDATA’ Select Available || Select Updates | Deselect Al Continue

RADTRAD and Uncertainty.
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SNAP/RADTRAD Installation

« The SNAP Installation is written to the /users/homedir where homedir is
the home directory for the login ID being used unless you specified a
different location.

« If you are not sure of where you home directory is, open a command
window by going to Start and typing in “command” in the Search
textbox. A command prompt window should appear (select
“Command Prompt” from menu above if necessary). Then, type in
echo %USERPROFILE% and your home directory will be
displayed.

» The SNAP installer creates two directories: snap and .snap under
/users/nomedir. The code files are written to snap and files needed to use
SNAP on a given system are written to .snap.

» EXx: the location of the root folder on a given computer is written to
.shap.
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SNAP/RADTRAD Installation

Once the SNAP/RADTRAD package is installed, the RADTRAD
analytical code is installed.

« RADTRAD analytical code files are listed below:

radtrad.jar castor-xml.jar
castor-codegen.jar castor-xml-schema.jar
castor-core.jar commons-logging.jar

« Basically, the user copies these files to a suitable directory and sets a link to
the radtrad.jar file using the SNAP Configuration Tool.

* Most users create a “radtrad” subdirectory in the /users/homedir/snap
subdirectory and copy the files to that location. Then, the user opens the
configuration tool and sets the path to the radtrad.jar file:

${SNAPINSTALL }radtrad/radtrad.jar

» Alternately, the user can copy the files to any location and set the path
appropriately in the Configuration Tool.
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SNAP/RADTRAD Installation

To start the Configuration Tool, enter
Start->AllPrograms->Snap->Configuration Tool

.
NAP Configuration ll“ | =RHC] PS

File Edit Help

E hE @ & & v 9D

Click here to show the available
applications.

9 M Personal Settings ‘| v General ["] Show Disabled
& Platforms [0] :
™ ¢ B Applications [9] [ name [RADTRAD ||P
ACAP | Type £3 RADTRAD 7
AptPlat : r—
AptBatch :| Desciription | The Radienuclide Transport and Removal and Dose estimation ... |EY| ?
*® Ediract Data Arguments | = none = (g ?
Lk AVF =
B DAKOTA il Options  [=none = |9
._ KEffective ¥ Application Locations
@ Python :
“* RADTRAD | aqditional Setup |N0ne |v| ?
/| Local Location {[$(SNAPINSTALLjvadtradvradirad4_5_2vadtrags_5_2jar ||V P

—

——

Type the location path here
or

click here to navigate to the

radtrad.jar file location

9 (select tool).




&

AptPlot Installation NS £

4 AN
M maperensr©

» AptPlot Installation — same idea as SNAP.

« Download the AptPlotinstaller.jar file and then either install from the
internet or from a local directory.

— X |£:| Plugin Manager b4

@ Initializing AptPlot Installation

o AnaInyng Installan.on NewapdahesB) Please select the packages to be

e Preparing Installation

@ Checking File Permissions Package Status Available installed from the list on the left.

9 Unpacking Files I:‘ ACS Plug-in 2.1.2

& Installing Files I:‘ PyPost 1.2.2

9 Generating Launchers. [] PyPostTestSuite L2

e Generating Menu Entries.
Il Checking for Plugins

Select Available Select Updates Deselect Al Continue
APT Installer (3.0.1) Copyright © 2001-2015, Applied Programming Technology Inc., All rights reserve d.




